delete messages from server when deleted locally should work immediately

RESOLVED WONTFIX

Status

MailNews Core
Networking: POP
--
minor
RESOLVED WONTFIX
16 years ago
3 months ago

People

(Reporter: Shane Kemp, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
See bug 33943, supposed to be FIXED back in 2000.  Still not working as far as I
can tell.
(Assignee)

Comment 1

16 years ago
Did you do GetMsg() after deleting the msg locally, that will delete it on the
server. 

Comment 2

16 years ago
*** Bug 160998 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
I've been seeing this from back around 0.9.5 (??) right through to 1.1.  I'm not
sure if it ALWAYS happens, or only sometimes, but it certainly does happen. I
only notice it because I occasionally do sanity checks on my pop accounts with a
thin pop client.

FWIW, I see it with both sendmail and qmail.
(Reporter)

Comment 4

16 years ago
Seems to delete messages if you do a getmsg after deleting messages locally, but
that doesn't seem like a true solution - more of a work around.

Comment 5

15 years ago
*** Bug 229765 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
Updating and confirming bug.

To reproduce:
1) Set server for 
  [x] Leave messages on server
    [x] Until I delete or move them from Inbox
2) Retrieve new messages
3) Delete one or more
4) Check (however you can do this) whether messages are still on server
5) Get New Messages on server
6) Check again whether messages are still on server

Actual results: Message(s) not deleted from server until after step 5.
Expected results: Message(s) deleted when the Delete takes place

I reproduced these results using 
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040324

I have shell access to the system that runs the mail server and used fetchmail 
to confirm whether the messages had been deleted.

I think that most POP mail accounts are set up to check mail regularly, so the 
actual server deletion occurs automatically, if not immediately.  At any rate, 
using Get New Messages is a workaround, so this is a minor bug (maybe even an 
enhancement).

Note that the mechanism for performing this deletion is to maintain a list of 
kept-on-server messages in popstate.dat; when a message is deleted by the user, 
its entry in that file is marked; and then at the next POP update, those marked 
messages are deleted.  This keeps the traffic to a manageable level.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: delete messages from server when deleted locally still doesn't work → delete messages from server when deleted locally should work immediately

Comment 7

14 years ago
Immediate deletion would make it necessary to connect to the server, log in,
delete and disconnect. You want this for each message?
POP isn't made for this type of use. I could live with the proposal of bug
239133. And we could modify the help and the UI to make it more clear, another
server connect is needed to sync the local delete. But I'm very opposed to
immediate sync.

Comment 8

14 years ago
Christian, no, I wasn't implying that it should be fixed.  Mostly I'm trying to 
close out several apparent dupes; this bug appears to be the earliest, and the 
behavior described does in fact exist.

I won't mind if this is WONTFIX'd, just so we have a reference bug to dupe the 
complaint to.
*** Bug 231543 has been marked as a duplicate of this bug. ***
I like the when exited idea, but I also believe that at timed intervals (1
minute?) that we should reconnect to the POP server to remove messages IF there
are existing messages to remove.

We also need to make sure that when mailnews crashes (god forbid!) or the system
crashes (god forbid!) before its gotten a chance to delete from the server, that
they'll be deleted upon restart. Otherwise, they'll be a pile of messages
building up on the server that SHOULD have been deleted (and it'd be a matter of
time before people complained and filed a bug). That means there should probably
be some hidden "deleted" folder or data structure that queues messages for deletion.

Comment 11

14 years ago
Brian, as Mike already stated in comment #6, we keep the state of the messages
in the popstate.dat. There's no need of any hidden folder or other things to be
introduced.

Comment 12

14 years ago
*** Bug 227340 has been marked as a duplicate of this bug. ***
So if it crashes, and you re-open the mail client and close it, they will then
be deleted?

Comment 14

14 years ago
i use thunderbird 0.8 on my notebook and my pc. on the notebook i have checked
the "delete message on server when deleted locally or moved from inbox". but
this feature doesn't work. on the notebook i get all the deleted mails again and
again. on the pc i get them to - there i have set "automatically delete from
server".

there is a small problem with delete from server, as thunderbird needs another
connect to the inbox to perform the delete. with only a modem dial-up i maybe
don't want thunderbird to this automatically. it should do this when i hit "get
messages", it first performs the delete and then gets the other new mails.
in this case a small icon in the statusbar could indicate that there are mails
to be deleteted...

markus
Product: MailNews → Core

Comment 15

10 years ago
wontfix is suggested in comment 8 - does this make sense?

Comment 16

10 years ago
I think so.
->WONTFIX
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Product: Core → MailNews Core

Updated

3 months ago
See Also: → bug 185791
You need to log in before you can comment on or make changes to this bug.