Closed Bug 1546984 Opened 7 months ago Closed 2 months ago

[about:addons] Remember scroll offsets when switching views

Categories

(Toolkit :: Add-ons Manager, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox68 --- unaffected
firefox69 --- wontfix
firefox70 + verified
firefox71 --- verified

People

(Reporter: robwu, Assigned: robwu)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When the user switches views, the previous scroll offset is forgotten and the top of the view is shown, instead of the location where the user left off.

This can result in a confusing experience when the user switches away from a long list of add-ons (e.g. at the discopane or extension list) and then back.

The forgetful behavior is already existing in the extension/theme/plugin list in the old about:addons page, but not in the discopane because that was a separate <browser>. But once bug 1546248 is fixed, the new discopane will also be affected by this bug (it could be seen as a regression).

Assignee: nobody → rob
Status: NEW → ASSIGNED
Priority: -- → P1

This is a nice-to-have, so I'll move this to phase 2.

Blocks: 1556776
No longer blocks: 1533795
Priority: P1 → P2
Duplicate of this bug: 1559507
Duplicate of this bug: 1562451
Duplicate of this bug: 1569409

Rob, since this has some duplicates, seems like people notice it, can this get back on your radar for 71 or possibly even 70? Thanks!

Flags: needinfo?(rob)

Done. Took a bit longer because I had to debug some odd test failures.

The patch is relatively simple (and also fixes another issue, namely that when one switches from a long list to a different (new) long list, that the top of the page is shown instead of an arbitrary location. I wouldn't be against putting this polish into 70 via an uplift.

Flags: needinfo?(rob)
  • Remember scroll offsets for certain views in about:addons.

  • For other views, start at the top of the page, regardless of the
    scroll position of the (likely unrelated) previous view.

Duplicate of this bug: 1580151

Thank you! Is this ready to land? Can you land it and then request uplift to beta?

Flags: needinfo?(rob)

It's pending review. I expect it to land this week, and otherwise no later than next week.

Flags: needinfo?(rob)
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/5d38d3937cac
Add scroll restoration to about:addons r=mstriemer
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Comment on attachment 9090698 [details]
Bug 1546984 - Add scroll restoration to about:addons

Beta/Release Uplift Approval Request

  • User impact if declined: When the user navigates to a different tab at about:addons, the previous scroll offset may be shown instead of the expected top of the page. This is a regression from enabling the HTML about:addons in version 68.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small UI-only change, covered by unit tests.
  • String changes made/needed: none
Attachment #9090698 - Flags: approval-mozilla-beta?

Comment on attachment 9090698 [details]
Bug 1546984 - Add scroll restoration to about:addons

Fix for regression from 68, let's uplift for beta 7.

Attachment #9090698 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hello,

Verified the fix using the latest Nightly (71.0a1/20190915214245) under Windows 10 Pro 64-bit and macOS High Sierra 10.13.6.

Switching between the different tabs from about:addons, will always show the top of the page regardless of the previous tab scroll offset, confirming the fix.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]

Hello,

Verified the fix using the latest Beta (70.0b7/20190916074538) under Windows 10 Pro 64-bit and macOS High Sierra 10.13.6.

Switching between the different tabs from about:addons, will always show the top of the page regardless of the previous tab scroll offset, confirming the fix.

You need to log in before you can comment on or make changes to this bug.