Closed Bug 1547558 Opened 5 months ago Closed 4 months ago

HTML about:addons details view is unreadable in dark mode

Categories

(Firefox :: Theme, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1551202

People

(Reporter: ntim, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

Attachments

(1 file)

I've just done some work to fix this in bug 1544111, but looks like this regressed again with bug 1535683.

Here's something I quickly whipped up using the "Changes" DevTool:

 .addon-detail-row {
-  border-top: 1px solid var(--grey-90-a20);
-  color: var(--grey-90);
+  border-top: 1px solid var(--in-content-border-color);
 }
 .addon-detail-row-help {
-  color: var(--grey-60);
+  color: var(--in-content-deemphasized-text);
 }
 .addon-detail-rating-star {
+  -moz-context-properties: fill;
+  fill: currentColor;
 }
Summary: Some elements in HTML about:addons are unreadable in dark mode → HTML about:addons details view is unreadable in dark mode
Attached image image.png
Priority: -- → P3

addon-options-prompts-stack text is the same color as the background.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1551202
You need to log in before you can comment on or make changes to this bug.