Remove nsCSSValue bindings from the style system.

RESOLVED FIXED in Firefox 68

Status

()

task
P3
normal
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: emilio, Assigned: emilio)

Tracking

(Regressed 1 bug)

unspecified
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(8 attachments)

No description provided.

Use more compact types, and remove some manual implementations that can be
derived.

Depends on D31314

This appears to be a task, as opposed to a bug. Please move back if not.

Type: defect → task
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/86159475ddd3
Remove legacy transform interpolation code and related dead code. r=boris
https://hg.mozilla.org/integration/autoland/rev/8a7a0329bdc3
Cleanup a bit the counter style code. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/6c1f00cc30ca
Remove nsCSSValue usage from GetPad. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/37fd602bebc2
Remove nsCSSValue usage for negative / suffix / prefix. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/c354e61f2a34
Remove nsCSSValue usage for range checks in CounterStyleRule. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/d81e4aa6bf0c
Remove nsCSSValue usage of GetSymbols() GetAdditiveSymbols(). r=jwatt
https://hg.mozilla.org/integration/autoland/rev/e12a979de502
Remove usage of nsCSSValue for SpeakAs. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/3bb3fafa62e2
Remove nsCSSValue bindings. r=jwatt

New failure "Assertion failure: _0.ptr->data.header.header == kArcSliceCanary (Uh?), at z:/build/build/src/obj-firefox/dist/include\mozilla/ServoStyleConstsInlines.h:118"

Failure link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=246826943&repo=autoland&lineNumber=993

see bug 1550554 comment 11 for the explanation.

Flags: needinfo?(emilio)
Priority: -- → P3
Attachment #9065164 - Attachment description: Bug 1551991 - Cleanup a bit the counter style code. r=#style → Bug 1551991 - Cleanup a bit the counter style code. r=jwatt
Attachment #9065165 - Attachment description: Bug 1551991 - Remove nsCSSValue usage from GetPad. r=#style → Bug 1551991 - Remove nsCSSValue usage from GetPad. r=jwatt
Attachment #9065166 - Attachment description: Bug 1551991 - Remove nsCSSValue usage for negative / suffix / prefix. r=#style → Bug 1551991 - Remove nsCSSValue usage for negative / suffix / prefix. r=jwatt
Attachment #9065167 - Attachment description: Bug 1551991 - Remove nsCSSValue usage for range checks in CounterStyleRule. r=#style → Bug 1551991 - Remove nsCSSValue usage for range checks in CounterStyleRule. r=jwatt
Attachment #9065168 - Attachment description: Bug 1551991 - Remove nsCSSValue usage of GetSymbols() GetAdditiveSymbols(). r=#style → Bug 1551991 - Remove nsCSSValue usage of GetSymbols() GetAdditiveSymbols(). r=jwatt
Attachment #9065169 - Attachment description: Bug 1551991 - Remove usage of nsCSSValue for SpeakAs. r=#style → Bug 1551991 - Remove usage of nsCSSValue for SpeakAs. r=jwatt
Attachment #9065170 - Attachment description: Bug 1551991 - Remove nsCSSValue bindings. r=#style → Bug 1551991 - Remove nsCSSValue bindings. r=jwatt
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3c388ac5887c
Remove legacy transform interpolation code and related dead code. r=boris
https://hg.mozilla.org/integration/autoland/rev/5bac84efbf6d
Cleanup a bit the counter style code. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/336a076368eb
Remove nsCSSValue usage from GetPad. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/76ba2ec949d3
Remove nsCSSValue usage for negative / suffix / prefix. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/f06a39190b3d
Remove nsCSSValue usage for range checks in CounterStyleRule. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/80046630ae82
Remove nsCSSValue usage of GetSymbols() GetAdditiveSymbols(). r=jwatt
https://hg.mozilla.org/integration/autoland/rev/56b6c33c74dd
Remove usage of nsCSSValue for SpeakAs. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/d02c7d06cc79
Remove nsCSSValue bindings. r=jwatt
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/41abcc264037
followup: Don't derive the destructor of CounterSpeakAs so that we can return it safely by value in Win32. r=me
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/f41aae1abbba
followup: Give up on passing CounterSpeakAs by value since the previous patch busted non-Windows platforms.

:emilio one of your bugs caused an improvment
Bugs: Bug 1529002 Bug 1550554 Bug 1551991

== Change summary for alert #21025 (as of Tue, 21 May 2019 11:14:03 GMT) ==

Improvements:

2% raptor-motionmark-htmlsuite-firefox macosx1010-64-shippable opt 37.88 -> 38.80

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=21025

Duplicate of this bug: 1421509
Duplicate of this bug: 1387667
You need to log in before you can comment on or make changes to this bug.