Closed Bug 1552285 Opened 3 years ago Closed 3 years ago

Remove interrupts and triplets experimentation code

Categories

(Firefox :: Messaging System, task, P2)

task

Tracking

()

RESOLVED DUPLICATE of bug 1583262
Tracking Status
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- affected
firefox69 --- affected

People

(Reporter: Mardak, Unassigned)

References

(Blocks 1 open bug)

Details

Assuming we won't need this anymore in 68+ release, we can clean up locale-specific selecting logic. This probably wants to happen after bug 1552280. Although potentially depending on the decision there, we might end up re-purposing some of the experimentation logic to randomly pick a triplet.

Notably, we shouldn't need the enrollment ping bug 1549784 nor pref for survey bug 1549846.

More generally, we should work with normandy to figure out a more reusable experimentation framework for firstrun experiments.

Priority: -- → P1
No longer blocks: 1552282
Component: Activity Streams: Newtab → Messaging System
Blocks: skyline-firstrun
No longer blocks: trailhead-firstrun
Priority: P1 → P2
Priority: P2 → P1
Priority: P1 → P2

Bug 1583262 will be removing locale stuff while adding some more branches

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1583262
You need to log in before you can comment on or make changes to this bug.