Update default 68+ about:welcome experience including cards for return-to-AMO

VERIFIED FIXED in Firefox 68

Status

()

enhancement
P1
major
VERIFIED FIXED
2 months ago
21 days ago

People

(Reporter: Mardak, Assigned: Mardak)

Tracking

(Blocks 3 bugs)

unspecified
Firefox 69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 unaffected, firefox67.0.1 unaffected, firefox68blocking verified, firefox69 verified)

Details

Attachments

(3 attachments)

We don't want this for 67.* but assuming we go with one of the new trailhead flows based on the outcome of bug 1545802, we'll at least want to set the default experience for release users to be something other than "control". And at the same time, we should probably make return-to-amo at least show the same cards experience (i.e., cards above search box).

Blocks: 1552282
Blocks: 1552285

Oh, this will most likely require mozilla-central/firefox.js default pref changes:

https://searchfox.org/mozilla-central/rev/94c6b5f06d2464f6780a52f32e917d25ddc30d6b/browser/app/profile/firefox.js#1329-1333

#ifdef NIGHTLY_BUILD
pref("trailhead.firstrun.branches", "join-privacy");
#else
pref("trailhead.firstrun.branches", "control");
#endif
Iteration: --- → 69.1 - May 13 - 26
Priority: -- → P2
Iteration: 69.1 - May 13 - 26 → 69.2 - May 27 - Jun 9
No longer depends on: trailhead-firstrun
No longer blocks: 1552282
See Also: → 1556276

In order to wait for analysis from 67.0.1, we would like to target 68 Beta 12 for this uplift

Priority: P2 → P1
See Also: → 1550217
Firefox Messaging System: --- → trailhead
Iteration: 69.2 - May 27 - Jun 9 → 69.3 - Jun 10 - 23
Assignee: nobody → khudson
Blocks: 1558284

Aaron, originally this bug was filed to also update return-to-amo cards which currently shows the add-on install modal followed by the 3 non-trailhead cards modal then the new tab page.

For 68 uplift, the smallest beta change would be to set the override pref to the desired branch, e.g., join-privacy (which is currently the default on nightly) but this would not affect return-to-amo. Is that acceptable or should we update that path to show 3 trailhead cards that push down new tab content?

Flags: needinfo?(abenson)

We will probably want to fix up return-to-amo soon anyway as part of bug 1558284 if we don't fix it here. Just that we need to get a fix for here landed and verified in nightly before we can uplift to beta 68, and bug 1558284 clean up doesn't need to be uplifted.

(In reply to Ed Lee :Mardak from comment #3)

Aaron, originally this bug was filed to also update return-to-amo cards which currently shows the add-on install modal followed by the 3 non-trailhead cards modal then the new tab page.

For 68 uplift, the smallest beta change would be to set the override pref to the desired branch, e.g., join-privacy (which is currently the default on nightly) but this would not affect return-to-amo. Is that acceptable or should we update that path to show 3 trailhead cards that push down new tab content?

Cross-posting from our discussion: I think my preferred flow would be (in order of preference):

  1. amo modal -> trailhead cards on new tab (if possible).
  2. amo modal -> 3 trailhead cards in old modal -> New tab page
  3. amo modal -> 3 old card modal -> new tab

Jim was curious of the numbers for this particular flow to help determine how we should prioritize it.

Flags: needinfo?(abenson)
Duplicate of this bug: 1559007
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a87fb6dc17bf
Update default 68+ about:welcome experience including cards for return-to-AMO r=k88hudson
Assignee: khudson → edilee
Firefox Messaging System: trailhead → ---
Component: Activity Streams: Newtab → Messaging System
Blocks: 1560065

Comment on attachment 9072742 [details]
Bug 1552280 - Update default 68+ about:welcome experience including cards for return-to-AMO

Beta/Release Uplift Approval Request

  • User impact if declined: Users would see the old blue control welcome messaging instead of the new Join Firefox trailhead experience
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1) open 68 with a new profile
    expect: join modal then "browse privately, protection from tracking, take your passwords everywhere" cards at the top of new tab

testing RTAMO:

  1. configure return to amo attribution on the executable
  2. open 68 with a new profile
    expect: addon modal then "add-ons, private browsing, screenshots" cards in modal then new tab
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Just using the same preference that has been on nightly except keeping "control" for return-to-amo experience
  • String changes made/needed: none
Attachment #9072742 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Status: NEW → RESOLVED
Closed: 28 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Comment on attachment 9072742 [details]
Bug 1552280 - Update default 68+ about:welcome experience including cards for return-to-AMO

about:welcome update for 68.0b12

Attachment #9072742 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Hi guys, We can confirm this issue verified as Fixed but for both beta 68 and Nightly 69 we are getting a different modal window.

in the expected results :

open 68 with a new profile
expect: addon modal then "add-ons, private browsing, screenshots" cards in modal then new tab

Our Actual results are: "Private Browsing, Screenshots and Sync"
Is this the correct model window ? should we see a different one ? including Add-ons ? please see the attached file.

Ed can you please take a look and confirm its the right modal window before we mark this issue verified as fixed ?

Flags: needinfo?(edilee)

Oh yup, the sync one is expected in the 3rd spot as we would otherwise not offer sync on about:welcome.

Flags: needinfo?(edilee)

This issue is Verified as Fixed in Both Beta 68 as well as our Latest Nightly 69. I will mark this issue accordingly.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Posted image privacy cards

To be clear, attachment 9073184 [details] is the cards shown after Return to AMO. With the change here, almost all new users will see the join modal with the privacy cards (attached).

You need to log in before you can comment on or make changes to this bug.