Clicking on submenu parent menu item does not work

VERIFIED DUPLICATE of bug 13334

Status

()

defect
P4
normal
VERIFIED DUPLICATE of bug 13334
20 years ago
11 years ago

People

(Reporter: CodeMachine, Assigned: mikepinkerton)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Currently clicking on a submenu, eg "Wallet >" dismisses the menu and
seems to deliver a click to what is underneath.  I would expect it to open the
submenu.

I have tested this on both Linux and Win 98 and would expect this on neither.
The Win build I have here is 1999093012.
(Reporter)

Updated

20 years ago
Summary: Clicking on submenu header does not work.
(Reporter)

Updated

20 years ago
Severity: enhancement → normal

Updated

20 years ago
Assignee: trudelle → saari
Priority: P3 → P4
Target Milestone: M12

Comment 1

20 years ago
This is timing related, the click dismisses the menu if it is already up. I
couldn't confirm that the object underneath gets the click though.  While trying
to reproduce this, I also managed to get the menus into a state where the
menubar ignored all clicks.  I'll try to reproduce that. reassigning to saari
as p4 for m12.
(Reporter)

Comment 2

20 years ago
There's currently a bug where clicking on the personal toolbar loads a "chrome:"
URL into the URL bar.  I reproduced this on the menus and that's what has led me
to believe this.

Comment 3

20 years ago
*** Bug 17115 has been marked as a duplicate of this bug. ***

Comment 4

20 years ago
mass-moving all m12 bugs to m13

Comment 5

20 years ago
*** Bug 18582 has been marked as a duplicate of this bug. ***

Updated

20 years ago
OS: other → Windows NT
Summary: Clicking on submenu header does not work. → [PP] Win32 - Clicking on submenu header does not work.

Comment 6

20 years ago
Marking [PP] - I was not able to reproduce on Linux or Mac using the 19991109xx
builds. matty, can you verify that?

Comment 7

20 years ago
I can reproduce this on Win32 (1999111108) quite easily. Just do your initial
click on a different menu than the one you do the submenu click in --- e.g. click
on "Edit", drag to "View", and then click on "Translate". The menu will be
dismissed.
(Reporter)

Comment 8

20 years ago
Yeah I can repro this on Linux, build 1999111208.  It seems that mousedown
toggles and mouseover turns on.  They should both turn on.  So whether the
behaviour occurs depends on whether you beat the mouseover.

I can't see the click-through problem anymore though.
(Reporter)

Comment 9

20 years ago
*** Bug 19999 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

20 years ago
Bug #19999 is about the click-through behaviour still occuring.  I'm keeping
these two issues together because they're probably the same problem ...
(Reporter)

Comment 11

20 years ago
Click-through is probably Windows only.
(Reporter)

Comment 12

20 years ago
Bug #13334 is a related bug on Linux behaviour.

Comment 13

20 years ago
matty, when you pull down a menu and then click on a submenu what do you expect to happen?
Currently, if you beat the mouseover and click before the menu shows up, the menu still shows
up (as it should). If you don't beat the mouseover, that means you're looking at the submenu
and have now clicked on the name of the submenu and it(the entire menu) dismisses (matching 4.x).
The only thing I can think of is that clicking on a submenu when it is already open could dismiss the
submenu only.
In a nutshell, i'm not clear on what the expected behavior is. If it's to match 4.x, then aside from the
click-through (Bug 19999) we've already got that.

Comment 14

20 years ago
Worst case scenario: the "Mouseclicks can pass through XP menus" would
be extremely heinous if it affected greyed items on context menus over
the browser window. Checked this, not a problem.

The "Mouseclicks can pass through XP menus" problem could conceivably
activate arbitrary links on the webpage if the click fell through the
labels for the submenus on the Edit, View, or Bookmarks menus,
so if this is still happening at all, this is a real bug, IMHO.

Unable to replicate, making sure to beat the mouseover.
Tested with: 1999-12-09-08-M12 nightly bianry on Windows NT 4.0sp3
(Reporter)

Updated

20 years ago
Summary: [PP] Win32 - Clicking on submenu header does not work. → [PP] Win32 - Clicking on submenu parent menu item does not work.
(Reporter)

Comment 15

20 years ago
No, the dismissal does not occur on NN4 on Windows or Linux, or in any other app
I've ever seen for that matter.  Clicking on a submenu parent menu item should
turn on the submenu regardless of whether it is already up, so there is no race
condition.

Are you sure we're talking about the same thing?  Clarified the description a
bit.  Maybe this has been fixed recently on Win?
Component: XP Toolkit/Widgets → XPMenus
updated component... i tried this out with 1999121509/winNT, and cannot seem to
repro... is it still a problem for others?

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M13 → M15
(Reporter)

Comment 17

20 years ago
Still there for build 1999121915/Win98.
(Reporter)

Comment 18

20 years ago
It's interesting to compare this with the behaviour of a menu directly off the
menu bar.  Clicking a second time on the menubar item will dismiss the menu on
Win and XP (but not NC4 Linux or GTK), but that's OK because there is no popup
on mouseover that needs to be beaten.

Regarding the comment of just dismissing the submenu, I think this would be OK
since you don't have to traverse the entire hierachy again, and your mouse is
already where it needs to be to reopen the submenu if necessary, but I still
would prefer it not dismiss, since I see no purpose in dismissing it (if you
want to choose something else then just do so).
(Assignee)

Updated

20 years ago
Assignee: saari → pinkerton
Status: ASSIGNED → NEW
taking popup/menu bugs.

Updated

20 years ago
QA Contact: claudius → sairuh

Comment 20

20 years ago
*** Bug 16876 has been marked as a duplicate of this bug. ***

Comment 21

20 years ago
*** Bug 23101 has been marked as a duplicate of this bug. ***
Summary: [PP] Win32 - Clicking on submenu parent menu item does not work. → Clicking on submenu parent menu item does not work
summary: removed pltf parity, since this occurs on linux as well (whose bug[s]
have just been dup'd of this one :-).
(Reporter)

Comment 23

20 years ago
Bug #13334 is about Linux behaviour (which doesn't have the click-thru part),
but I guess it's not platform parity if the main part happens everywhere.

Comment 24

20 years ago
BULK MOVE: Changing component from XP Menus to XP Toolkit/Widgets: Menus.  XP 
Menus component will be deleted.
Component: XPMenus → XP Toolkit/Widgets: Menus
bulk accepting xpmenu/popup bugs. sigh.
Status: NEW → ASSIGNED

Comment 26

20 years ago
*** Bug 25400 has been marked as a duplicate of this bug. ***

Comment 27

20 years ago
Adding myself to the CC list


*** This bug has been marked as a duplicate of 13334 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
yeah, this certainly appears to be a dup of 13334...
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.