Closed Bug 1552966 Opened 1 year ago Closed 7 months ago

Convert the printing code from DocShellTree* to BrowsingContext

Categories

(Core :: Printing: Setup, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla75
Fission Milestone M6
Tracking Status
firefox75 --- fixed

People

(Reporter: jwatt, Assigned: jwatt)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [print2020_v75])

Attachments

(1 file)

No description provided.
Fission Milestone: --- → M5

M6 because printing support blocks enabling Fission in Nightly.

Fission Milestone: M5 → M6

Jonathan, do you have an ETA for when you will be able to look at this bug?

IIUC, this bug blocks printing, so we'll need to fix it before enabling Fission Nightly (M6). Here are instructions for replacing nsIDocShellTreeItem with BrowsingContext:

https://wiki.mozilla.org/Project_Fission/DocShell_Tree_Replace

Virtually all DocShellTree* uses have been removed from the printing code in various other printing refactoring bugs. I'll put up a patch for the rest shortly.

Pushed by jwatt@jwatt.org:
https://hg.mozilla.org/integration/autoland/rev/fd383a15ed4e
Convert the printing code to stop using DocShellTree* classes. r=farre

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:jwatt, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(jwatt)
Flags: needinfo?(jwatt)
Pushed by jwatt@jwatt.org:
https://hg.mozilla.org/integration/autoland/rev/33a086f16245
Convert the printing code to stop using DocShellTree* classes. r=farre
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Regressions: 1620314
Whiteboard: [print_v75]
Regressions: 1630095
Whiteboard: [print_v75] → [print2020_v75]
Regressions: 1639816
Duplicate of this bug: 1597484
You need to log in before you can comment on or make changes to this bug.