Closed Bug 1553065 Opened 1 year ago Closed 1 year ago

[linux] Nightly logo and name is shown under about Firefox window

Categories

(Firefox Build System :: General, defect)

68 Branch
Desktop
Linux
defect
Not set
major

Tracking

(Root Cause:?, firefox-esr60 unaffected, firefox67 unaffected, firefox68blocking verified, firefox69blocking verified)

VERIFIED FIXED
mozilla69
Root Cause ?
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 blocking verified
firefox69 blocking verified

People

(Reporter: atrif, Assigned: mshal)

References

(Regression)

Details

(Keywords: rca-needed, regression)

Attachments

(4 files)

Attached image nightbeta.png

Affected versions

  • Firefox 68.0b3 (20190520131124)

Affected platforms

  • Ubuntu 18.04

Steps to reproduce

  1. Download Firefox from https://archive.mozilla.org/pub/firefox/candidates/68.0b3-candidates/build1/linux-x86_64/en-US/
  2. Open Firefox and go to Help - About Firefox.

Expected result

  • Firefox icon and name is displayed.

Actual result

  • Firefox Nightly image and names are displayed.

Regression Range

  • I will search for one ASAP.

Additional Notes

  • Attached a screenshot with this issue.
  • Profile manager and section under Help-> About Firefox use Nightly name as well.
  • Firefox 67.0b19 and Firefox 68.0b3 DevEdition (20190520131124) have desired image and names.
  • Ubuntu 16 x86 is not affected.
  • Ubuntu 18.04 x64 affected locales de and zh-CN.
Has Regression Range: --- → no
Has STR: --- → yes
Summary: [Ubuntu] Nightly logo and name is shown under about Firefox window → [linux] Nightly logo and name is shown under about Firefox window

So it looks like we now set mozconfig-variant to profile-use, which uses the nightly branding instead of the official one.

Flags: needinfo?(mshal)
Product: Firefox → Firefox Build System
Regressed by: 1516114
Regressed by: 1507334

(my patch fixes the immediate issue for 68; we still need to fix things properly for 69+)

Hello,
The issue is verified using Firefox 68.0b3-build2 (20190521110747) and also Firefox snap build on Ubuntu 18.04.

I think this will be fixed more generally by going back to using "nightly" mozconfigs instead of the new "profile-use" mozconfigs for PGO builds. The PGO logic can then go in common mozconfig files, for use by both nightly and beta/release builds. Patches incoming...

Flags: needinfo?(mshal)
Assignee: nobody → mshal

The 3-tier PGO builds used a separate mozconfig called 'profile-use' for
the final tier. This created a problem when it rode to beta, since the
same mozconfig was used for all trees, which meant we ended up with
nightly branding on beta builds.

With the PGO-enabling logic in common mozconfigs, we can enable it by
setting the MOZ_PGO_PROFILE_USE environment variable from the task
definition. All of the final-tier PGO builds now use the nightly, beta,
etc mozconfigs like before, so branding should be intact.

Depends on D33171

:jcristau, can you verify that these patches would also fix the branding on beta builds? Or is there an easy way I can do so on try?

Flags: needinfo?(jcristau)
Duplicate of this bug: 1553157

(Replying for Julien, because I'm the one who showed him this trick) There's a nice way to test what builds looks like on beta, on try 😃:

./mach try release --version 68.0b9 --migration central-to-beta --tasks release-sim

You may need to replace the version number with something more current.

Flags: needinfo?(jcristau)

(In reply to Johan Lorenzo [:jlorenzo] from comment #12)

(Replying for Julien, because I'm the one who showed him this trick) There's a nice way to test what builds looks like on beta, on try 😃:

./mach try release --version 68.0b9 --migration central-to-beta --tasks release-sim

Thanks, that helps! The branding looks fixed as far as I can tell: https://treeherder.mozilla.org/#/jobs?repo=try&revision=9dc17cb7a3dd92aa7bfbe8551ae29dc79f9bd3ef

I'll land these patches, please keep me posted if there are any other similar issues with PGO.

Pushed by mshal@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8245ccd3c948
Use MOZ_LTO environment variable in mozconfig.unix; r=firefox-build-system-reviewers,chmanchester
https://hg.mozilla.org/integration/autoland/rev/4f56db8e65a6
Move profile-use mozconfig info into common mozconfigs; r=firefox-build-system-reviewers,chmanchester
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Thanks for the fix, Mike! Quick followup question, do you think the patches should be uplifted to beta, in order to help fixing bug 1555982?

Context: One the 68 branch, I introduced new Android job/mozconfigs in order to build both the Nightly and the Build flavors on the same branch (bug 1523402). I missed to use the profile on one beta build. I wonder if we should get rid of the profile there too. What do you think?

Flags: needinfo?(mshal)
See Also: → 1555982, ESR-Fennec

Comment on attachment 9068736 [details]
Bug 1553065 - Use MOZ_LTO environment variable in mozconfig.unix; r?#firefox-build-system-reviewers

Beta/Release Uplift Approval Request

  • User impact if declined: Beta Fennec builds won't have PGO enabled (see bug 1555982)
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is running on nightly, and Fennec arm builds are built with PGO there. The changes involve bringing the mozconfigs more in line with how they are named historically, so it shouldn't require additional changes on beta to enable PGO for these builds.

Another alternative is to change the Taskcluster files, and possibly the mozconfigs, to point the beta builds to the profile-use mozconfig and make sure branding and other beta-specific features are kept.

  • String changes made/needed:
Flags: needinfo?(mshal)
Attachment #9068736 - Flags: approval-mozilla-beta?
Attachment #9068738 - Flags: approval-mozilla-beta?

(In reply to Johan Lorenzo [:jlorenzo] from comment #16)

Thanks for the fix, Mike! Quick followup question, do you think the patches should be uplifted to beta, in order to help fixing bug 1555982?

Context: One the 68 branch, I introduced new Android job/mozconfigs in order to build both the Nightly and the Build flavors on the same branch (bug 1523402). I missed to use the profile on one beta build. I wonder if we should get rid of the profile there too. What do you think?

Good idea, yeah - these patches should fix that issue as well. I've just requested an uplift! If you notice any further issues after that please ping/ni me.

beta would need a rebased patch.

I'm uneasy about taking this at this point. Johan offered to run a staging release and check for unintended side effects which might tip the balance.

(In reply to Julien Cristau [:jcristau] from comment #19)

beta would need a rebased patch.

I'm uneasy about taking this at this point. Johan offered to run a staging release and check for unintended side effects which might tip the balance.

Either way is fine with me - whichever is easiest. We should be able to fixup the TC configs / mozconfigs for bug 1555982 if we want to go that route.

I rebased the patch on top of beta, and pgo builds are failing across the board: https://treeherder.mozilla.org/#/jobs?repo=try&revision=577d0214201bd523582b75ed20f4c4865b8ae486&selectedJob=250404999

I'm not sure what's happening. Do you see something, Mike?

Flags: needinfo?(mshal)

(In reply to Johan Lorenzo [:jlorenzo] from comment #21)

I rebased the patch on top of beta, and pgo builds are failing across the board: https://treeherder.mozilla.org/#/jobs?repo=try&revision=577d0214201bd523582b75ed20f4c4865b8ae486&selectedJob=250404999

I'm not sure what's happening. Do you see something, Mike?

Ahh, looks like my patch needs bug 1553972 to work, which changed --with-pgo-profile-path to point to a directory instead of a file. I think either of these options will fix it:

  1. Include the patch from bug 1553972
  2. In build/unix/mozconfig.unix and mobile/android/config/mozconfigs/common, use:

ac_add_options --with-pgo-profile-path=/builds/worker/fetches/default.profraw

instead of:

ac_add_options --with-pgo-profile-path=/builds/worker/fetches

Flags: needinfo?(mshal)

(In reply to Michael Shal [:mshal] from comment #22)

  1. Include the patch from bug 1553972

I went with this option: https://treeherder.mozilla.org/#/jobs?repo=try&revision=042e96b220da28f08d2b18783125189952ac7d60&selectedJob=250967253

The logs look good to me. The beta build does use the PGO profile, per the logs. This fixes bug 1555982. Do you see anything fishy, Mike?

Flags: needinfo?(mshal)
Duplicate of this bug: 1555982

(In reply to Johan Lorenzo [:jlorenzo] from comment #23)

(In reply to Michael Shal [:mshal] from comment #22)

  1. Include the patch from bug 1553972

I went with this option: https://treeherder.mozilla.org/#/jobs?repo=try&revision=042e96b220da28f08d2b18783125189952ac7d60&selectedJob=250967253

The logs look good to me. The beta build does use the PGO profile, per the logs. This fixes bug 1555982. Do you see anything fishy, Mike?

Looks pretty good to me! I double-checked that we have LTO and PGO set on nightlies and beta builds. The only thing that looks a little strange is the use-pgo flags for beta builds. We currently have:

android-api-16-beta/opt: use-pgo: android-api-16/pgo
android-api-16-beta-test/opt: use-pgo: android-api-16/pgo
android-aarch64-beta/opt: use-pgo: android-api-16-beta/pgo

IOW, the first two are pulling data from android-api-16/pgo builds, while the aarch64 build is pulling from android-api-16-beta/pgo builds. This probably has a minimal effect on the final product, but I think all three should be android-api-16-beta/pgo for consistency.

Flags: needinfo?(mshal)

Thanks for catching this! I made the changes in https://treeherder.mozilla.org/#/jobs?repo=try&revision=516b8f9496193535201ec8e92b5c3bac4721f7cb.

Ryan, Julien is flying out today. Can we get this one and bug 1553972 approved? Or would you prefer Julien to handle it?

Flags: needinfo?(ryanvm)

Comment on attachment 9068736 [details]
Bug 1553065 - Use MOZ_LTO environment variable in mozconfig.unix; r?#firefox-build-system-reviewers

Improves maintainability and simplifies PGO handling for Fennec on ESR (where the mozconfig situation is a bit more complicated otherwise). Looks good on Try. Approved for 68.0b11 with mshal's comments addressed.

Flags: needinfo?(ryanvm)
Attachment #9068736 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9068738 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Hello
The issue is verified fixed with Firefox 69.0b3 (20190708182549) including snap build on Ubuntu 18.04. Thank you!

Status: RESOLVED → VERIFIED
Flags: qe-verify+

This bug has been identified as part of a pilot on determining root causes of blocking and dot release drivers.

It needs a root-cause set for it. Please see the list at https://docs.google.com/document/d/1FFEGsmoU8T0N8R9kk-MXWptOPtXXXRRIe4vQo3_HgMw/.

Add the root cause as a whiteboard tag in the form [rca - <cause> ] and remove the rca-needed keyword.

If you have questions, please contact :tmaity.

Keywords: rca-needed

Please specify a root cause for this bug. See :tmaity for more information.

Root Cause: --- → ?
You need to log in before you can comment on or make changes to this bug.