Closed Bug 1553682 Opened 2 years ago Closed 1 month ago

Context menus and menu popups are not dark in the dark theme

Categories

(Firefox :: Theme, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1681822
Tracking Status
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- wontfix
firefox80 --- wontfix
firefox85 --- ?
firefox86 --- ?
firefox87 --- affected

People

(Reporter: mj12agent, Unassigned)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

Attachments

(1 file)

Attached image sdf.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Right click on a bookmark/bookmarks toolbar/tab/web page/toolbar element (like add-on icon, search bar or address bar) while theme is set to dark.

Actual results:

Menus' background is still light.

Expected results:

The background of the right click context menus should have been dark.

Component: Untriaged → Theme
Depends on: 1529323
OS: Unspecified → All
Priority: -- → P3
Hardware: Unspecified → All
See Also: → 1475520, 1408121
Version: 68 Branch → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 1523995
Blocks: 1532172
See Also: → 1568364
Summary: Right-click context menus are not dark in the dark theme → Context menus and menu popups are not dark in the dark theme
See Also: 1568364
Duplicate of this bug: 1568364
See Also: → 1571065
Blocks: 1595743
See Also: → 1597631

Could this be prioritized? This is from what I can tell probably the biggest source of brightness in dark mode.

See Also: → 1566685

[Tracking Requested - why for this release]:

See Also: → 1631554

(In reply to tamerfadli@gmail.com from comment #8)

Is this still being considered?

Context menus on Windows 10 would also look better if they are themed like the Photon popups from the rest of the application. Ex. clicking on the three dots button under Top sites provides a menu, right-click context menus should emulate this look.

Blocks: dark-mode
Duplicate of this bug: 1643891

I'm looking at where I would have to change to fix this, would putting a background under prefers-color-scheme in https://searchfox.org/mozilla-central/source/browser/themes/shared/contextmenu.inc.css work?

Flags: needinfo?(dao+bmo)

Tracking stops with Firefox 80. :D
We are at 85 now.
Any sort of ETA here?

This should be an easy fix after all; the Windows Explorer has dark context menus, too.

This may be resolved with bug 1681822? (I specifically see mention of dark mode in bug 1682522.)

Windows 10 is covered by bug 1682522, macOS by bug 1475520, Linux has always supported system themes.

Status: NEW → RESOLVED
Closed: 1 month ago
Flags: needinfo?(dao+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: proton-context-menus

@(In reply to Tim Nguyen :ntim from comment #16)

Windows 10 is covered by bug 1682522, macOS by bug 1475520, Linux has always supported system themes.

*** This bug has been marked as a duplicate of bug 1681822 ***

1682522 seem to be done for 87, but that's the version I have installed and my menus are still grey.

You need to log in before you can comment on or make changes to this bug.