Closed Bug 15545 Opened 20 years ago Closed 20 years ago

{css1} Broken floating IMG elements dissapear [ALT]

Categories

(Core :: Layout, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: emk, Assigned: troy)

References

Details

(Keywords: css1, Whiteboard: (py8ieh: snarf test cases for eviltests))

Attachments

(2 files)

Step to reproduce:
1. Launch apprunner.
2. Go to the following attachment.

Expected result:
Floating, broken IMG elements should float and should not ignore width and
height because floating elements are block-level elements, NOT inline elements.

See the CSS2 spec. "9.7 Relationships between 'display', 'position',
and 'float'" and "10.3 Computing widths and margins".

Actual result:
The alternate text does not float and width/height gone.

I am using [1999100308] build on WinNT4 (SP5).
Depends on: 1994
QA Contact: petersen → py8ieh=bugzilla
Stealing QA contact...
Status: NEW → ASSIGNED
This seems to be fixed now except that the loading icon will not change
to the broken icon.
*** Bug 22507 has been marked as a duplicate of this bug. ***
*** Bug 22444 has been marked as a duplicate of this bug. ***
Adding testcase from bug 22444 -- just noting (for completeness) that behaviour
within tables can differ from the general case for flow :
   http://bugzilla.mozilla.org/showattachment.cgi?attach_id=4115
Summary: [ALT]Floating, broken IMG elements should float → {css1} Floating, broken IMG elements should float [ALT]
Whiteboard: (py8ieh: reinvestigate)
Summary: {css1} Floating, broken IMG elements should float [ALT] → {css1} Broken floating IMG elements dissapear [ALT]
Whiteboard: (py8ieh: reinvestigate) → (py8ieh: snarf test cases for eviltests)
STEPS TO REPRODUCE:
Open http://bugzilla.mozilla.org/showattachment.cgi?attach_id=2001 in Mozilla.

ACTUAL RESULTS:
This is not fixed at the moment. We first lay out correctly, but upon finding
that the image doesn't exist, we currently DO NOT reflow the floater. A forced
redraw (e.g. invalidating the window by dragging it out of the screen and back
again) hides the floater. A reflow shows that the floater has in fact totally
dissapeared.

A reload places an IE-style "broken image" box with glyph.

EXPECTED RESULTS:
Once the image is found to not be available (whether during the initial flow
or later on) the IMG element should be treated as a normal element containing
the ALT text, as with non-floating broken IMG elements.

ADDITIONAL COMMENTS:
The bug at the moment seems to be that if the element is floating, the
CantRenderReplacedContent (or whatever it's called) fails. Troy?

VYV03354: Note that we do not ever want to see the "broken icon". See bug 1994
for more details on that.
I know it's broken, that's why the bug is marked ASSSIGED...
Troy: I never suggested you might think otherwise -- I just figured that since
I had just investigated the problem, and had notes that were slightly more
detailed than currently included in this bug, I might as well file them too...
Since I'm QA contact, that would be my responsability, no? :-)
Yup, it makes perfect sense. I was just chiming in that I'm aware of the
problme and do actually plan on fixing it some day. :-)
Keywords: css1
Migrating from {css1} to css1 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
Okay, this is fixed now. Turns out there were three separate problems that 
needed to be fixed.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
We still see the "broken image" icon when we reload the page.
I'm not sure I follow. It displays correctly the first time, but then if you 
reload the page you see the broken image?

If so, it sounds like a different problem
Main issue has been fixed. Opened bug 24815 to cover the reload problem.
VERIFIED.
Blocks: html4.01
Status: RESOLVED → VERIFIED
Depends on: 75185
No longer depends on: 1994
You need to log in before you can comment on or make changes to this bug.