Closed Bug 1554666 Opened 1 year ago Closed 1 year ago

Card images are wrongly resized if the window is resized under 846 width

Categories

(Firefox :: Messaging System, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.1 - Jul 8 - 21
Tracking Status
firefox67 --- unaffected
firefox67.0.1 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- verified

People

(Reporter: cmuresan, Assigned: jcarlos)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(2 files)

[Affected versions]:

  • Firefox Nightly 69.0a1, Build ID 20190527095441
  • Firefox Beta 68.0b4, Build ID 20190523115432
  • Firefox Release 67.0.1, Build-ID 20190523020236 (treeherder build)

[Affected Platforms]:

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]:

  • Have the trailhead.firstrun.branches set to join-privacy in a new profile.

[Steps to reproduce]:

  1. Start the browser with the profile from prerequisites.
  2. Navigate to about:welcome and dismiss the modal.
  3. Resize the browser window to 867 width.
  4. Resize the browser window to 846 width and observe the behavior.

[Expected results]:

  • The browser window is resized and the cards are unaffected.

[Actual results]:

  • The browser window is resized and the images from the cards become smaller.

[Notes]:

  • The issue is reproducible on all triplets.
  • Attached a screenshot of the issue.
Blocks: trailhead-firstrun
No longer blocks: 1552282
Component: Activity Streams: Newtab → Messaging System

The component has been changed since the priority was decided, so we're resetting it.
For more information, please visit auto_nag documentation.

Priority: P3 → --
Iteration: --- → 70.1 - Jul 8 - 21
Priority: -- → P2
No longer blocks: trailhead-firstrun
Priority: P2 → P1
Assignee: nobody → jcarlos

In the codebase there's a media query to shrink the size of this image after 850px break point, so looks like the images are supposed to shrink. Though, the cards going into a different row should probably have a consistent height.

PR will keep consistent height if a card breaks into a new row and the image shrinking break point is updated (but will likely break again with minor CSS changes - should be fine.)

https://drive.google.com/open?id=1EGgdmOMFlSu7LoyNNWK-mhpt6qNOp51O

Blocks: 1565293
Status: NEW → RESOLVED
Closed: 1 year ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

I have verified that the issue is no longer reproducible on the latest Nightly 70.0a1 (Build ID 20190713215744) on Windows 10, macOS 10.14, and Arch Linux 14.4.3.

Status: RESOLVED → VERIFIED

Is this something we should consider backporting to Beta for Fx69 or can this ride the trains with 70 instead? Please nominate this for Beta approval if you think this needs uplift.

Flags: needinfo?(jcarlos)

Nope, should be fine if we just bring this to 70

Flags: needinfo?(jcarlos)
You need to log in before you can comment on or make changes to this bug.