Closed Bug 1555468 Opened 2 years ago Closed 4 months ago

[meta] Scrollbar dragging issues with desktop zooming

Categories

(Core :: Panning and Zooming, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1657822
Tracking Status
firefox69 --- affected

People

(Reporter: botond, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: meta)

After we get scrollbar rendering to work with desktop zooming (bug 1523405), allowing the scrollbars to be dragged (via mouse or touch) in a zoomed state will need some extra work, which this bug tracks.

Currently, enabling apz.allow_zooming breaks scrollbar dragging even if you're not zoomed.

Depends on: 1556556

(In reply to Botond Ballo [:botond] from comment #1)

Currently, enabling apz.allow_zooming breaks scrollbar dragging even if you're not zoomed.

Filed bug 1556556 for this.

Scrollbar rendering now works well enough that work on scrollbar dragging is unblocked.

No longer depends on: 1523405
Blocks: desktop-zoom

With bug 1556556 in place, scrollbar dragging seems to be working well with apz.allow_zooming=true, both when zoomed in and when not zoomed in, and both on viewport scrollbars and subframe scrollbars.

There may, however, be issues with scrollbar dragging on specific sites (e.g. I just filed bug 1636273 for an issue on BMO). Let's repurpose this into a meta bug to hang such issues off of.

Keywords: meta
Summary: Get scrollbar dragging to work with zooming on desktop → [meta] Get scrollbar dragging to work with zooming on desktop
Depends on: 1636273
Summary: [meta] Get scrollbar dragging to work with zooming on desktop → [meta] Scrollbar dragging issues with desktop zooming

Remaining scrollbar stuff has been or is being handled in bug 1657822 and dependencies.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1657822
You need to log in before you can comment on or make changes to this bug.