Closed Bug 1557661 Opened 6 months ago Closed 3 months ago

java.lang.NullPointerException: at org.mozilla.gecko.home.TabMenuStripLayout.onPageSelected(TabMenuStripLayout.java)

Categories

(Firefox for Android :: Theme and Visual Design, defect)

Firefox 68
Unspecified
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox-esr68 69+ verified
firefox68 + verified
firefox69 --- fixed

People

(Reporter: jcristau, Assigned: andrei.a.lazar)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [fennec68.1])

Crash Data

Attachments

(1 file)

Seeing crashes after bug 1371217 was uplifted to 68:
https://crash-stats.mozilla.com/signature/?signature=java.lang.NullPointerException%3A%20at%20org.mozilla.gecko.home.TabMenuStripLayout.onPageSelected%28TabMenuStripLayout.java%29&date=%3E%3D2019-05-31T09%3A08%3A00.000Z&date=%3C2019-06-07T09%3A08%3A00.000Z

java.lang.NullPointerException: Attempt to invoke virtual method 'void android.widget.TextView.setTextColor(int)' on a null object reference at org.mozilla.gecko.home.TabMenuStripLayout.onPageSelected(TabMenuStripLayout.java:131) at org.mozilla.gecko.home.TabMenuStrip.onConfigurationChanged(TabMenuStrip.java:135) at android.view.View.dispatchConfigurationChanged(View.java:13048)

Flags: needinfo?(anca.manu)

Bug 1371217 was backed out of beta.

Fixed an issue where we were trying to set some attributes on a null object due to the fact that
the view had not finished rendering.

Assignee: nobody → andrei.a.lazar
Flags: needinfo?(anca.manu)
Keywords: checkin-needed

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1e2272faa004
java.lang.NullPointerException: at org.mozilla.gecko.home.TabMenuStripLayout.onPageSelected(TabMenuStripLayout.java) r=VladBaicu

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Please nominate this for ESR68 approval when you get a chance.

Flags: needinfo?(andrei.a.lazar)

Comment on attachment 9073182 [details]
Bug 1557661 java.lang.NullPointerException: at org.mozilla.gecko.home.TabMenuStripLayout.onPageSelected(TabMenuStripLayout.java) r=VladBaicu

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: This is a pretty critical bug since it can be reproduced 100% of time upon screen orientation change.
  • User impact if declined: Users won't be able to change the screen orientation without getting a crash (in some particular screens) which leads to bad user experience.
  • Fix Landed on Version: 68
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change is small and it has been hard tested and it doesn't introduce any new behaviors, we are just adding a sanity check.
  • String or UUID changes made by this patch:
Flags: needinfo?(andrei.a.lazar)
Attachment #9073182 - Flags: approval-mozilla-esr68?

Comment on attachment 9073182 [details]
Bug 1557661 java.lang.NullPointerException: at org.mozilla.gecko.home.TabMenuStripLayout.onPageSelected(TabMenuStripLayout.java) r=VladBaicu

Fixes a crash caused by bug 1371217, approved for 68.1b2.

Attachment #9073182 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+

Hi, the issue has been checked on build Firefox Beta 68.1b1 (build 3) and not reproduced with devices:

  • Google Pixel C (Android 8.0.0)
  • Samsung Galaxy J7 (2016) (Android 6.0.1)
  • Sony Xperia Z5 (Android 7.0)
    on platform android - api 16.
  • Google Pixel 3a XL (Android 9)
    on platform android-aarch64.

Will leave the ticket unchanged until I will also make a check on an X86 device.

Hello, I tried to reproduce the problem using Xiaomi Mi Pad 2 (Android 5.1 - x86 architecture) on the affected build of Nightly(68.0a1 2019-06-05) but I wasn't able. It seems that the x86 build is not affected.
Additionally, I verified with Samsung Galaxy Tab S3 (Android 8.0) on the same build for the API 16 architecture and I was able to reproduce the problem.
I tried with the latest version of Nightly from the archive (68.1a1 2019-07-13) and Nightly (69.0a1 2019-07-06) from treeherder and the issue is not reproducible.
I'll let the issue open until I can confirm the fix on Beta 68.1b2, thanks.

Duplicate of this bug: 1565622
Crash Signature: [@ java.lang.NullPointerException: at org.mozilla.gecko.home.TabMenuStripLayout.onPageSelected(TabMenuStripLayout.java)] → [@ java.lang.NullPointerException: at org.mozilla.gecko.home.TabMenuStripLayout.onPageSelected(TabMenuStripLayout.java)] [@ java.lang.NullPointerException: at org.mozilla.gecko.home.TabMenuStripLayout$1.onGlobalLayout(TabMenuStripLayout.java)]

Hello, I can confirm that the issue is not reproducible on Beta 68.1b2 using Samsung Galaxy Tab S3 (Android 8.0) and Nexus 9 (Android 7.1.1).

Status: RESOLVED → VERIFIED
Crash Signature: [@ java.lang.NullPointerException: at org.mozilla.gecko.home.TabMenuStripLayout.onPageSelected(TabMenuStripLayout.java)] [@ java.lang.NullPointerException: at org.mozilla.gecko.home.TabMenuStripLayout$1.onGlobalLayout(TabMenuStripLayout.java)] → [@ java.lang.NullPointerException: at org.mozilla.gecko.home.TabMenuStripLayout.onPageSelected(TabMenuStripLayout.java)] [@ java.lang.NullPointerException: at org.mozilla.gecko.home.TabMenuStripLayout$1.onGlobalLayout(TabMenuStripLayout.java)]
Regressions: 1567093

I just updated to 68.1b2 and started getting a crash with this signature almost every time my screen rotates orientation:

https://crash-stats.mozilla.org/report/index/09a424d9-782a-4565-8656-422680190722

I didn't get this with 68.1b1 or earlier. Is it the same bug or a new one?

Indeed, this signature looks pretty high in 68.1b2. Andrei, any ideas?

Flags: needinfo?(andrei.a.lazar)

This problem is resolved by the patch from bug 1562622 which is not yet uplifted.

Flags: needinfo?(andrei.a.lazar)

Hello Andrei: I still see a fairly significant number of crashes (over 800) in Fennec nightly, 68.1a1 even though a fix for this landed. Is there a reason why it is still showing up in nightly? Some of the comments:

*Opening phone from sleep caused Firefox to crash.
*App crashed when switched to landscape mode.
*it crashes when i use split screen

If needed, we can file a new bug. This is currently the top crash on Fennec nightly.

Flags: needinfo?(andrei.a.lazar)

I know you also mentioned in Comment 15 that the patch in that bug would fix it, but the 2 signatures in this bug still have crashes in both 68.1b3 and 68.1b4.

Hello, this should be fixed by Brad's patch as soon as this gets merged.

Flags: needinfo?(andrei.a.lazar)

bug 1562622 comment 29 states that this should be fixed, but today's Nightly is still crashing a lot for me.

Whiteboard: [fennec68.1]

This is still present on nightly and beta 68.1, e.g. bp-78c0abcc-5e05-490d-8bf7-6ebd00190827

Status: VERIFIED → REOPENED
Flags: needinfo?(andrei.a.lazar)
Resolution: FIXED → ---

Bug 1575605 was tracking that I thought.

Flags: needinfo?(jcristau)

sigh ok.

Status: REOPENED → RESOLVED
Closed: 5 months ago3 months ago
Flags: needinfo?(jcristau)
Flags: needinfo?(andrei.a.lazar)
Resolution: --- → FIXED

I retested the issue on Beta 68.2b3 and Nightly 71.0a1 using a Samsung Galaxy S9 (Android 8.0.0) and the issue does no longer occurs.

Hello, I can't reproduce the issue on Firefox 68.2.0 using Nexus 9 (Android 7.1.1), Xiaomi Mi 8 Lite (Android 9) and OnePlus 5T(Android 9). Due to that, I'll close this ticket as verified, thanks.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.