Closed Bug 1561018 (geckoview-glean) Opened 5 months ago Closed 4 months ago

Replace GV's Gecko telemetry snapshot API with Glean metrics API

Categories

(GeckoView :: General, defect, P1)

All
Android
defect

Tracking

(firefox68 fix-optional, firefox69 affected)

RESOLVED DUPLICATE of bug 1566367
Tracking Status
firefox68 --- fix-optional
firefox69 --- affected

People

(Reporter: cpeterson, Assigned: esawin)

References

(Blocks 1 open bug)

Details

(Whiteboard: [geckoview:fenix:m7])

Work breakdown for moving GV from the old Gecko telemetry snapshot API to Glean:

https://docs.google.com/spreadsheets/d/1EZGVGmybvF1sH-XrsXMlplK7fWQfDniIeqXrkfDQrlc/edit#gid=1766954950

Fenix submits its app metrics using Glean. Fenix doesn't submit any Gecko telemetry because GV still uses the legacy Gecko telemetry snapshots. Until this GV bug is fixed, Fenix should submit the Gecko telemetry (like Focus+GV does):

https://github.com/mozilla-mobile/fenix/issues/3631

Alias: geckoview-glean
Depends on: 1561019
Priority: -- → P1
Whiteboard: [geckoview:fenix:m7]
See Also: → 1562267
See Also: → 1497812
Assignee: nobody → esawin
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1566367
You need to log in before you can comment on or make changes to this bug.