Closed Bug 1561465 Opened 5 months ago Closed 5 months ago

`mach build` is too verbose

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 fixed, firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Bug 1560527 was not supposed to change that, but it turns out it did, because the ifeq it copied from one place to another was wrong in the first place.

Bug 1560527 was not supposed to change verbosity for mach build, but it
turns out it did, because the ifeq it copied from one place to another
was wrong in the first place.

While here, replace a ifeq that did work with the now equivalent
BUILD_VERBOSE_LOG.

The condition that enabled ELOG to do something has been broken since
bug 279212 landed two years ago, because MAKEFLAGS doesn't contain the
dash for flags, so looking for "-s" never did anything.

Bug 1560527 changed the condition to !BUILD_VERBOSE_LOG, which as of the
previous commit, does work. This would restore the old behavior, at the
expense of build time, since it involves wrapping in a shell script,
which is not necessarily desirable (and hasn't been done for two years
now)

It is worth noting that currently this is causing a high rate of build failures due to triggering of bug 1500436.

Blocks: mach-busted
See Also: → 1500436

Comment on attachment 9074063 [details]
Bug 1561465 - Avoid being too verbose after bug 1560527.

Beta/Release Uplift Approval Request

  • User impact if declined: Logs being too verbose when they should otherwise not be after bug 1560527
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Practically NPOTB for automation.
  • String changes made/needed:
Attachment #9074063 - Flags: approval-mozilla-beta?
Attachment #9074064 - Flags: approval-mozilla-beta?

Comment on attachment 9074063 [details]
Bug 1561465 - Avoid being too verbose after bug 1560527.

a+ for 68.0b14

Attachment #9074063 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9074064 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.