Closed Bug 1561715 Opened 2 years ago Closed 10 months ago

Remove `TabGroup` in favour of `BrowsingContextGroup`

Categories

(Core :: DOM: Navigation, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla73
Fission Milestone M5b
Tracking Status
firefox73 --- disabled
firefox74 --- disabled

People

(Reporter: nika, Assigned: farre)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

These two concepts should now reflect the same idea in the in-process case, but BrowsingContextGroup now correctly exists and works across processes. At some point, we should completely rip out TabGroup, and replace it with BrowsingContextGroup to avoid having different concepts here, and make the concept more fission future-proof.

Blocks: improve-bc
Fission Milestone: ? → M5
Assignee: nobody → afarre
Blocks: 1575051
Status: NEW → ASSIGNED
No longer blocks: 1575051
Depends on: 1575051
Fission Milestone: M5 → M4
Priority: P3 → P2
Blocks: 1580191
Blocks: 1588926
Blocks: 1580194

Roll some unfixed bugs from Fission Milestone M4 to M6

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: M4 → M6

Test bug 1588926 in milestone M4.1 depends on this bug, so I am tentatively moving this bug to M4.1 too.

Fission Milestone: M6 → M4.1
Blocks: 1590048
No longer blocks: 1588926
No longer blocks: 1588926

The M4.1 test which was blocked on this is now resolved. This now blocks the M5 crashes, so moving this to M5 too.

Fission Milestone: M4.1 → M5
Attachment #9115195 - Attachment description: Bug 1561715 - Part 2: TBD! → Bug 1561715 - Part 2: Remove TabGroup::Count. r=smaug
Priority: P2 → P1
Pushed by afarre@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c201d1f7c1a8
Part 1: Remove unused functionality in SchedulerGroup. r=smaug
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Regressions: 1603733
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: mozilla73 → ---
Pushed by afarre@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/529292d8e921
Part 2: Remove TabGroup::Count. r=smaug
Status: ASSIGNED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Pushed by afarre@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/57904839c037
Part 3: Remove SchedulerGroup::IsBackground. r=smaug
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Andreas, are you still working on removing TabGroups for our Fission M5 dogfooding milestone?

No longer blocks: 1610971
Depends on: 1610971
Flags: needinfo?(afarre)

Chris: yes, occasionally now and again.

Flags: needinfo?(afarre)
Depends on: 1618236
Depends on: 1620594
No longer depends on: 1620594

I decided to finish this in bug 1620594 to not have to trouble with the existing incremental patches in this bug. I'll close this as soon as bug 1620594 is resolved.

Moving P1 M5 bugs to M5a milestone

Fission Milestone: M5 → M5a

Moving to Fission M5b because this fix is important but not top priority.

Fission Milestone: M5a → M5b
Component: DOM: Core & HTML → DOM: Navigation

depends on completely removing TabGroup in bug 1620594

Depends on: 1620594

Bug 1620594 has been fixed, and by that this bug is ready to be closed!

Status: REOPENED → RESOLVED
Closed: 1 year ago10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.