Closed Bug 1561904 Opened 1 year ago Closed 3 months ago

Stop overlapping other toolbars with the focused urlbar

Categories

(Firefox :: Address Bar, defect, P2)

defect
Points:
1

Tracking

()

RESOLVED FIXED
Firefox 71
Iteration:
71.4 - Oct 14 - 20
Tracking Status
firefox71 --- fixed

People

(Reporter: dao, Assigned: dao)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

From https://mozilla.invisionapp.com/share/DNSDVW5E8QK#/screens/367251846_Photon_Design_Update:

"When the quantumbar is automatically focused (startup, new tab, clicking home, new window) and the Bookmarks Toolbar is displayed, the toolbar will get a 10px top margin so bookmarks clear the bottom. If the quantumbar loses focus, the toolbar's margin will animate away along with the quantumbar to its unfocused state."

Points: --- → 2
Assignee: nobody → dao+bmo
Iteration: --- → 70.4 - Aug 19 - Sep 1
Iteration: 70.4 - Aug 19 - Sep 1 → 71.2 - Sept 16 - 29

I'm not quite convinced of the proposed UX here e.g. as it implies shifting the whole content area. I propose we just don't expand the urlbar at all when the bookmarks toolbar is present. mconnor is going to discuss this with verdi.

Assignee: dao+bmo → nobody
Iteration: 71.2 - Sept 16 - 29 → ---
Flags: needinfo?(mconnor)

Mike and I discussed this today and agreed that we should go ahead and implement it.

Flags: needinfo?(mconnor)
Duplicate of this bug: 1585958

(In reply to Verdi [:verdi] NI or PM me from comment #2)

Mike and I discussed this today and agreed that we should go ahead and implement it.

is "it" mean "don't expand the urlbar at all when the bookmarks toolbar is present" in comment #1 ?
if so, can we change the bug summary for clarity?

Flags: needinfo?(mverdi)

(In reply to Tooru Fujisawa [:arai] from comment #4)

(In reply to Verdi [:verdi] NI or PM me from comment #2)

Mike and I discussed this today and agreed that we should go ahead and implement it.

is "it" mean "don't expand the urlbar at all when the bookmarks toolbar is present" in comment #1 ?
if so, can we change the bug summary for clarity?

No it means we're going to do what the bug title says - shift the bookmarks toolbar downwards when the urlbar is focused in new tabs.

Flags: needinfo?(mverdi)

so, this bug covers the case for new tabs (that shows about:newtab), right?
should we open another bug for non-new tabs? or does bug 1585958 cover the case?

Flags: needinfo?(mverdi)

(In reply to Tooru Fujisawa [:arai] from comment #6)

so, this bug covers the case for new tabs (that shows about:newtab), right?

Yep.

should we open another bug for non-new tabs? or does bug 1585958 cover the case?

No. On non-new tabs we don't autofocus the address bar so it doesn't cover anything until you interact with it.

Flags: needinfo?(mverdi)

The fact that it changes the viewport of the browser is going to be pretty annoying / have side effects like content jumping around, which is not great.

I must note it's only on "(startup, new tab, clicking home, new window)", on normal focusing it won't do it.

Blocks: 1586388

How are we supposed to handle the whole content area shifting as the urlbar loses focus the moment the user interacts with the new tab page?

Flags: needinfo?(mverdi)
Keywords: blocked-ux

when (in which timing) does the bookmark bar shifts and unshifts ?
what happens when user starts interacting with bookmark bar (like, opening bookmark folder, drag and drop item) while urlbar is expanded?

No longer blocks: 1586388

The fact that it changes the viewport of the browser is going to be pretty annoying / have side effects like content jumping around, which is not great.

Also, in general, seems to conflict with the idea of compact density. Maybe disable this behavior when compact density is set?

What about extensions that change the new tab page? There is quite a few of them that use the top-most part of the page, or can be configured to do so.

I have a custom made new tab page that uses webextension API to create a bookmarks bar, and there is at least a few extensions on AMO that have the same functionality.

Maybe decrease the bottom padding of the megabar when there is a non-default new tab page so it won't cover content?

Priority: P3 → P2

(In reply to Dão Gottwald [::dao] from comment #10)

How are we supposed to handle the whole content area shifting as the urlbar loses focus the moment the user interacts with the new tab page?

I'm not quite sure what you are asking. Maybe we can delay moving the content until mouseup so that targets don't move under the pointer and maybe we can skip moving the content if another url has been requested.

Flags: needinfo?(mverdi)

(In reply to Verdi [:verdi] NI or PM me from comment #14)

(In reply to Dão Gottwald [::dao] from comment #10)

How are we supposed to handle the whole content area shifting as the urlbar loses focus the moment the user interacts with the new tab page?

I'm not quite sure what you are asking. Maybe we can delay moving the content until mouseup so that targets don't move under the pointer and maybe we can skip moving the content if another url has been requested.

about:newtab contains things that require multiple click (I mean, not something that triggers pageload by one click) to interact.

example case with Top Sites menu:

  1. click "..." button next to "Top Sites"
  2. a menu is opened under the button
  3. click a menu item there, or just click elsewhere to close the menu

another case in search field:

  1. click search field
  2. secondary click there to open context menu
  3. a context menu is opened next to the cursor
  4. click "Paste"
  5. click arrow button to search the pasted text

in both case, if a content slides up in any timing, that will be annoying.
if something else than about:newtab is opened there by extension, similar case will happen there also.

also, the same thing happens when user starts interacting with bookmark toolbar items.

Flags: needinfo?(mverdi)
See Also: → 1577340

Why not change the behavior to only expand the megabar once the user starts typing (or results are displaying via clicking the drop-down arrow)? It seems like that would address a lot of the usability/UI concerns with the current implementation/design without making the UI feel even more janky.

Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Type: enhancement → defect
Iteration: --- → 71.4 - Oct 14 - 20
Points: 2 → 3
Flags: needinfo?(mverdi)
Keywords: blocked-ux
Summary: Shift the bookmarks toolbar downwards when the urlbar is focused in new tabs → Stop overlapping other toolbars with the focused urlbar
Blocks: 1588780
Points: 3 → 1
No longer blocks: 1588780
Duplicate of this bug: 1588780
Blocks: 1585958
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e71fb039af06
Stop overlapping other toolbars with the focused urlbar. r=harry
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Blocks: 1585933
You need to log in before you can comment on or make changes to this bug.