Closed Bug 1585958 Opened Last month Closed 27 days ago

Megabar should not overlap adjacent toolbar items

Categories

(Firefox :: Address Bar, defect, P3)

71 Branch
Desktop
All
defect
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 71
Iteration:
71.4 - Oct 14 - 20
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- disabled
firefox71 --- fixed

People

(Reporter: Virtual, Assigned: dao)

References

(Blocks 2 open bugs)

Details

(4 keywords)

Attachments

(5 files)

STR:

  1. Start Mozilla Firefox with:
  • disabled "Flexible Space" from both sides of Address Bar
  • enabled "Compact" Density
  • enabled "Bookmarks Toolbar"
    and see that most bookmarks in "Bookmarks Toolbar" and buttons in Address Bar are obscured and obstructed by MegaBar by default without address bar interaction, same thing happens on opening new windows and new tabs.

Each time I have to move focus away from Address Bar to use bookmarks in "Bookmarks Toolbar" and buttons in Address Bar when I'm starting Mozilla Firefox, opening new window and new tab.

It doesn't happen in competitive browsers.

Has Regression Range: --- → yes
Has STR: --- → yes
QA Contact: Virtual

(In reply to Virtual_ManPL [:Virtual] 🇵🇱 - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #0)

and see that most bookmarks in "Bookmarks Toolbar" and buttons in Address Bar are obscured and obstructed by MegaBar by default without address bar interaction, same thing happens on opening new windows and new tabs.

This is bug 1561904

Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → DUPLICATE
Duplicate of bug: 1561904

Will 10px top margin help also with visibility of buttons in Address Bar?

Flags: needinfo?(mak77)

your should probably either morph this bug to only cover toolbar buttons covered by the side expansion, or file a specific bug for that, 2 bugs in one report is not trackable.

Flags: needinfo?(mak77)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
OS: Windows 7 → All
Hardware: x86_64 → Desktop
Summary: MegaBar is disturbing and bothering in some cases → MegaBar may cover some useful toolbar icons (Library/Home) on a customized toolbar

Please don't change the framing of this topic. There is unexpected space to the left of the TP icon and to the right of the bookmarks icon. It should not cover tabs. The address bar should have the same size when focused. I haven't seen an input field behaving so unusual like this anywhere else. Megabar was copied from Chrome, but with this regression added.
(I assume you just want users to search using your ref links, but you don't offer some built-in warmness like a Doodle or a background image in exchange. Somewhat related to search experience: Months ago my Firefox regressed to contaminate browsing history plus suggestions with "google.com" instead of "google.de" entries. Since elementary school in 2002 my muscle memory is trained to open google.de.)

Summary: MegaBar may cover some useful toolbar icons (Library/Home) on a customized toolbar → MegaBar should not cover tabs + toolbar icons
Duplicate of this bug: 1585979

(In reply to Dão Gottwald [::dao] from bug 1561904 comment #1)

I propose we just don't expand the urlbar at all when the bookmarks toolbar is present.

This should be applied also here.
urlbar shouldn't be expanded when there's no flexible space placed on both side of it.

(In reply to Tooru Fujisawa [:arai] from comment #9)

urlbar shouldn't be expanded when there's no flexible space placed on both side of it.

also, urlbar shouldn't be expanded even when there's flexible spaces if it has not enough width, due to having many toolbar icons

(In reply to Tooru Fujisawa [:arai] from comment #10)

(In reply to Tooru Fujisawa [:arai] from comment #9)

urlbar shouldn't be expanded when there's no flexible space placed on both side of it.
also, urlbar shouldn't be expanded even when there's flexible spaces if it has not enough width, due to having many toolbar icons

On a compact theme with no flexible space items it shouldn't expand on top, left and right side because
when the urlbar is focused it prevents the user to click on some elements in the UI. The user need
to first click somewhere where nothing is triggered by a click and after that they have access to the
hidden elements.

No longer blocks: 1573581
Type: defect → enhancement
Keywords: blocked-ux
Priority: -- → P5
No longer regressed by: 1577541
Type: defect → enhancement
Keywords: regression

Does this being a P5 mean this will not be fixed before shipping the megabar?

If so, some rationale for that would be appreciated. I think this is a significant usability issue.

Nope, we listen to feedback, we are working on solutions. It will require some changes and polish.
This is pretty much a meta bug at this point.

Depends on: 1586287
Keywords: meta
Priority: P5 → P3
Duplicate of this bug: 1585991
Summary: MegaBar should not cover tabs + toolbar icons → [meta] MegaBar should not cover tabs + toolbar icons

drag a selected URL in Address Bar and move mouse over Bookmarks ToolBar,
The MegaBar covers Drop Indicator, so it is hard to see the Drop Indicator.

I will admit that I initially came here with the righteous fury of a user that had their nice, familiar UI changed out from under them (https://xkcd.com/1172), but after reading through this and other related bugs (and also discovering browser.urlbar.megabar=False) I can look at this a bit more objectively now.

I would suggest that a separate preference to disable the expansion regardless of other UI state (bookmarks bar, flexible space, compact mode) would be very useful. Even in the "vanilla" layout a new profile gives, I don't think I'd want the urlbar expanding on me, as I detest unnecessary padding and whitespace that seems to be creeping into the UI of applications everywhere these days.

Other than that, I actually like that the new megabar results don't fill the whole window width unnecessarily, though until the expansion part is addressed, it will have to stay disabled on my profiles, unfortunately.

(In reply to Alice0775 White from comment #15)

drag a selected URL in Address Bar and move mouse over Bookmarks ToolBar,
The MegaBar covers Drop Indicator, so it is hard to see the Drop Indicator.

File a separate bug please.

Depends on: 1586386

(In reply to Marco Bonardo [::mak] from comment #17)

(In reply to Alice0775 White from comment #15)

drag a selected URL in Address Bar and move mouse over Bookmarks ToolBar,
The MegaBar covers Drop Indicator, so it is hard to see the Drop Indicator.

File a separate bug please.

Filed Bug 1586388 and Bug 1586392

Duplicate of this bug: 1586408
Duplicate of this bug: 1586507
Duplicate of this bug: 1587478
Depends on: 1588780
No longer depends on: 1588780
Depends on: 1561904
Assignee: nobody → dao+bmo
Iteration: --- → 71.4 - Oct 14 - 20
Points: --- → 2
Keywords: blocked-ux, meta
Summary: [meta] MegaBar should not cover tabs + toolbar icons → MegaBar should not cover tabs + toolbar icons
No longer depends on: 1586386
Duplicate of this bug: 1586386

Tabs were handled in bug 1561904.

Type: enhancement → defect
Summary: MegaBar should not cover tabs + toolbar icons → Megabar should not overlap adjacent toolbar icons
Summary: Megabar should not overlap adjacent toolbar icons → Megabar should not overlap adjacent toolbar items
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/61f7d1cc144c
Stop overlapping adjacent toolbar items with the megabar. r=harry
Blocks: 1589696
Status: NEW → RESOLVED
Closed: Last month27 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Blocks: 1585933
You need to log in before you can comment on or make changes to this bug.