Closed Bug 1569701 Opened 3 months ago Closed 2 months ago

Use GetEffectiveComputedBSize() when applying ColumnSetWrapper's block-size constraint for ColumnSet

Categories

(Core :: Layout: Columns, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: TYLin, Assigned: TYLin)

References

Details

Attachments

(3 files)

Bug 1523595 Part 3 applied ColumnSetWrapper's block-size constraint to the available size when creating BlockReflowInput for ColumnSet, but it didn't consider the case when theColumnSetWrapper is fragmented. We might want to use GetEffectiveComputedBSize to get the remaining block-size for ColumnSetWrapper.

Assignee: nobody → aethanyc
Status: NEW → ASSIGNED
Regressions: 1573759

We always pass consumed block-size into BlockReflowInput's constructor
in nsBlockFrame::Reflow(). By making mConsumedBSize a constant, its
assessor method becomes redundant.

Update the documentation to reflect the reality that ConsumedBSize()
accumulates content block-size from all previous continuations, which
was done in Bug 1506293 Part 2.

Depends on D41905

Run broken-column-rule-1.html with column-span enabled because it was
regressed by Bug 1548100 Part 2, but fixed by this patch.

Depends on D41906

Pushed by aethanyc@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e56e6ed91e5a
Part 0 - Use nscoord instead of int for contentBEnd in nsColumnSetFrame::ReflowChildren(). r=dbaron
https://hg.mozilla.org/integration/autoland/rev/6d5655c8638d
Part 1 - Make BlockReflowInput::mConsumedBSize a constant, and delete it assessor method. r=dbaron
https://hg.mozilla.org/integration/autoland/rev/e9611b9cff9a
Part 2 - Use ColumnSetWrapper's effective computed content block-size to impose constraint for ColumnSet. r=dbaron
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/18462 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Regressions: 1575106
You need to log in before you can comment on or make changes to this bug.