Closed Bug 1570282 Opened 5 years ago Closed 5 years ago

The user risks losing his password if he changes it using password generator while a login with a blank username is previously saved

Categories

(Toolkit :: Password Manager: Site Compatibility, defect)

Desktop
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1119035
Tracking Status
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- affected

People

(Reporter: danibodea, Unassigned)

References

Details

(Whiteboard: [passwords:generation] [skyline])

Attachments

(1 file)

Note

  • The user risks losing his password if he changes it using password generator while a login with a blank username is previously saved.

Affected versions

  • Nightly v70.0a1

Affected platforms

  • Windows 10
  • Mac OS 10.14

Steps to reproduce

  1. Open browser.
  2. Log into Pinterest.
  3. Save the credentials, but with a blank username (clear the username field before saving the login).
  4. Go to the Change password screen.
  5. Use the Generated password from the Password Manager drop-down to fill in generated passwords in the New and Confirmation password fields.
    NOTICE that the newly generated password is not being saved automatically (as intended), a grey key-like icon is displayed on the address bar.
  6. Finish the password saving process and confirm the password change.

Expected result

  • Google and Yahoo would have displayed a focused door hanger at this point, while Pinterest does not. The door hanger should be focused so the user can choose to save it.

Actual result

  • The door-hanger is not being focused, the gray-ley like icon remains displayed in the address bar. If the user does not click the grey key-like icon from the address bar and save the password, he will lose it.
No longer blocks: 1565409
Blocks: 1565409

Yeah, this is a known issue due to the amount of scope we had to cut to get this feature in 70. There is a whole section of the spreadsheet named "Reliably save the generated passwords for the site" to address issues of not reliably saving. Bug 1166995, bug 1548855, bug 1536728, bug 1289947 and bug 1119083 along with other bug 1119035 dependencies were all ones that could help with this problem but were cut from Skyline.

We are aware of this limitation so I will dupe to bug 1119035 for now since its dependencies will address this, just not for 70.

Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: