Closed Bug 1572698 Opened 3 months ago Closed 3 months ago

The Website Address link is wrongly displayed in the left part on RTL builds

Categories

(Firefox :: about:logins, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- verified

People

(Reporter: cosmin.muntean, Assigned: itiel_yn8)

References

Details

(Keywords: rtl, Whiteboard: [passwords:management] [skyline])

Attachments

(2 files)

[Affected Versions]:

  • Nightly 70.0a1

[Affected Platforms]

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]

  • Have the latest Nightly RTL build installed or extracted.
  • Have a Firefox profile with multiple saved logins.

[Steps to reproduce]:

  1. Open the latest Nightly RTL build with the profile from prerequisites.
  2. Navigate to "about:logins" page.
  3. Click one of the saved logins.
  4. Observe the website address link.

[Expected results]:

  • The link is correctly displayed in the right part under the "Website Address" text.

[Actual results]:

  • The link is wrongly displayed in the left near the "Launch" button.

[Notes]:

  • Attached a screenshot with the issue.

Ehsan, can you confirm the expected behaviour?

Flags: needinfo?(ehsan)
Keywords: rtl

Bug 1567546 fixed the directionality of the address field, which is nice. As far as text alignment goes, this is first and foremost a UX design matter in my opinion, so we can definitely decide that what we have here is fine. But to me this looks a bit out of place, given the rest of the alignment of the rest of the fields on this page. My opinion is that we should probably right-align this field on RTL builds for consistency with the rest...

Flags: needinfo?(ehsan)
Priority: -- → P3

Itiel, is this something you'd like to work on given that you already fixes locally ?

Flags: needinfo?(itiel_yn8)

(In reply to Tim Nguyen :ntim from comment #3)

Itiel, is this something you'd like to work on given that you already fixes locally ?

Sure thing.

Assignee: nobody → itiel_yn8
Status: NEW → ASSIGNED
Flags: needinfo?(itiel_yn8)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/3852e7ad5633
Fix the text alignment of the textboxes and the "Copied!" checkmark position for RTL r=ntim
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

This is now fixed on the main view of a login but not on edit mode. I'm planning to fully fix this in bug 1577271.

Depends on: 1578324
Flags: qe-verify+

I have verified this issue and is no longer reproducible on Firefox Beta 70.0b3 build and the latest Nightly 71.0a1 build on Windows 7 x64, Mac 10.14 and Ubuntu 16.04 x64.

  • The link is correctly displayed in the right part under the "Website Address" text on Login Item using RTL builds.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla70 → Firefox 70
Version: 70 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.