Closed Bug 1574507 Opened 1 year ago Closed 1 year ago

Update pageinfo to use SitePermissions.jsm

Categories

(SeaMonkey :: Page Info, task)

task
Not set

Tracking

(seamonkey2.49esr unaffected, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.68
Tracking Status
seamonkey2.49esr --- unaffected
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

Port parts of the following:

  • Bug 889835 - Use SitePermissions.jsm as the backend for Page Info's Permissions tab
  • Bug 894877 - permissions.js onRadioClick tries to pass a host string to SitePermissions
  • Bug 1072889 - Replace array.indexOf(...) != -1 with array.contains(...)
  • Bug 1144493 - wallpaper over enough cracks to make page info work with e10s
  • Bug 1320557 - Prevent broken UI from invalid permission states
  • Bug 1299967 - Sort page permissions list alphabetically
  • Bug 1206232 - Add temporary permission states to SitePermissions.jsm
  • Bug 1331172 - Current permission state should use the past tense
Attached patch use SitePermissions (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: Some permissions are missing
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: Some removed and one added

Attachment #9086099 - Flags: review?(frgrahl)
Attachment #9086099 - Flags: approval-comm-release?
Attachment #9086099 - Flags: approval-comm-esr60?
Blocks: 1574689

Adapted to use ChromeUtils

Attachment #9086099 - Attachment is obsolete: true
Attachment #9086099 - Flags: review?(frgrahl)
Attachment #9086099 - Flags: approval-comm-release?
Attachment #9086099 - Flags: approval-comm-esr60?
Attachment #9086248 - Flags: review?(frgrahl)
Attachment #9086248 - Flags: approval-comm-release?
Attachment #9086248 - Flags: approval-comm-esr60?

Also allow file scheme as a supported URI

Attachment #9086248 - Attachment is obsolete: true
Attachment #9086248 - Flags: review?(frgrahl)
Attachment #9086248 - Flags: approval-comm-release?
Attachment #9086248 - Flags: approval-comm-esr60?
Attachment #9088127 - Flags: review?(frgrahl)
Attachment #9088127 - Flags: approval-comm-release?
Attachment #9088127 - Flags: approval-comm-esr60?
Blocks: 1576618
Comment on attachment 9088127 [details] [diff] [review]
Use SitePermissions v1.2

r/a= me 

lgtm
Attachment #9088127 - Flags: review?(frgrahl)
Attachment #9088127 - Flags: review+
Attachment #9088127 - Flags: approval-comm-release?
Attachment #9088127 - Flags: approval-comm-release+
Attachment #9088127 - Flags: approval-comm-esr60?
Attachment #9088127 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/3fe0df4dabbb
Update pageinfo to use SitePermissions.jsm. r=frg

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.