Closed Bug 1576618 Opened 1 year ago Closed 1 year ago

Port |Bug 1330467 - Add SitePermissions APIs functions to accept principal and use them| to SeaMonkey

Categories

(SeaMonkey :: Passwords & Permissions, task)

task
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 fixed, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.68
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

Attachments

(1 file)

Port the following:

  • Bug 1330467 - part 2. Add SitePermissions APIs functions to accept principal
  • Bug 1330467 - part 3. Use principal for permissions in pageinfo/permissions.js
  • Bug 1330467 - part 5. Access permissions by principal in PermissionUI.jsm
Attached patch Use principalsSplinter Review

[Approval Request Comment]
Regression caused by (bug #): None
User impact if declined: None
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None

Attachment #9088129 - Flags: review?(frgrahl)
Attachment #9088129 - Flags: approval-comm-release?
Attachment #9088129 - Flags: approval-comm-esr60?
Comment on attachment 9088129 [details] [diff] [review]
Use principals

Works fine. r/a+++
Attachment #9088129 - Flags: review?(frgrahl)
Attachment #9088129 - Flags: review+
Attachment #9088129 - Flags: approval-comm-release?
Attachment #9088129 - Flags: approval-comm-release+
Attachment #9088129 - Flags: approval-comm-esr60?
Attachment #9088129 - Flags: approval-comm-esr60+

NIT description of isSupportedPrincipal and isSupportedURI (oversight from Bug 1574507) is wrong. We added the file protocol and it works fine. Fix it here or in a follow-up?

Flags: needinfo?(iann_bugzilla)

(In reply to Frank-Rainer Grahl (:frg) from comment #3)

NIT description of isSupportedPrincipal and isSupportedURI (oversight from Bug 1574507) is wrong. We added the file protocol and it works fine. Fix it here or in a follow-up?

Yes, remove the part of the comment about file protocol.

Flags: needinfo?(iann_bugzilla)

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/1b84ea4d5b17
Port Bug 1330467 "Add SitePermissions APIs functions to accept principal and use them" to SeaMonkey. r=frg

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.