Closed Bug 1576568 Opened 2 years ago Closed 2 years ago

Enable editor mode everywhere

Categories

(DevTools :: Console, task, P2)

task

Tracking

(firefox71+ verified, firefox72 verified)

VERIFIED FIXED
Firefox 72
Tracking Status
firefox71 + verified
firefox72 --- verified

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Since we added a deprecation warning in Scratchpad in 70, and since we talk about the editor mode as an alternative in the MDN page we link to from the deprecation message, I wonder if we could enable the editor mode in Beta for 70.

What do you think Harald?

Flags: needinfo?(hkirschner)

Yes, we should get editor mode roll into release unless any blockers get filed. So far I am not aware of any.

Flags: needinfo?(hkirschner)
Depends on: 1577074
Summary: Enable editor mode in Beta → Enable editor mode everywhere
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Depends on: 1577896
Depends on: 1580871

The focus previous element function needed to be modified
in order to not find non-visible elements.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c8a702f3b356
Enable editor mode everywhere. r=Honza.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Comment on attachment 9102523 [details]
Bug 1576568 - Enable editor mode everywhere. r=Honza.

Beta/Release Uplift Approval Request

  • User impact if declined: Users won't have access to the new editor mode in the console.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: On any page
  1. Open the webconsole
  2. There should be an icon on the end of the input
  3. Click on it

it should put the input on the left side of the panel, taking all the vertical space and adding a toolbar

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The editor mode was already in DevEdition since 70.
  • String changes made/needed:
Attachment #9102523 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9102523 [details]
Bug 1576568 - Enable editor mode everywhere. r=Honza.

Fix for a visible bug in devtools, patch with tests, uplift approved for 71 beta 4, let's have QA verify the fix in beta with the STR provided in the uplift request. Thanks!

Attachment #9102523 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Hello!
Using STR from comment 6 with Firefox 72.0a1 (20191022214314) the editor is correctly open as described on Windows 10x64, macOS 10.14 and Ubuntu 18.04.

Hello!
Verified the issue using Firefox 71.0b4 (20191023211321) from comment 9 on Windows 10x64, Ubuntu 18.04 and macOS 10.14. The editor is correctly opened as described in comment 6.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.