Closed Bug 1576600 Opened 5 months ago Closed 4 months ago

The "Learn more" text doesn't have an hover effect

Categories

(Firefox :: Protections UI, enhancement, P1)

70 Branch
enhancement

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 --- verified
firefox71 --- verified

People

(Reporter: oana.botisan, Assigned: nhnt11)

Details

(Whiteboard: [privacy-panel][skyline])

Attachments

(3 files)

Affected versions

  • Firefox 70.a01

Affected platforms

  • Windows 10 x64
  • Ubuntu 18.04 x64
  • macOS 10.13

Steps to reproduce

  1. Open any site with a new profile or click on the shield icon from URL bar and then on the "i" symbol.
  2. Hover the cursor over "Learn more".

Expected result

  • The cursor changes and the text has a link hover effect.

Actual result

  • The cursor changes.

Regression range

  • I don't think this is a regression.

Additional notes

  • Please look at the attached gif.
Whiteboard: [privacy-panel][skyline]

Should this be required for 70/Skyline, or do you want to make it a lower priority? I'd still take a patch for this in beta.

Flags: needinfo?(jhofmann)

Will triage

Flags: needinfo?(jhofmann)
Priority: -- → P1
Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d1fe84998565
Fix styling of Learn More link in protections panel info message. r=andreio

Backed out 4 changesets (bug 1583355, bug 1576600, bug 1576601, bug 1583350) for browser-chrome failures at browser/base/content/test/siteProtections/browser_protections_UI.js

Backout: https://hg.mozilla.org/integration/autoland/rev/283763664a4b94cdfe9124846cdb04114c197440

Failure push: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=d1fe84998565c0a1f22979b467eb4e21862dc5c0

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=269024083&repo=autoland&lineNumber=6488

[task 2019-09-30T11:07:41.359Z] 11:07:41 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded full_report telemetry event -
[task 2019-09-30T11:07:41.360Z] 11:07:41 INFO - Leaving test bound testShowFullReportButton
[task 2019-09-30T11:07:41.360Z] 11:07:41 INFO - Entering test bound testMiniPanel
[task 2019-09-30T11:07:41.361Z] 11:07:41 INFO - Buffered messages finished
[task 2019-09-30T11:07:41.361Z] 11:07:41 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/siteProtections/browser_protections_UI.js | The section 'protections-popup-mainView-panel-header-section' is hidden in the toast. -
[task 2019-09-30T11:07:41.362Z] 11:07:41 INFO - Stack trace:
[task 2019-09-30T11:07:41.362Z] 11:07:41 INFO - chrome://mochikit/content/browser-test.js:test_ok:1580
[task 2019-09-30T11:07:41.363Z] 11:07:41 INFO - chrome://mochitests/content/browser/browser/base/content/test/siteProtections/browser_protections_UI.js:testMiniPanel:277
[task 2019-09-30T11:07:41.363Z] 11:07:41 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1350
[task 2019-09-30T11:07:41.364Z] 11:07:41 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1385
[task 2019-09-30T11:07:41.364Z] 11:07:41 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1213
[task 2019-09-30T11:07:41.364Z] 11:07:41 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:805

Flags: needinfo?(nhnt11)
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/298653e2ce27
Fix styling of Learn More link in protections panel info message. r=andreio
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/991d6d6efcca
Ensure Learn More link is visible in dark mode. r=andreio
Flags: needinfo?(nhnt11)
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9096925 [details]
Bug 1576600 - Fix styling of Learn More link in protections panel info message. r=andreio

Beta/Release Uplift Approval Request

  • User impact if declined: Inferior Skyline feature onboarding experience.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open the protections panel and click the "i" icon. The "Learn More" link should be underlined on hover and the mouse pointer should change. The link should be white in both light and dark modes.
  • List of other uplifts needed: Bug 1583350, Bug 1576601, Bug 1576600, Bug 1583355
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small change, visual polish.
  • String changes made/needed:
Attachment #9096925 - Flags: approval-mozilla-beta?
Attachment #9097373 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9096925 [details]
Bug 1576600 - Fix styling of Learn More link in protections panel info message. r=andreio

Polish for Skyline feature, fine for uplift for beta 12.

Attachment #9096925 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9097373 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

I verified the fix using latest Nightly 71.0a1 and Firefox 70.0b12 on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.