Closed Bug 1583350 Opened 3 months ago Closed 2 months ago

[Protections Panel] Make the more info image full width with no borders

Categories

(Firefox :: Site Identity, task, P3)

task

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 --- verified
firefox71 --- verified

People

(Reporter: epang, Assigned: nhnt11)

References

(Blocks 1 open bug)

Details

(Whiteboard: [privacy-panel][skyline])

Attachments

(5 files)

Is it possible to make the image in the more info panel full width with no borders? Also, can we have the gradient background from the header expand and be the background of the image itself?

Will followup with a motion example.

Attached video more-info.mp4

When the more info icon is pressed the header gradient's background is expanded and the image and copy are revealed.

Priority: -- → P3
Whiteboard: [privacy-panel][triage][skyline] → [privacy-panel][skyline]
Attached image more-info-image.svg

SVG of the illustration that only uses white at different gradients and opacity. Should work with the light or dark background gradient.

Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/012d008e440a
Make the more info image full-width with no borders. r=johannh

Backed out 4 changesets (bug 1583355, bug 1576600, bug 1576601, bug 1583350) for browser-chrome failures at browser/base/content/test/siteProtections/browser_protections_UI.js

Backout: https://hg.mozilla.org/integration/autoland/rev/283763664a4b94cdfe9124846cdb04114c197440

Failure push: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=d1fe84998565c0a1f22979b467eb4e21862dc5c0

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=269024083&repo=autoland&lineNumber=6488

[task 2019-09-30T11:07:41.359Z] 11:07:41 INFO - TEST-PASS | browser/base/content/test/siteProtections/browser_protections_UI.js | recorded full_report telemetry event -
[task 2019-09-30T11:07:41.360Z] 11:07:41 INFO - Leaving test bound testShowFullReportButton
[task 2019-09-30T11:07:41.360Z] 11:07:41 INFO - Entering test bound testMiniPanel
[task 2019-09-30T11:07:41.361Z] 11:07:41 INFO - Buffered messages finished
[task 2019-09-30T11:07:41.361Z] 11:07:41 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/siteProtections/browser_protections_UI.js | The section 'protections-popup-mainView-panel-header-section' is hidden in the toast. -
[task 2019-09-30T11:07:41.362Z] 11:07:41 INFO - Stack trace:
[task 2019-09-30T11:07:41.362Z] 11:07:41 INFO - chrome://mochikit/content/browser-test.js:test_ok:1580
[task 2019-09-30T11:07:41.363Z] 11:07:41 INFO - chrome://mochitests/content/browser/browser/base/content/test/siteProtections/browser_protections_UI.js:testMiniPanel:277
[task 2019-09-30T11:07:41.363Z] 11:07:41 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1350
[task 2019-09-30T11:07:41.364Z] 11:07:41 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1385
[task 2019-09-30T11:07:41.364Z] 11:07:41 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1213
[task 2019-09-30T11:07:41.364Z] 11:07:41 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:805

Flags: needinfo?(nhnt11)
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/65068b971683
Make the more info image full-width with no borders. r=johannh
Flags: needinfo?(nhnt11)
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9096912 [details]
Bug 1583350 - Make the more info image full-width with no borders. r=johannh

Beta/Release Uplift Approval Request

  • User impact if declined: Inferior Skyline feature onboarding experience
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open the protections panel and click the "i" icon at the top right.
  • List of other uplifts needed: Bug 1583350, Bug 1576601, Bug 1576600, Bug 1583355
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Visual polish.
  • String changes made/needed:
Attachment #9096912 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9096912 [details]
Bug 1583350 - Make the more info image full-width with no borders. r=johannh

Polish for Skyline feature, fine for uplift for beta 12.

Attachment #9096912 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

I verified the fix using latest Nightly 71.0a1 and Firefox 70.0b12 on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64. The issue is not reproducing anymore.

However, on Ubuntu 18.04 x64 we've noticed that a white line is still present in on the border. Should I log a separate bug for this issue?

Flags: needinfo?(nhnt11)

(In reply to Oana Botisan, Desktop Release QA from comment #11)

Created attachment 9098817 [details]
imgpsh_fullsize_anim.png

I verified the fix using latest Nightly 71.0a1 and Firefox 70.0b12 on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64. The issue is not reproducing anymore.

However, on Ubuntu 18.04 x64 we've noticed that a white line is still present in on the border. Should I log a separate bug for this issue?

That looks like the usual panel border to me, nothing abnormal. Thanks!

Flags: needinfo?(nhnt11)

We've verified this fix using latest Beta 70.0b14 and Nigthly 71.0a1 across platforms: Windows 10 x64, macOS 10.14 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.