Closed Bug 1577472 Opened 3 months ago Closed 2 months ago

Always use position:absolute for the megabar so it doesn't get reframed on focus

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 71
Iteration:
71.1 - Sept 2 - 15
Tracking Status
firefox71 --- fixed

People

(Reporter: dao, Assigned: dao)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The breakout on focus breaks drag-selecting in the URL.

Depends on: 1577000
Iteration: --- → 71.1 - Sept 2 - 15

I've added click-selects-all to this bug since both issues have the same root cause. Some testing shows that this is probably related to the setting of position: absolute on #urlbar[breakout]. Remove that rule and both click and drag work fine. It seems like setting position: absolute causes the UrlbarInput._on_click handler to "forget" what it was doing. That is, it no longer recognizes mouseup to complete the click event.

Summary: Drag-select from unfocused state is broken in megabar → Drag-select from unfocused state and click-selects-all are broken in megabar
Duplicate of this bug: 1578291
Depends on: 1579051
Duplicate of this bug: 1579063
Attachment #9090761 - Attachment description: Bug 1577472 - WIP → Bug 1577472 - Always use position:absolute for the megabar so it doesn't get reframed on focus
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0d53fda7ac1e
Always use position:absolute for the megabar so it doesn't get reframed on focus r=harry
Regressions: 1580248
Blocks: 1579003
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Not fixed for me with latest Nightly on Windows 10 and Ubuntu 19.04, drag-selecting and click-selects-all still break when focusing the megabar.

(In reply to Kestrel from comment #7)

Not fixed for me with latest Nightly on Windows 10 and Ubuntu 19.04, drag-selecting and click-selects-all still break when focusing the megabar.

Thanks, I can confirm this, will file a new bug.

Summary: Drag-select from unfocused state and click-selects-all are broken in megabar → Always use position:absolute for the megabar so it doesn't get reframed on focus
Blocks: 1580538
Regressions: gigabar
You need to log in before you can comment on or make changes to this bug.