Closed Bug 1581482 Opened 5 months ago Closed 5 months ago

Subject label has disappeared from screen reader (Daily 71)

Categories

(Thunderbird :: Disability Access, defect)

defect
Not set

Tracking

(thunderbird71 verified)

RESOLVED FIXED
Thunderbird 71.0
Tracking Status
thunderbird71 --- verified

People

(Reporter: jpmengual, Assigned: aleca)

References

(Regression)

Details

(Keywords: access, regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

In the latest nightly (regression introduced about 3 days ago):

  1. ctrl-n
  2. tab until the subject field

Actual results:

The screen reader does not say the field label

Expected results:

Should say "Subject", sent to at-spi. The label is no longer there

I'm pretty sure this is from bug 1563121.

Flags: needinfo?(alessandro)
Regressed by: 1563121
Summary: Subject labbel has disappeared → Subject labbel has disappeared (Daily 71)
Version: 71 → Trunk
Summary: Subject labbel has disappeared (Daily 71) → Subject label has disappeared (Daily 71)

Maybe msgSubject needs a aria-labelledby="subjectLabel"
https://searchfox.org/comm-central/rev/45e763ae702e00168ffc2e8287315c2d1e5efffd/mail/components/compose/content/messengercompose.xul#2070

I suppose the xul controls= could have added that automatically earlier?

Keywords: access, regression
Summary: Subject label has disappeared (Daily 71) → Subject label has disappeared from screen reader (Daily 71)
Assignee: nobody → alessandro
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(alessandro)
See Also: → 1582929
Duplicate of this bug: 1583205
Attachment #9096961 - Flags: review?(mkmelin+mozilla)
Status: NEW → ASSIGNED
Attachment #9096961 - Flags: review?(mkmelin+mozilla) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/a05365ba5266
Fix missing aria label on the Subject field of the compose dialog. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 71.0

Hi,

I confirm the bug is fixed. Great

Thanks

Regards

You need to log in before you can comment on or make changes to this bug.