[BETA][DOGFOOD]No proxy authentication

VERIFIED DUPLICATE of bug 22405

Status

()

defect
P3
blocker
VERIFIED DUPLICATE of bug 22405
20 years ago
18 years ago

People

(Reporter: Glenn.McGrath, Assigned: warrensomebody)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

Reporter

Description

20 years ago
Bug 8559 says that proxy's are supported now, so i entered my proxy details in
the preferences.
The folling is in my PREF.JS file

user_pref("network.proxy.http", "proxy.jcu.edu.au");
user_pref("network.proxy.http_port", 8080);
user_pref("network.proxy.type", 1);

With other browsers when i contact the proxy i get a dialog box where i enter
username/password for proxy authentication, i dont get that dialog box with
mozilla M10

I get a message from my proxy server saying i need a HTTP/1.1 compliant browser.
I read on another page that authentication worked, but it doesnt appear to for
me.

Apprunner reports that the web page loaded succesfully, but the browseer doesnt
display it.
OS: Windows 98 → All
(Changing OSes to `All' -- verified on MacOS build)

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 2

20 years ago
*** Bug 17240 has been marked as a duplicate of this bug. ***

Comment 3

20 years ago
*** Bug 15175 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Target Milestone: M12
Hardware: PC → All
[changing Platform to All -- forgot to do that earlier]

Any sign of movement on this? It's my main Dogfood bug ... I, and probably a fair
few other people at universities and other proxy-bound institutions, can't test
Mozilla seriously without having access to proxied sites.

Comment 5

20 years ago
I cant promise you too much but the solution is very similar to another bug
relating to persistent authentication. I am hoping to fix both for M12 so hang
in there...

Updated

20 years ago
Blocks: 18471

Updated

20 years ago
Assignee: gagan → valeski
Status: ASSIGNED → NEW

Comment 6

20 years ago
Is this related to bug #6144?   Since bug #6144 seems almost fixed, can this one
be easily fixed also?

Updated

20 years ago
Assignee: valeski → gagan

Comment 7

20 years ago
this bug is not related to 6144. This is pure proxy authentication.

Comment 8

20 years ago
*** Bug 19544 has been marked as a duplicate of this bug. ***

Comment 9

20 years ago
Moving Assignee from gagan to warren since he is away.

Updated

20 years ago
Summary: No proxy authentication → [DOGFOOD]No proxy authentication

Updated

20 years ago
Whiteboard: should be PDT+ because it is blocking many people from using browser, and is 3rd most voted for browser bug

Comment 10

20 years ago
important beta bug but we work around it for Netscape dogfood.  Let's try to fix
it for beta....coming soon.

Updated

20 years ago
Whiteboard: should be PDT+ because it is blocking many people from using browser, and is 3rd most voted for browser bug → [PDT-] should be PDT+ because it is blocking many people from using browser, and is 3rd most voted for browser bug

Comment 11

20 years ago
adding PDT-., forgot to do that on the last comment.

Updated

20 years ago
Summary: [DOGFOOD]No proxy authentication → [BETA][DOGFOOD]No proxy authentication
Whiteboard: [PDT-] should be PDT+ because it is blocking many people from using browser, and is 3rd most voted for browser bug → [PDT-]
Assignee

Updated

20 years ago
Blocks: 20400
Assignee

Updated

20 years ago
Target Milestone: M12 → M14

Comment 12

20 years ago
Bulk move of all Networking-Core (to be deleted component) bugs to new
Networking component.

Updated

20 years ago
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE

Comment 13

20 years ago
*** This bug has been marked as a duplicate of 22405 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 14

20 years ago
verified duplicate of 22405

Comment 15

20 years ago
*** Bug 22904 has been marked as a duplicate of this bug. ***

Updated

19 years ago
No longer blocks: 18471
You need to log in before you can comment on or make changes to this bug.