Closed Bug 1598464 Opened 9 months ago Closed 3 months ago

Stop pre-filtering logins from autocomplete and the context menu to about:logins

Categories

(Toolkit :: Password Manager, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
mozilla77
Tracking Status
firefox77 --- verified

People

(Reporter: MattN, Assigned: bdanforth)

References

(Blocks 2 open bugs)

Details

(Keywords: parity-chrome, parity-safari)

Attachments

(2 files)

Since autocomplete and the context menu both show a superset of the logins available in about:logins when View Saved Logins is currently chosen due to the filter argument, it's more confusing than helpful to continue to pre-filter the results.

I think for now we can probably leave the pageinfo entrypoint doing the pre-filtering since the user is expecting to only see ones for the site in that case.

Blocks: 1609853
No longer blocks: 1595915
Duplicate of this bug: 1610443
Blocks: 1567822
See Also: → 1599910
Blocks: 1423733
Assignee: nobody → bdanforth
Status: NEW → ASSIGNED
Attachment #9143822 - Attachment description: Bug 1598464 - Stop pre-filtering logins from autocomplete to about:logins → Bug 1598464 - Stop pre-filtering logins from autocomplete to about:logins. r=MattN

Try server push

  • ./mach try fuzzy toolkit/components/passwordmgr/ browser/components/aboutlogins/ except Android tests

test-verify push

  • TV job added through Phabricator due to Bug 1598776; OSX omitted, since I develop on OSX and did a local TV run.

Landing of this bug failed due to:
"Reason:
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

applying /tmp/tmpuBXDtQ
toolkit/components/passwordmgr/LoginAutoComplete.jsm
Hunk #1 FAILED at 728.
1 out of 1 hunk FAILED -- saving rejects to file toolkit/components/passwordmgr/LoginAutoComplete.jsm.rej"

:bdanforth can you please take a look?

Flags: needinfo?(bdanforth)

Thanks for letting me know. I addressed the merge conflict, pushed an updated revision and re-added the Check-in Needed tag in Phabricator. It should be ready to land now.

Flags: needinfo?(bdanforth)
Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7f905e02d117
Stop pre-filtering logins from autocomplete to about:logins. r=MattN
https://hg.mozilla.org/integration/autoland/rev/e061b7e371f6
Stop pre-filtering logins from the context menu to about:logins. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77

I have verified this issue and the logins from "about:logins" page are no longer pre-filtered in the following cases:

  • If the "View Saved Logins" option is clicked from the autocomplete menu, the logins are no longer filtered after the used website.
  • If the "View Saved Logins" option is clicked from the context menu, the logins are no longer filtered after the used website.

Tested on the latest Nightly 77.0a1 build (Build ID 20200430082621) on Windows 10 x64, Mac 10.14.6 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.