Crash when playing QuickTime Movie - [@ QuickTimeEssentials.qtx]

RESOLVED INVALID

Status

Plugins Graveyard
QuickTime (Apple)
P3
critical
RESOLVED INVALID
16 years ago
2 years ago

People

(Reporter: Torben, Unassigned)

Tracking

({crash, topcrash-, topembed-})

Details

(Whiteboard: [PL2:Vendor][THIS IS NOT A MOZILLA ISSUE -- THIS IS A QUICKTIME ISSUE], crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.1b) Gecko/20020728
BuildID:    2002072818

When you play the movie at
http://www.apple.com/quicktime/download/theater/edit.html Mozilla will crash
(invalid pagefault in modul quicktime.qts). Other QT movies work fine.

Reproducible: Always
Steps to Reproduce:
1. Open URL
2. When page has finnished loading, click to play the movie.

Actual Results:  Mozilla crashes. The movie will however keep playing until you
click close in the dialog.

Expected Results:  No chrash

Also reported in the newsgroup (netscape.mozilla.user.win32) with moz1.0 and
build 2002072508 under Win 98.

Talkback ID TB8775620G

Comment 1

16 years ago
Dupe of bug 159923 ?
Severity: normal → critical
Keywords: crash, stackwanted
Whiteboard: TB8775620G

Comment 2

16 years ago
Boris, should I ask you for TB8775620G?

Comment 3

16 years ago
Incidetn #8775620
-----------------
Product ID MozillaTrunk
Build ID 2002072818
Operating System Windows 95 4.0 build 67109975

QUICKTIME.QTS + 0x116ee (0x668116ee)
0x56524400 

Updated

16 years ago
Keywords: stackwanted
Whiteboard: TB8775620G

Comment 4

16 years ago
Reporter, what version of QuickTime was this ?

dupe of bug 157631 ? (crash in Quicktime 6 on MacOS 9, with the scriptable plugin)
(Reporter)

Comment 5

16 years ago
Re comment 1 and 4: bug 159923 and bug 157631 both works for me, using QT 6.0

However, playing the movie directly in QT gives the exact same crash, so must be
a bug in QT not Mozilla, except that QT shouldn't take mozilla down when it crashes.

Resolving this bug as invalid, sorry for not checking with QT before filling
this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 6

16 years ago
amreopening this one..just to keep a track on whether apple fixes this or not. 
I could repro the same crash on today's branch build 0807 on windows using 
qktime6
go here

http://www.apple.com/trailers/wb/analyze_that.html

'click ot play'

let robert De nero cry...click on the movie progress somewhere behind where it 
is actually so that the movie tries to rewind and play again..

same crsah

qktime.qts.  Makes our browser look bad since qktime take sit down too.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Summary: Crash when playing QuickTime Movie → [CRASH IN QUICKTIME PLUGIN CODE] Browser crashes when playing QuickTime Movie

Updated

16 years ago
Priority: -- → P3
Summary: [CRASH IN QUICKTIME PLUGIN CODE] Browser crashes when playing QuickTime Movie → Crash when playing QuickTime Movie
Whiteboard: [PL2:Vendor][THIS IS NOT A MOZILLA ISSUE -- THIS IS A QUICKTIME ISSUE]
Target Milestone: --- → Future

Comment 7

16 years ago
http://www.greatestplaces.org/medias/media_html/sounds.html (on this page, click  
the second link 'shaman singing'). Yhis will bring your app down. Still 
happening on 1016 trunk build with quicktime 6.0. What can be done about this ?
 

Comment 8

16 years ago
still happens on 1021 trunk.

Comment 9

16 years ago
*** Bug 166692 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
*** Bug 168006 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

16 years ago
Apple have updated the QuickTime-plugin (available through QuickTime Updater,
the version is still 6.0). For me it still crashes un the url in comment 0
(Talkback IDs TB13004619W and TB13004619W).

shrirang, you might want to check your URLs too.

Comment 12

16 years ago
Not seeing link in comment #7 crash Mozilla trunk build 2002102308.  This link
is audio only -- could this give us a clue here?  Most of the video on Apple's
website is MPEG-4... unless it says you need QT 5.  Hmmm.

Mac OS 9.2.2, QT 6.0.2.  This same build will crash when leaving a page with a
QT video movie.  See my MacsBug stdlog for bug #157631.

Comment 13

16 years ago
Internal reference:
http://bugscape.mcom.com/show_bug.cgi?id=19549

Keywords: topembed+

Comment 14

16 years ago
Another internal Reference:
http://bugscape.netscape.com/show_bug.cgi?id=19550

Comment 15

16 years ago
My bug is related if not the same.  When I go to http://www.apple.com/trailers
and try to open trailers in new tabs I start getting the spinning beach ball all
the time, I cannot pause the playback, I cannot switch tabs, cannot do much of
anything other than force quit Mozilla.  I tried the nightly build from 11/20/02
and got the same thing.  The same stuff works fine with Internet Explorer.
(Reporter)

Comment 16

16 years ago
Nate, I doubt that your problem and this bug are the same, your problem sounds
more like these bugs: bug 104970, Bug 123168, Bug 151923, or Bug 167199.

Comment 17

16 years ago
This is not a mozilla issue, removing the topembed+
Keywords: topembed+ → topembed-

Comment 18

16 years ago
reassign
Assignee: beppe → peterl

Comment 19

16 years ago
beppe: why do we think this is not a mozilla issue?  if mozilla crashes just
because a poorly written plugin croaks, that's an issue.  i lost a lot of state
last time quicktime bit me :(

additional talkback id's:
TB13616158Q
TB15110009W

using Moz 1.2b on XP

marc
(Reporter)

Comment 20

16 years ago
Marc, that would probably be bug 156493, maybe also related to bug 115903. But I
do agree with your point, a plugin should not be able to make mozilla crash.

Comment 21

16 years ago
I'm not crashing on any of these pages with a trunk build on WinXP. 

If anyone is still crashing, can you please paste the URL to the SRC/DATA media
file along with the URL to the page that is causing the crash. Be sure you have
the lastest trunk build and latest Quicktime update.
(Reporter)

Comment 22

16 years ago
With Mozilla 1.3a (2002121215) and QT 6.0.2 the URL in comment 0 no longer
crashes for me. I get a warning that "The plugin performed an illegal operation.
You are strongly recommended to restart navigator", if I ignore this the movie
plays just fine even though it still crash if I try to play it directly in the
QT player.

Since I am the orginal reporter I am taking the liberty to resolve as fixed, if
someone still crashes feel free to reopen. Also feel free to reresolve as a dupe
if you know which check-in fixed this.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 23

15 years ago
Adding topcrash keyword and  [@ QuickTimeEssentials.qtx] to summary for future
reference.  Talkback is reporting crashes under that signature for many Mozilla
and Netscape releases...so just want to make sure we have a tracking bug for
those crashes.

I see crashes in recent MozillaTrunk builds, as well as Mozilla FireBird .06. 
Here is the latest Talkback data in case anyone wants to take a look into
this...but assuming this really isn't a Mozilla issue, I guess there isn't much
we can do about it:
Rank    StackSignature    Count  

6   QuickTimeEssentials.qtx   131 
 
====================================================================================================
     Count   Offset    Real Signature
[ 35   QuickTimeEssentials.qtx + 0x9712 (0x672c9712) 47de6bea -
QuickTimeEssentials.qtx + 0x9712 (0x672c9712) ]
[ 18   QuickTimeEssentials.qtx + 0x9712 (0x672d9712) 06064982 -
QuickTimeEssentials.qtx + 0x9712 (0x672d9712) ]
[ 5   QuickTimeEssentials.qtx + 0x4ac2 (0x672c4ac2) 14bcffb1 -
QuickTimeEssentials.qtx + 0x4ac2 (0x672c4ac2) ]
[ 4   QuickTimeEssentials.qtx + 0x9b26 (0x672c9b26) 5bf742e1 -
QuickTimeEssentials.qtx + 0x9b26 (0x672c9b26) ]
[ 3   QuickTimeEssentials.qtx + 0x9b26 (0x672d9b26) 1a2f6089 -
QuickTimeEssentials.qtx + 0x9b26 (0x672d9b26) ]
[ 3   QuickTimeEssentials.qtx + 0x9582 (0x631c9582) 3fff8404 -
QuickTimeEssentials.qtx + 0x9582 (0x631c9582) ]
[ 3   QuickTimeEssentials.qtx + 0x176fc (0x672e76fc) 9d09031e -
QuickTimeEssentials.qtx + 0x176fc (0x672e76fc) ]
[ 2   QuickTimeEssentials.qtx + 0x4d3b (0x672c4d3b) ae1e6893 -
QuickTimeEssentials.qtx + 0x4d3b (0x672c4d3b) ]
[ 2   QuickTimeEssentials.qtx + 0x4bc2 (0x672c4bc2) 04138c91 -
QuickTimeEssentials.qtx + 0x4bc2 (0x672c4bc2) ]
[ 2   QuickTimeEssentials.qtx + 0x30c8 (0x672c30c8) fa8f1adb -
QuickTimeEssentials.qtx + 0x30c8 (0x672c30c8) ]
[ 1   QuickTimeEssentials.qtx + 0x9996 (0x631c9996) ffaf026b -
QuickTimeEssentials.qtx + 0x9996 (0x631c9996) ]
[ 1   QuickTimeEssentials.qtx + 0x924c (0x631c924c) 72fb60d7 -
QuickTimeEssentials.qtx + 0x924c (0x631c924c) ]
[ 1   QuickTimeEssentials.qtx + 0x4cb9 (0x631c4cb9) a9dd0110 -
QuickTimeEssentials.qtx + 0x4cb9 (0x631c4cb9) ]
[ 1   QuickTimeEssentials.qtx + 0x4c89 (0x672d4c89) 8b11c05d -
QuickTimeEssentials.qtx + 0x4c89 (0x672d4c89) ]
 
     Crash date range: 2003-06-06 to 2003-06-15
     Min/Max Seconds since last crash: 51 - 2352741
     Min/Max Runtime: 191 - 11950041
 
     Count   Platform List 
     49   Windows NT 5.1 build 2600
     30   Windows NT 5.0 build 2195
     2   Windows NT 4.0 build 1381
 
     Count   Build Id List 
     81   2003051616
 
     No of Unique Users        76
 
 Stack trace(Frame) 

	 QuickTimeEssentials.qtx + 0x9712 (0x672c9712)   
 
     (21064243)	URL: http://img-nex.theonering.net/movies/gollum_mtvawards_Bband.mov
     (21064243)	Comments: I was viewing a quicktime movie and as I paused it
Firebird crashed.
     (21045655)	Comments: kazaa opens up a window to play a in program .mov
file. I tried to pause the movie it when BOOM.
     (21040772)	URL: ebay.com
     (21028144)	Comments: quicktime movie playing in satellite window  Firebird
crashed when movie got to the point where it needed to catch up with download. 
     (20988111)	Comments: Watching a Quicktime movie  of Gollum accepting MTV award.
     (20978021)	URL: www.blancolioni.org/gollum.mov
     (20972432)	URL: http://www.theonering.net/scrapbook/view/6856
     (20972432)	Comments: adjusting the volume on the quicktime video.   
firebird has crashed a number of times when working with media files... in fact
 that (working with video) seems to be the ONLY thing that will crash my
firebird consistently.    by the way; you guys are
     (20972432)	Comments:  doing a freakin' great job with this browser. 
phoenix and firebird are all i've been using for the last 5 or 6 months.  keep
up the good work.  it's appreciated.
     (20953683)	URL: http://idg.se/cs (therunder  the advanced search page)
     (20929469)	URL: www.comingsoon.net
     (20929469)	Comments: still problems loading quicktime movies in the browser
     (20906981)	URL: yahoo.com
     (20906981)	Comments: watching a quicktime embedded movie
     (20900561)	URL: apple.com
     (20900561)	Comments: quicktime movie
     (20897029)	Comments: playing a quicktime video. crashed the instant i
changed the volume on my ibm t23 laptop. 
     (20888487)	URL: http://www.tokyodv.com/news/Robodex2003Montage.html
     (20888487)	Comments: watching a quicktime video and either switching tabs
or clicking another link (can't recall)
     (20885270)	Comments: Watching a quick time feed  (unrelated? and adjusting
the sound control (not of the quick time app but of the system))
     (20875497)	URL: markwalker.reebok.com
     (20875497)	Comments: Trying to watch quicktime movie
     (20875040)	URL: http://www.boardsmag.com/screeningroom/commercials/
     (20875040)	Comments: Watching QT movie. This happens commonly with Moz
Firebird. May be a QT problem  because it has happened once or twice with IE as
well.
     (20870815)	Comments: Watching the MTV awards snippet where "Golum" wins the
virtual performance award. Follow the link from Slashdot and load the broadband
.mov file to see it.
     (20863367)	Comments: watching a quicktime movie.
     (20861893)	Comments: was watching a quicktime video.. refreshed the page by
clicking the URL bar and pressing "enter" <crash>    Thanks ;-)
     (20860131)	URL: www.img-nex.com
     (20860131)	Comments: changing the volume of a quicktime movie during
playback using the plugin's volume control
     (20856217)	URL: www.google.com
     (20856214)	URL: https://webmail.ualberta.ca
     (20856214)	Comments: Its impossible to write what url it was  -watching a
quicktime movie clip.
     (20854421)	URL: http://www.streamload.com/steve/gollum_mtvawards_Bband.mov
     (20854421)	Comments: nothing at all =)
     (20853591)	URL: http://img-nex.theonering.net/movies/gollum_mtvawards_Bband.mov
     (20853591)	Comments: watching a quicktime movie
     (20853059)	URL:
http://www.amazon.com/exec/obidos/flex-sign-in/102-9738021-1128914?opt=af&response=subst/misc/amazon-cobrand-cc/v3/marketing-from-siteskin-step2.html&ccc=1
     (20853059)	Comments: Watching a quicktime video  trying to move the window  
     (20849512)	Comments: qt movie
     (20849320)	Comments: while watching a quicktime clip  i tried to increase
the volume using the jog shuttle on my logitech elite keyboard... this heyboard
displays a on screen indicator for the volume... 
     (20849318)	Comments: closing the LOTR MTV video of Golum acceptance speach
     (20849266)	Comments: playing a .mov file in quicktime
     (20848587)	Comments: Quicktime movie had just finished playing
     (20848053)	URL: http://www.streamload.com/steve/gollum_mtvawards_Bband.mov
     (20848053)	Comments: watching a quicktime movie 
     (20843437)	URL: http://img-nex.theonering.net/movies/gollum_mtvawards_Bband.mov
     (20843437)	Comments: I followed a link from http://buzz.bazooka.se which
sent me to http://www.theonering.net/scrapbook/view/6856. I clicked on the 8.2
meg .mov file and it started loading but when it had preloaded enough and
started to playback the file it crasched. I had 3
     (20843437)	Comments:  browser windows open and no other programs running at
the time. Quicktime version is 6.1.
     (20833236)	URL:
http://mediaviewer.ign.com/ignMediaPage.jsp?media_id=1740758&object_id=568236&channel_id=70&page_title=Way+of+the+Samurai+2&adString=network%3Dign%26site%3Dps2%26pagetype%3Dvideo&return_url=http%3A%2F%2Fps2.ign.com%2Fobjects%2F568%2F568236.html
     (20833236)	Comments: playing the following quicktime file:
http://ps2movies.ign.com/ps2/video/waySamurai2Trailer_free.mov  
     (20817251)	Comments: Watching a Quciktime movie  what else?  This ALWAYS
crashes Mozilla


Reopening for now in case Peter wants to look into these recent crashes with
FireBird.  If not, please return this to worksforme or something.  Thanks.
Status: RESOLVED → REOPENED
Keywords: topcrash
Resolution: FIXED → ---
Summary: Crash when playing QuickTime Movie → Crash when playing QuickTime Movie - [@ QuickTimeEssentials.qtx]

Comment 24

15 years ago
hm...I'm not crahing with those urls in a recent trunk build of seamonkey but I
am using QT 6.0.2.10.

If anyone is able to reproudce, we need this info:
browser version: seamonkey/camino/firebird and the build ID (please use a daily
trunk)
quicktime version: shows up in about:plugins
testcase URL: please extract the media URL (the WAV or MOV file) from the HTML
page that crashes.

Also, please check if clearning your cache or creating a new profile has any
effects.

This information will greatly help narrow down the cause of these crashes.

Comment 25

14 years ago
ALL INSTANCES CRASH:

This URL crashes the latest release versions of Mozilla, Mozilla Firefox, and IE:
http://www.deadtroll.com/index2.html?/video/livehelldesk.html~content

However, the bug in QuickTime crashes only ONE instance of IE, if more than one
are running. The bug crashes ALL instances of Mozilla and Mozilla FireFox.

Comment 26

14 years ago
Created attachment 142057 [details]
Windows XP Microsoft Error Report file

Mozilla FireFox crash database, from Microsoft Error reporting, as requested.
Always crashes ALL INSTANCES when visiting this link:
http://www.deadtroll.com/index2.html?/video/livehelldesk.html~content

Comment 27

14 years ago
Mozilla FireFox crash database, from Microsoft Error reporting, as requested.
Always crashes ALL INSTANCES when visiting this link:
http://www.deadtroll.com/index2.html?/video/livehelldesk.html~content

See attachment.
> The bug crashes ALL instances of Mozilla and Mozilla FireFox

There is never more than one instance running, so.....
(In reply to comment #25)
> However, the bug in QuickTime crashes only ONE instance of IE, if more than one
> are running. The bug crashes ALL instances of Mozilla and Mozilla FireFox.

No, only one instance of mozilla crashes. that single isntance manages all the
open windows, though.

Comment 30

14 years ago
Marking this topcrash- to get it off the radar.  Hopefully the next version of
QT helps prevent some of these crashes...whenever that might be released.
Keywords: topcrash → topcrash-

Comment 31

14 years ago
WMF, and also crashes IE6.  Not a FF bug, therefore.

Comment 32

12 years ago
I am also seeing a crash when trying to play a QuickTime movie in Firefox.

Firefox Version:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

Plug-In Version:
QuickTime Plug-in 6.5.1

The file I am trying to play is:
http://movies.crooksandliars.com/WH-Dinner-Colber.mov

This crash is a hard crash... Firefox just dies with no error report from Windows and no feedback assistant from Firefox.  Firefox doesn't even know that it crashed.  Any settings made during the session are lost.

Comment 33

12 years ago
URLs in comment #27 and #32 WFM with Camino trunk build 2006102501 (v1.2+) running under Mac OS 10.3.9, and QT 7.1.3.

This bug may only occur with QT version 6.x.

Comment 34

11 years ago
Reassigning (+QA) to component defaults.
Assignee: peterl-bugs → nobody
Status: REOPENED → NEW
QA Contact: shrir → plugins

Comment 35

11 years ago
Created attachment 279191 [details]
Mini-Crash Dump of Firefox vs. QuickTime

There sure is a lot of yada, yada, yada going on about this problem. I have NEVER been able to play a QuickTime movie with Firefox; it has always crashed, regardless of the version, and all I was doing was trying to view a video ... on any site. Nothing fancy at all. I have the mini-crash dump files attached in case someone who knows how to read them would do so. I'm running Windows XP Pro 32-bit on a cable-connection with the latest Firefox & QuickTime. Ahem!

Comment 36

10 years ago
I'm adding one more link to this, so far reproducible every time on my side:

http://www.scene.org/file_dl.php?url=http://http.de.scene.org/pub/parties/2008/breakpoint08/demo/videos/farbrausch_neuro-masagin.mp4&id=501726

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13 

local QT version is 7.2

Comment 37

10 years ago
I just downloaded Firefox 3 RC2 this morning and was watching a video on the code igniter site and every time I get about 3/4 the way through it Firefox crashes.

Link: http://codeigniter.com/tutorials/watch/intro/

I have tried 3 times and it crashes every time.

Updated

8 years ago
Component: Plug-ins → QuickTime (Apple)
Product: Core → Plugins
QA Contact: plugins → apple-quicktime
Target Milestone: Future → ---
Version: Trunk → unspecified
(Assignee)

Updated

7 years ago
Crash Signature: [@ QuickTimeEssentials.qtx]

Comment 38

6 years ago
QuickTimeEssentials.qtx doesn't show up in crash reports any more, so I guess this particular part of QT is irrelevant now. Please file new bugs with links to actual crash reports for new QuickTime issues.
Status: NEW → RESOLVED
Last Resolved: 16 years ago6 years ago
Resolution: --- → INVALID
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.