middle mouse button doesn't open new tab

RESOLVED DUPLICATE of bug 151249

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 151249
16 years ago
10 years ago

People

(Reporter: Max Waterman, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020727
BuildID:    2002072703

On IRIX and Linux, there is an option such that clicking on an 'http://' link
using the middle mouse button will open a new tab displaying that link.

On Mac OS X, clicking the middle mouse button has no effect (even with the
option enabled).

Control-click is also an option which is supposed to open the link in a new tab,
but which also has no effect on OS X.

Max.
Max.

Reproducible: Always
Steps to Reproduce:
1.enable preference to open link in new tab for middle click and control click
2.middle click on a link and/or control click on a link
3.

Actual Results:  Nothing happens.

(control-click seems to be the same as a right click)

Expected Results:  should open a new tab with the link loading

Comment 1

16 years ago
What kind of mouse?
Possible dup of bug 151249.
Possibly related: bug 106692, bug 106215
(Reporter)

Comment 2

16 years ago
> ------- Additional Comments From dark@c2i.net  2002-07-29 15:18 -------
> What kind of mouse?

Two Logitech mice (at different locations), neither of which has the
middle-mouse functionality, and one of which is supported by the new logitech
mouse drivers (they only support USB keyboard/mice, and the other one I have is
a PS/2).

Ref Logitech Command Centre, which is now at versions 1.0.0 (ie released, no
longer beta) <http://www.versiontracker.com/moreinfo.fcgi?id=14421&db=mac>

> Possible dup of bug 151249.

Yup, I think so, though with a different mouse. I don't think the type of mouse
makes any difference (I'm pretty sure I've used other mice also with 3 buttons,
and none of them work).

> Possibly related: bug 106692, bug 106215

Yup, sounds likely.

Max.

Comment 3

16 years ago
And you have this in your prefs?

user_pref("middlemouse.openNewWindow", true);
(Reporter)

Comment 4

16 years ago
> ------- Additional Comments From dark@c2i.net  2002-07-29 16:43 -------
> And you have this in your prefs?
> 
> user_pref("middlemouse.openNewWindow", true);

Er, I do now, and it doesn't make any difference, as far as I can tell.

Max.

Comment 5

16 years ago
hmm. Keep in mind that mozilla must be closed when you edit prefs.js - or
changes are overwritten on quit. (And changes won't take effect untill a fresh
start.)
(Reporter)

Comment 6

16 years ago
> ------- Additional Comments From dark@c2i.net  2002-07-29 16:55 -------
> hmm. Keep in mind that mozilla must be closed when you edit prefs.js - or
> changes are overwritten on quit. (And changes won't take effect untill a fresh
> start.)

I kept that in mind when I did it....and...checking...yes, the preferences did
stick.

Max.
(Assignee)

Comment 7

16 years ago
I've been using command+click for a while on Mac OS X, so that should at least
work, if you have all your prefs set correctly. I realize the preference text
says "control+click", that should be command+click on the Mac, unfortunately we
haven't gotten around yet to fixing that text.
(Reporter)

Comment 8

16 years ago
re command-click

Indeed it does! I more than likely was misled by the word 'control' in prefs.

Thanks for the w/a.

Max.

Comment 9

16 years ago
Confirmed using FizzillaCFM/2002072203 and a Kensington Optical Pro mouse.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: sairuh → pmac

Comment 10

16 years ago
I just filed bug 180799 to fix the text in Preferences.  Definitely a dupe of
bug 151249, and I'd figured something like bug 106692 was the answer. :-)

Comment 11

16 years ago
Very simply, Mozilla on MacOS X doesn't recognize the middle mouse button. This
is easily confirmed by attaching a mousedown event handler on a page to alert
all mouse presses. so 151249 and this are symptoms of 106692

Comment 12

16 years ago
*** Bug 181358 has been marked as a duplicate of this bug. ***
*** Bug 198558 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
Camino, however, does not have this bug (ie. middle button opens a new tab just
fine). Using a Microsoft optical wheel mouse (USB). I'm seeing the same thing in
Mozilla as Max has.

Comment 15

15 years ago
Just another confirm, and this is hugely annoying because of my usage of Moz on
Win & Linux. Middle-button is ingrained in my habits, and making moz really hard
to use on Mac OS X. Safari does support this.

Comment 16

15 years ago
This bug is the main reason why I haven't migrated to Firefox.
*** Bug 204640 has been marked as a duplicate of this bug. ***

Comment 18

14 years ago
it should be noted that the middle click support should address not only opening
links in a new tab, but also when middle-clicking on an already opened tab, the
tab should close.  This appears to be the way the Linux and Windows versions behave.

Comment 19

14 years ago
(In reply to comment #18)
> it should be noted that the middle click support should address not only opening
> links in a new tab, but also when middle-clicking on an already opened tab, the
> tab should close.  This appears to be the way the Linux and Windows versions
behave.

Preliminary patch for bug 151249 resolves this. As far as I can see this bug is
pretty much a duplicate of that one, rather than dependent on it.

Comment 20

14 years ago
Definitely looks like a duplicate, and having both open is fragmenting discussion. 

*** This bug has been marked as a duplicate of 151249 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
No longer depends on: 151249
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.