Last Comment Bug 160261 - (TIFF) [RFE] TIFF Support?
(TIFF)
: [RFE] TIFF Support?
Status: RESOLVED WONTFIX
parity-safari
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All All
: -- enhancement with 41 votes (vote)
: Future
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.eluxury.com/browse/section...
: 171514 221333 408197 (view as bug list)
Depends on:
Blocks: wontfix+addonwanted
  Show dependency treegraph
 
Reported: 2002-07-30 22:59 PDT by Jeremy M. Dolan
Modified: 2016-02-18 18:03 PST (History)
48 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jeremy M. Dolan 2002-07-30 22:59:47 PDT
On all major Linux distributions, and with openstep on Solaris, libtiff is
included. (Which is BSD licensed, if that's a concern).

I didn't see any bug in all of bugzilla that proposed adding TIFF support to
Mozilla. The US Patent Office uses TIFF files for all of their images of
patents, which I ended up having to view source and manually download.

Is there interest in adding TIFF, or is it not a "web format" and considered
bloat? (It's more of a web format then BMP and XBM).

This support might also be very useful to online faxing applications, since
faxes are generally stored as TIFF files.
Comment 1 tenthumbs 2002-07-31 03:46:40 PDT
The big problem with TIFF is that it's not a streaming format. You 
have to have the entire file before you can begin to display it. No 
incremental display. That's one reason why it's not used much.

There's also the compression issue. LZW was one of the original 
compression schemes so there are patent issues. Lots of people are using 
uncompressed TIFFs to avoid this so you wind up downloading megabyte 
blobs before anything happens. The one big win is CCITT G4 (fax) 
compression which is usually better on b/w images than anything else. 
That's why the USPTO uses it.

Overall, I don't think it's a good idea.
Comment 2 Darin Fisher 2002-08-23 12:58:18 PDT
adding URL of top site that uses TIF images:
http://www.eluxury.com/browse/section.jhtml?SectionID=1000
Comment 3 Sebastian Biallas 2002-09-29 04:36:44 PDT
*** Bug 171514 has been marked as a duplicate of this bug. ***
Comment 4 jg 2002-09-29 04:41:56 PDT
Could an <a href...> be added under the tiff links then? we could at least
download the as there is no support currently.

Now i have to hunt through the source to get the url to download them

JG
Comment 5 Igor Furlan 2002-09-29 08:41:40 PDT
Darin Fisher said:

adding URL of top site that uses TIF images:
http://www.eluxury.com/browse/section.jhtml?SectionID=1000

Igor:
I could not find any TIFF image on that page



Comment 6 Andrew Hagen 2002-11-01 22:26:20 PST
*** Bug 167037 has been marked as a duplicate of this bug. ***
Comment 7 Andrew Hagen 2002-11-01 22:29:14 PST
Windows, too.

Indeed, TIFF is a poor choice for web graphics. TIFF is very old and very common
format, however. A lot of old image archives use it because it is still useful.
Commercial and governmental customers will need TIFF support.

Comment 8 Carleton MacGregor 2002-11-02 16:15:30 PST
The website http://www.ureach.com uses TIFF files for it's unified messaging fax 
format and I am unable to use Mozilla with that website as the TIFF files don't 
download. TIFF is still a useful format and I'd love to see Mozilla support it.
Comment 9 Stuart Parmenter 2002-11-02 16:18:11 PST
As others have said, TIFF is an awful format for the web.  We shouldn't
encourage anyone to actually use TIFFs by adding support for it <insert comment
about BMPs here>.
Comment 10 jg 2002-11-02 17:21:23 PST
Hi,

Just have to speak now.

Legacy compatability is what computing is all about, 60% of software is
recycling, its the same with gfx files. It is essential to have support, but by
all means do not promote the use of TIFF at all. I agree completly to that.

Other browsers support tiff, and unfortunatily mozilla is not in a monopoly
dominating possition to declair that tiff should not be used on the web.

JG



> ------- Additional Comments From pavlov@netscape.com  2002-11-02 16:18 -------
> As others have said, TIFF is an awful format for the web.  We shouldn't
> encourage anyone to actually use TIFFs by adding support for it <insert comment
> about BMPs here>.
> 
Comment 11 Jason Summers 2002-11-02 17:43:11 PST
> Other browsers support tiff

Name one.

Image browsers, yes. Web browsers, no.
Comment 12 jg 2002-11-02 17:55:02 PST
Next you will be saying take out gif support as you do not want to promote
another legacy file format with some issues.
IE supports TIFF does'nt it?
JG
Comment 13 Jason Summers 2002-11-02 18:08:15 PST
Depends on exactly what you mean by "supports". As far as I know, no
out-of-the-box version of IE will ever, under any normal circumstances, display
a TIFF file referred to using <img src=foobar.tif>. I realize that IE is vast
and mysterious, so if I'm wrong, please correct me (and provide evidence).
Comment 14 Andrew Hagen 2002-11-02 22:34:53 PST
Adding TIFF support won't create any noticeable overhead unless a user actually
loads a TIFF file. It won't encourage web developers to use TIFF images inline
on web sites because in the free marketplace, the inefficient TIFF file format
will lose out to the competition. Displaying TIFF files in "img src=" is not
required. What is needed is displaying TIFF files when the URI directly
references a TIFF file.

The up side is we broaden market share. There are corporate and government
environments where this would be useful. See this message, for example.

http://remotesensing.org/lists/libtiff_archive/msg00460.html

Finally, space imagery is often contained in TIFF.

http://heritage.stsci.edu/gallery/galindex.html
Comment 15 José Henrique F. Melman 2002-11-08 02:11:44 PST
Please take comment #12 and comment #14 as if they were said by me, although
comme nt #14 starts saying support should be added (for me it means displaying
on an "img src=" tag), and then says that just the URI to the tiff should be
showed. I am for the first option.
Comment 16 Carleton MacGregor 2003-03-28 12:31:12 PST
I see that Mozilla 1.3 was recently released but still doesn't fix the problem 
with TIFF files. Any idea when this will be fixed? I'll be able to move my 
company to Mozilla as soon as this is done since we visit the patent website and 
Ureach.com website daily. We don't need to display the TIFF in the browser, only 
the ability to download this file type and view it in a seperate application.
Comment 17 Andrew Hagen 2003-03-28 13:55:11 PST
If that's all you need, then go into Edit | Preferences | Navigator | Helper
Applications. Click on "New Type." Fill it out.

MIME Type:  image/tiff
Description: Tagged Image File Format
Extension: tiff

Select the appropriate choice for what application to run. (Hint: select either
default viewer or specify the application.) 

Good luck.
Comment 18 Samir Gehani 2003-04-25 15:14:54 PDT
adt: nsbeta1-
Comment 19 Christian :Biesinger (don't email me, ping me on IRC) 2003-10-06 05:20:33 PDT
*** Bug 221333 has been marked as a duplicate of this bug. ***
Comment 20 Hem Ramachandran 2003-10-06 06:48:32 PDT
Thank you for finding that the bug report I had, 221333 is the duplicate of this
one. I think the image was renamed wrongly gif, but it was a tiff format
orginally. To answer a question, in the comments, IE 5.5 supports .tiff format,
but not IE 6.0. 
I think if it is not a big effort, Mozilla/Firebird supporting .tiff might be a
good idea, that way we will have a more 'complete' browser. My 2 cents.
Comment 21 johann.petrak@gmail.com 2003-11-20 11:48:16 PST
Re: comment #11, Jason Summers: Konqueror displays TIFF images without a problem.

BTW all images in the online database of the patent office are TIFF. 
Comment 22 Derak Kilgo 2004-01-13 11:47:33 PST
From a document imaging and archival point of view, Tiff is still the de-facto 
standard for the imaging of paper documents. It is a very efficient format for 
bitonal images, and none of the other formats currently available really fit 
this niche. Currently, document imaging is starting to move away from client-
server software to a web-based model. All web-based document-imaging systems 
use some kind of third party plug-in to view tiff images, and most of them are 
quite expensive. If Netscape/Mozilla added native support for tiff images, they 
would instantly be the platform of choice for web-based document imaging 
systems similar to the US Patent office.This is a feature I would really like 
to see.

Example: An 8.5 by 11 document scanned at 200dpi
filesize format color space compression type
43KB     Tiff    B and W    CITT group 4 as implemented in libtiff
84KB     PNG     B and W
100KB    GIF     B and W
455KB    BMP     B and W
462KB    TIFF    B and W     uncompressed
544KB    JPEG    256 grays
Comment 23 Hem Ramachandran 2004-01-13 18:14:01 PST
Yes, I completely agree.
I am a real estate sales person in Austin, TX, and the MLS (multiple listing
service) and other tools realtors use  - they ask us to use IE only. And I am
reporting to the authorities my complaints about IE lock in. One of the things
they use is tiff support, which I think will help Mozilla/Firebird to be used as
a browser. Please bring TIFF support for Mozilla!
Comment 24 rschlem 2004-06-08 14:22:25 PDT
I have to agree to the need for tiff support.
Jpg images distort the colors. tiff is a much better system for printing.
It is condescending to make arbitrary esthetic decisions.
For instance, I would like to publish photos for a family history. I am hoping that folks who are 
interested in these data will download and print the images for their own collections.
 Jpg doesn't cut the mustard.
Comment 25 Joe Gwinn 2004-11-13 13:49:31 PST
The various comments to the effect that TIFF is too ugly to support misses the
point.  The various national Patent Offices have agreed upon the specific TIFF
format, and that's what they will yse, whatever we might think.  A big reason
that uncompressed TIFF was chosen was that legally, a totally lossless format
was required.

Many people will not be able to ditch IE unless TIFF display, file save, and
print are supported.
Comment 26 Martin Tomasek 2004-12-05 01:40:01 PST
> MIME Type:  image/tiff
> Description: Tagged Image File Format
> Extension: tiff

mozilla: "The page contais information of type (image/tiff) that can only be
viewed with the appropriate plug-in."

I'm currently using links browser for downloading images from uspto, because
mozilla 1.3 cannot handle even this.
Comment 27 Jerome Lacoste 2005-08-12 10:07:54 PDT
Could this be solved by a plugin?

I've found this: http://www.alternatiff.com/, but it seems to be Windows only.
Comment 28 johann.petrak@gmail.com 2005-08-12 17:17:27 PDT
(In reply to comment #27)
> Could this be solved by a plugin?
> 
> I've found this: http://www.alternatiff.com/, but it seems to be Windows only.

Plugger (http://fredrik.hubbe.net/plugger.html) can solve this (and other plugin
things) for Linux, but with limitations. It is a workaround but missing TIFF
support remains a bug to be solved.
Comment 29 Justin Kerk 2005-08-12 17:45:48 PDT
How is this parity-ie? IE doesn't do TIFF without a plugin either.
Comment 30 Steve Chapel 2005-08-12 17:57:45 PDT
I just tried it, and IE 6 SP2 certainly doesn't display TIFFs natively. I guess
the comments about needing IE to view TIFF images were misleading.
Comment 31 Akkana Peck 2005-08-12 22:40:07 PDT
Apparently now the patent office is using <embed> tags (type=image/tiff) instead
of <img> tags. Firefox doesn't appear to recognize there's anything there at all
-- it just shows a blank. If I assign an external helper program to image/tiff,
it still shows a blank area, but then image/tiff disappears from the helper app
dialog and can no longer be viewed or reassigned.

http://aiw2.uspto.gov/.aiw?docid=us20050177789ki&SectionNum=1&IDKey=22750A94BC01&HomeUrl=http://appft1.uspto.gov/netacgi/nph-Parser?Sect1=PTO1%2526Sect2=HITOFF%2526d=PG01%2526p=1%2526u=%25252Fnetahtml%25252FPTO%25252Fsrchnum.html%2526r=1%2526f=G%2526l=50%2526s1=%25252220050177789%252522.PGNR.%2526OS=DN/20050177789%2526RS=DN/20050177789
includes:
<embed
src="/.DImg?Docid=us20050177789ki&PageNum=1&IDKey=22750A94BC01&ImgFormat=tif"
width="570" height="840" type=image/tiff></embed>

Is there a way to get mozilla to show the presence of tiffs inside <embed>, so
an external handler can be called?
Comment 32 P Fudd 2005-12-04 22:33:44 PST
I just went to the patent office as well, and encountered the TIFF problem.

What's worse is that there is no way to add a helper via the Firefox menus!

Edit/Preferences/Downloads/View & Edit Actions
This screen lets you search for an existing action, remove an action, or change an action, but you cannot add an action, like what to do when you get a TIF file.

Combine that with no available plugin, and you've got yourself a browser that CANNOT view US Patents.  C'mon guys, I know you don't like software patents, but this is a bit extreme.

(Firefox 1.5 on Fedora 3 linux)
Comment 33 Matt Thompson 2006-09-29 13:09:12 PDT
From comment #1:

> There's also the compression issue. LZW was one of the original 
> compression schemes so there are patent issues.

Just a note, as reported all over (Slashdot, et al), the LZW patent mess seems to be over (we hope):

http://yro.slashdot.org/article.pl?sid=06/09/29/1657233

So if anyone was avoiding this for that reason, mayhaps it is time to revisit TIFF support in Firefox?
Comment 34 Steven Rogers 2007-02-26 11:35:59 PST
I agree TIF is awful for the web, but Mozilla is supposed to be an application development platform, not just a browser. There are numerous situations where it would be useful to support TIF display that have nothing to do with using TIF on web sites. In my particular case, I'm importing photos in base64 for display in an address book built in XUL. Apple's OS X Address Book application uses TIF as the format for photos it embeds in vcards - but since Mozilla the "browser" can't display TIF, Mozilla the "Rapid Application Development Platform" also can't display a TIF that's sitting in an installed extension. 

Saying "TIF is not a web format" is a very short sighted rationale for deciding whether to support the format in Mozilla.
Comment 35 Linus Kamb 2007-06-08 10:00:24 PDT
Perhaps TIFF images are "inappropriate" for the web, but they exist and have to be dealt with.  My application has to deal with all kinds of images, and FF lack of TIFF support is causing me much grief.  Safari happily handles all the images I (so far) have thrown at it.
Comment 36 Uri Bernstein (Google) 2007-12-14 05:29:45 PST
*** Bug 408197 has been marked as a duplicate of this bug. ***
Comment 37 Sivakatirswami 2009-03-08 12:50:39 PDT
it is true that tiff is a poor web format, but Mac OS X screen shots are defaulting to "pasteGraphic.tiff" and everyone else on our team use Apples Mail.app. When they send screen shots I have to open them in Photoshop. I would be happy if they just appeared in Thunderbird
Comment 38 d 2009-08-23 15:41:51 PDT
Just a note, as far as I can see, screenshots in Macs does not default to .tiff, but to .png.
Comment 39 Bobby Holley (PTO through June 13) 2009-09-11 00:04:20 PDT
Adding support for an image format in the official releases of the platform means putting it in the web browsers of 200 million people. The only reason we would do this would be if we thought that the benefit of having this support in the hands of web developers outweighed the increased security threat matrix to our users.

We clearly aren't looking to promote TIFF as a web format. As such, the reasons for having support are 2-fold:
1) Convenience for some users visiting websites like that of the US patent office
2) Usefulness of the platform for other (non-web) applications.

Both of these use cases can be handled by an extension. Interested users can install it, and xulrunner app developers can ship it with their product.

I don't think that Joe and I have much interest in writing such an extension ourselves anytime in the near future. However, we would gladly guide and support its development. If anybody is interested in writing one, please ping bholley or joe on irc (#gfx).
Comment 40 Joe Drew (not getting mail) 2009-09-11 09:22:03 PDT
TIFF is great for print and film, but not for the web. It's too complex and not used on the web. Its uses do not justify the increased threat surface it implies.
Comment 41 d 2009-09-11 10:48:36 PDT
Personally I have heard enough to conclude that TIFF support isn't needed, and might infact damage the web if supported. I suggest that if you don't have a very good reason which has not yet been brought up here, then there is nothing more to discuss.
Comment 42 d 2010-04-12 01:28:36 PDT
TIFF is now supported in the IE9 preview (they don't give any specific reason for adding the support). I still think we should avoid supporting it for the sake of the web.
Comment 43 d 2010-04-12 01:30:44 PDT
More interestingly, also supported in the IE9 preview is JPEG-XR. See bug 500500 for this format.
Comment 44 rsx11m 2011-07-03 07:09:07 PDT
(In reply to comment #38)
> Just a note, as far as I can see, screenshots in Macs does not default to
> .tiff, but to .png.

Well, then many Apple Mail users apparently don't find that setting, I'm usually getting those as (uncompressed) PastedGraphics.tiff inline images or attachments, thus it appears to be a not uncommon use case at least for e-mail.

Since ImageLib doesn't support it, neither Thunderbird nor SeaMonkey can display TIFF images in the message body or as attachment either. On the other hand, BMP is supported as inline format, which is not better at all than TIFF and doesn't even support compression. So, at least this is rather inconsistent.

> (comment #39) Both of these use cases can be handled by an extension.

Is there a pointer to such an extension for web or mail/news content?
Comment 45 [Baboo] 2011-07-12 04:00:00 PDT
(In reply to comment #44)
> BMP is supported as inline format, which is not better at all
> than TIFF and doesn't even support compression. 

Actually the BMP format supports some crude forms of lossless compression.
Comment 46 Joachim 2011-11-02 07:47:16 PDT
(In reply to rsx11m from comment #44)
> (In reply to comment #38)
> > Just a note, as far as I can see, screenshots in Macs does not default to
> > .tiff, but to .png.
> 
> Well, then many Apple Mail users apparently don't find that setting, I'm
> usually getting those as (uncompressed) PastedGraphics.tiff inline images or
> attachments, thus it appears to be a not uncommon use case at least for
> e-mail.
> 
> Since ImageLib doesn't support it, neither Thunderbird nor SeaMonkey can
> display TIFF images in the message body or as attachment either. On the
> other hand, BMP is supported as inline format, which is not better at all
> than TIFF and doesn't even support compression. So, at least this is rather
> inconsistent.
> 
> > (comment #39) Both of these use cases can be handled by an extension.
> 
> Is there a pointer to such an extension for web or mail/news content?
On the Mac:
Screenshot is png, BUT
I paste to Preview, than <CMD>C and viola, it's a tiff
So tell the Mac users to direct paste into mail!
Comment 47 Tony 2011-12-01 13:28:38 PST
In response to TIFF displaying: For Windows OSs there is a file viewing application called Quick View Plus. It adds file viewing for over 300 Windows, Macintosh, Internet, and DOS formats and opens the files either as a stand-alone in the Quick View Plus program or from within file managers and browsers. It's handy for opening file formats for which there is no program installed on the system with which to otherwise view them.

(https://avantstar.com/metro/home/Products/QuickViewPlusStandardEdition/Info/Overview

One of the most visually intense TIFF sites is NASA and its related Hubble, JPL and other sites. Beautiful, but huge files. (132 MB 7546 X 7518 X 24 for example) When accessing a TIFF image in Firefox, Quick View Plus is invoked and it displays TIFF file in a Firefox tab. I do not know of a similar program for Linux, but if NASA and JPL use Linux and view their own TIFF images on the Web, I would think there is a Linux program that would work as a Firefox extension.

When trying to insert a file into a Thunderbird message, the TIFF file format is not available for selection. Opting for "All files" and selecting a TIFF file does not invoke Quick View Plus and no image is displayed. (Just the "broken image" box.)
Comment 48 Chris O 2011-12-13 10:25:06 PST
To all those arguing the pros and cons of the TIFF file format, in my opinion I think you are missing the point.

- Mozilla Thunderbird does not support the TIFF format for inline images
- Thunderbird does not handle tiff images in a way that clearly explains to the non-technical user why they can't view the inline image in Thunderbird.
- the TIFF format is still commonly used, and will be for some time
- most email clients support the TIFF format
- most webmail clients support the TIFF format
- most professional image editing applications support the format

I understand that there arguments for or against handling various file formats in browsers.  Website developers should only work with those that are universally supported.  Emails clients, though, should support any sent attachment, inline or otherwise.  At the very least, Thunderbird should display an appropriate error message indicating that it does not support inline TIFF images.  Thunderbird could also provide access to the inline TIFF image as an attachment.  The current handling of TIFF images by Thunderbird is clunky and confusing.  Not resolving this issue will turn away many potential users of the Thunderbird Client.
Comment 49 Antti Kaihola 2012-02-21 00:00:21 PST
Today I received an e-mail with an inline or embedded (I'm not sure what's the difference) image.

The image doesn't appear, only a "broken image icon" is shown in the upper left corner of the image area.

The image does not appear as an attachment.

If I right-click on the image, there is no "save image as" option, only "Select All" and "Copy Image". The "Copy Image" function doesn't work - if I try to paste into The GIMP, it tells me that the clipboard doesn't contain an image.

This is Thunderbird 9.0 on Linux Mint 12.


*** CONCLUSIONS: ***
1. I can't view the image even in an external application.
2. There's no reasonable way to get the image file out of Thunderbird.
3. I can't use Thunderbird when communicating with our graphic designer.

*** SUGGESTION: ***
At least make it possible to save TIFF images.


---


Here are some hopefully relevant snippets from View/Message Source:

Content-Type: multipart/alternative; boundary="Apple-Mail=_2AC7276E-863D-48DD-AB9B-ACBDED4ECC96"
Mime-Version: 1.0 (Apple Message framework v1251.1)
X-Mailer: Apple Mail (2.1251.1)
X-Local-Part-Suffix: 


--Apple-Mail=_2AC7276E-863D-48DD-AB9B-ACBDED4ECC96
Content-Transfer-Encoding: 7bit
Content-Type: text/plain;
	charset=us-ascii


-- 
Juha Kaunisto, 2General Ltd
http://www.2general.com
+358 44 5471882





--Apple-Mail=_2AC7276E-863D-48DD-AB9B-ACBDED4ECC95
Content-Type: multipart/related;
	type="text/html";
	boundary="Apple-Mail=_EB4CAED1-5305-4D53-956F-989645211BBB"


--Apple-Mail=_EB4CAED1-5305-4D53-956F-989645211BBB
Content-Transfer-Encoding: 7bit
Content-Type: text/html;
	charset=us-ascii

<html><head></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><img id="e2dd69a7-c052-4b65-86e7-088fdf3f54d5" height="516" width="517" apple-width="yes" apple-height="yes" src="cid:F3D7B4A9-3DA2-467D-A30A-C1700FF04275"><br><div apple-content-edited="true">(text removed)</div><br></body></html>
--Apple-Mail=_EB4CAED1-5305-4D53-956F-989645211BBB
Content-Transfer-Encoding: base64
Content-Disposition: inline;
	filename=PastedGraphic-1.tiff
Content-Type: image/tiff;
	x-unix-mode=0666;
	name="PastedGraphic-1.tiff"
Content-Id: <F3D7B4A9-3DA2-467D-A30A-C1700FF04275>

TU0AKgAKrFaAKWBP9+QUAP2EQeEv6GAB7w8AN2JAA7nc6ACMRiGP+Mxh/x8AR9/R2SPt9vyQv+Rx
2PxyOxuSS0AAaaSSbTeMgEBAGSAMBAKUxx/SB/P2VzcA0mez6SUOXRmVU+PSCOgKmVGggCkzxyuV
(clip clip)
uDZjdXJ2AAAAAAAAAAEBzQAAc2YzMgAAAAAAAQxCAAAF3v//8yYAAAeSAAD9kf//+6L///2jAAAD
3AAAwGw=

--Apple-Mail=_EB4CAED1-5305-4D53-956F-989645211BBB--

--Apple-Mail=_2AC7276E-863D-48DD-AB9B-ACBDED4ECC95--
Comment 50 Stefan 2012-11-14 03:24:50 PST
I've to second Chris O's point here. If Thunderbird relies on ImageLib to support different image formats, tiff should be supported IMO.

Having a current mail-client not being capable of showing different image formats is a relevant draw-back in my opinion.

So if the "proper" way to add tiff-support to Thunderbird is to add tiff-support into ImageLib, here's my vote for this issue to be taken care of.

If the "proper" way is to handle image formats which are unsupported by ImageLib in Thunderbird differently, then I don't mind much in whether tiff-support is added to ImageLib or not.
Comment 51 Stefan 2012-11-14 03:27:50 PST
If this is considered not a valid feature request for ImageLib and hence is kept in the state "Won't fix", IMO issue 171514 shouldn't be considered a duplicate of this issue.
Comment 52 Leonid Rozenblyum 2014-10-13 06:08:41 PDT
Are there any chances the WONTFIX status be changed to something more optimistic?
It's really a nice to have feature
Comment 53 Marat Tanalin | tanalin.com 2016-01-31 09:51:32 PST
By the way, native TIFF support would be useful for creating browser-based viewer (as an extension) for local images even if TIFF support was not quite reasonable for the pure-web purpose.

Lack of TIFF support makes such possible browser-based viewer of quite limited usefulness since many serious lossless graphics (e.g. scanned photos or other documents) are usually in TIFF format. Web browser is currently more than just a _web_ browser.
Comment 54 lilydjwg 2016-02-18 18:03:58 PST
I got here because an online PPT previewer from Tencent email service uses TIFF. Also, some people send TIFF screenshots as mail attachments so I can't view them directly in the web mail page. It seems that some screenshoters love TIFFs so much...

Note You need to log in before you can comment on or make changes to this bug.