Closed Bug 1603275 Opened 2 years ago Closed 2 years ago

Update New Tab Banner Behaviour

Categories

(Firefox for Android Graveyard :: General, enhancement, P1)

enhancement

Tracking

(firefox-esr6873+ verified)

VERIFIED FIXED
Tracking Status
firefox-esr68 73+ verified

People

(Reporter: athomas, Assigned: petru)

References

Details

(Whiteboard: [fennec68.4.x])

Attachments

(4 files)

Vision
All users eligible for upgrade to Fenix get a chance to see the transition messaging when viewing the new tab screen

Acceptance Criteria

  • Transition banner is shown on the new tab page to all users eligible for Fenix upgrade (everyone except users on Android versions below 5.0)
    • Includes users who are logged into an account
    • Includes users who dismissed the banner in the past when it referred to account log in
  • Users can dismiss the new banner, which means it will not be shown again

Design
Mocks

Summary: Show New Tab Banner to All Users → Update New Tab Banner Behaviour
Priority: -- → P1
Whiteboard: [fennec68.3.2]
Whiteboard: [fennec68.3.2] → [fennec68.4.x]
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED

This new banner will not replace the old SignInRow (now FxaBannerRow) but
rather take precendence into being shown on the awesomescreen.
It will only be shown if

  • the app is the release version. Not for beta. Not for nightly.
  • the device has at least Android 5.0. The minsdk of Fenix.
  • user has not explicitly dismissed this banner.

Also consolidated some resources common to both banners.

The necessary strings have been added in previous patches in an effort to give
localizers more time to translate them.
Now that we are actually using this resources there's no need for the Lint
suppression anymore.

Depends on D58427

This was regressed by bug 1593322.
Now that we're touching this layouts again, let's make amends.

Depends on D58428

The new banner in action - https://drive.google.com/file/d/14DXrzIIEfEJwotO8C-_hTtu9xM_6gO8q/view
Description might seem a bit crammed but as can be seen in the layout png it respects the original banner specifications, and those from bug 1603270 comment 0.

Does this look ok with you Michelle?

Flags: needinfo?(mheubusch)
See Also: → 1603270

Please help test this against this try build based off the most recent esr68 tree.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=0e7108cf7a09a22f20ec5997030262ba15650c77

Flags: needinfo?(mheubusch) → qe-verify+

When trying to test this Eliza raised an important issue:
Treeherder doesn't build release and this feature is only to work on release.
After confirming with her I made a local build - https://drive.google.com/file/d/1j1D58y5NdhZ-ItsVMiYWnegdVB-Biocm which would help on testing this before it actually getting into release.

Petru: I had tested the build received in the previous comment and the banner is not dismissed when "Take a sneak peek" button is selected.

Thanks Eliza, indeed this wasn't implemented in the initial version of the patches.
I've updated them and now the above GDrive link should point to a new build that should also have this functionality.
Can you please retest this scenario?

Flags: needinfo?(eliza.balazs)

Thanks Petru!
Verified as fixed on the build received in Comment 7, with the following devices:

  • Google Pixel 3 (Android Q),
  • Samsung Galaxy S8 (Android 9),
  • Huawei Honor 8 (Android 7.0),
  • Huawei MediaPad M2 (Android 5.1.1).

With the latest build, the banner is dismissed when "Take a sneak peek" button is selected and the page opens in the same tab.

Flags: qe-verify+
Flags: needinfo?(eliza.balazs)

Comment on attachment 9118154 [details]
Bug 1603275 - Add a new FirefoxPromoBannerRow for the awesomescreen; r?VladBaicu

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Important new feature for the Fennec -> Fenix transition
  • User impact if declined:
  • Fix Landed on Version:
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Verified by QA
  • String or UUID changes made by this patch:
Attachment #9118154 - Flags: approval-mozilla-esr68?
Attachment #9118155 - Flags: approval-mozilla-esr68?
Attachment #9118156 - Flags: approval-mozilla-esr68?

Comment on attachment 9118154 [details]
Bug 1603275 - Add a new FirefoxPromoBannerRow for the awesomescreen; r?VladBaicu

Needed for Fennec->Fenix migration. Approved for 68.5b2.

Attachment #9118154 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+
Attachment #9118155 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+
Attachment #9118156 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

Hi, checked with Google Pixel 3a (Android 9) and Samsung Galaxy S9 (Android 8.0), on Firefox Release 68.4.1.
Unfortunately, the new banner is not displayed, the old banner is present.

Flags: needinfo?(petru.lingurar)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Thanks Diana
After decompiling fennec-68.4.1.en-US.android-aarch64.apk from here http://archive.mozilla.org/pub/mobile/candidates/68.4.1-candidates/build1/android-aarch64/en-US/ i see that the changes this batch of patches bring are not present.
@Ryan is this to be expected - that the latest build doesn't contain these patches?

Flags: needinfo?(petru.lingurar) → needinfo?(ryanvm)

Yes, these changes are only on the default branch (to-be-68.5).

Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Flags: needinfo?(ryanvm)
Resolution: --- → FIXED

Hi, verified as fixed on Fennec RC 68.5.0 with Samsung Galaxy Tab A (Android 9), Samsung Galaxy S8+ (Android 8.0.0), LG K4 (2017) (Android 6.0.1), Xiaomi Mi Pad 2 (Android 5.1) and LG G3 S(Android 4.4.2)
Scenarios checked and passed:

  • Transition banner is shown on the new "Top Sites" tab
  • Transition banner is not shown in Private mode after being dismissed in Normal mode.
  • Transition banner is not displayed after being dismissed
  • Transition banner is displayed after clear data
    For LG G3 S(Android 4.4.2) - the new banner is not displayed, as intended.
Status: RESOLVED → VERIFIED
Depends on: 1641037
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.