Closed Bug 1604097 Opened 3 years ago Closed 3 years ago

Incorrect recognizing of a file being copied in Mercurial.

Categories

(Conduit :: moz-phab, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: zalun, Assigned: zalun)

References

Details

(Keywords: conduit-triaged)

Attachments

(3 files, 1 obsolete file)

Steps to reproduce a copy error (an a dev site):

$  hg clone https://hg.mozilla.org/automation/phabricator-qa-dev/ 
$ hg copy TEST TEST2
$ hg commit -m "Bug 1 - copy"
$ moz-phab --no-arc .

Expected

https://phabricator-dev.allizom.org/D1633
(Observable by performing a submit using Arcanist moz-phab .)
"TEST This file was copied to TEST2."
"TEST2 This file was copied from TEST."

Observed

https://phabricator-dev.allizom.org/D1631
"TEST This file was moved to TEST2."
"TEST2 This file was moved from TEST."

Notes

An issue with hg move was initially reported in bug 1603447 by :calixte.
He mentioned a similar issue reported by :gsvelto in https://bugzilla.mozilla.org/show_bug.cgi?id=1594344#c15
MozPhab is now reverted to a state where the default action is to use Arcanist.

Previously all changing name of the file was treated as a move.
This patch is checking if od filename is removed - if so - it is a move
else it's a copy.

Assignee: nobody → pzalewa
Status: NEW → ASSIGNED
Duplicate of this bug: 1603508
Depends on: 1604458
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Attachment #9116952 - Attachment is obsolete: true
Summary: Incorect recognizing of a file being copied in Mercurial. → Incorrect recognizing of a file being copied in Mercurial.
You need to log in before you can comment on or make changes to this bug.