Closed Bug 1605845 Opened 10 months ago Closed 10 months ago

Port bug 1579952 - Mass rename .xul files to .xhtml

Categories

(Thunderbird :: General, task)

task
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 73.0

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(2 files)

Once bug 1579952 lands, none of our .xul files are going to work any more. I've done a mechanical replacement as a bustage fix that appears to work.

Here's what I did:

  • Rename all .xul files to .xhtml
  • Replaced everything matching /\.xul\b/ with .xhtml, except if it is part of there.is.only.xul
  • Replaced everything matching chrome://messenger/content/ with chrome://messenger/content/messenger.xhtml
  • Tidied up manually
  • Disabled the linter on .xhtml files for now. There's not much to fix but I've got better things to do right now.

So far the Try run looks good: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&group_state=expanded&revision=da85b26e3abcf181c65084aaa320ed68a4dbbce0

I think I'm just going to land this stuff, alongside bug 1604420, but if I don't it's here for the next person seeking to put out a burning tree.

Mozilla-central merge is expected at 1600 or 2200 UTC.

Severity: normal → blocker
Blocks: tb-de-xul

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/0ff64b19c513
Rename all .xul files to .xhtml; rs=bustage-fix
https://hg.mozilla.org/comm-central/rev/d58d6a653555
Change all references to .xul files to .xhtml instead; rs=bustage-fix

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 73.0

This makes that the configs in the xulstore aren't restored because the references are no longer xul but xhtml. Maybe a migration should be needed to not let the users with an initial appearance and then needed to made it again like they want.

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/5a0b6e3a4343
Follow-up: reformat. rs=reformat

(In reply to Richard Marti (:Paenglab) from comment #5)

This makes that the configs in the xulstore aren't restored because the references are no longer xul but xhtml. Maybe a migration should be needed to not let the users with an initial appearance and then needed to made it again like they want.

Probably, but if m-c does not do it (did they decide it isn't needed?) I'm not sure we want to poke so deep in the internals of xulstore. Can we even ask for the references stored there? This toolkit code usually works transparently to TB.

(In reply to :aceman from comment #7)

(In reply to Richard Marti (:Paenglab) from comment #5)

This makes that the configs in the xulstore aren't restored because the references are no longer xul but xhtml. Maybe a migration should be needed to not let the users with an initial appearance and then needed to made it again like they want.

Probably, but if m-c does not do it (did they decide it isn't needed?) I'm not sure we want to poke so deep in the internals of xulstore. Can we even ask for the references stored there? This toolkit code usually works transparently to TB.

FWIW, m-c did do some migrations: https://searchfox.org/mozilla-central/rev/c79fc6e32a5b561205a71fcfef9112d34b4037ae/browser/components/BrowserGlue.jsm#3240

See bug 1603457 and bug 1603612.

Depends on: 1606032

Did you really mean to rename in editor/ui as well, not that we care.

https://hg.mozilla.org/comm-central/rev/d58d6a653555#l187.12 didn't pan out for localized builds, the localizations still reference the XUL file, and with cross-channel, should continue to do so for the given string ID.

Possible ways to fix this would be to just drop the localized pref, or to do a proper string change for this.
Personally, the fewer localized prefs we have, the better, so I'd prefer to just get rid of this.

Oh yuck, why is that even a thing? I'm going to remove it since it appears no translations have any other value.

Depends on: 1606538
Regressions: 1633306
You need to log in before you can comment on or make changes to this bug.