Closed Bug 1607929 Opened 2 years ago Closed 8 months ago

Native Firefox title bar doesn't support Windows 10 App Dark Mode setting

Categories

(Core :: Widget: Win32, defect, P3)

All
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1734359

People

(Reporter: rctgamer3, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

I've enabled Dark Mode in Windows 10.
Yet, the native Firefox title bar does not support dark theme thus stays white.

Reproducible on latest nightly (2020-01-08)

The priority flag is not set for this bug.
:jimm, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jmathies)

How did you get the old titlebar to display? I don't have one in my browser. I wonder if this is a dev edition issue only.

Flags: qe-verify?

Customize → Title Bar

Ok, we need to add support for this via the dwm apis. I managed to fix this in a test app using

BOOL flag = true;
DwmSetWindowAttribute(hWnd, 19, &flag, sizeof(BOOL));

19 is an undefined DWMWINDOWATTRIBUTE. That's probably going to show up in a future sdk.

Some testing needs to be done to understand when we should set this.

I'd be happy to mentor a contributor on this. Since this option is buried pretty deep in our options and likely not a popular setting, I see no reason to track.

Flags: qe-verify?
Flags: needinfo?(jmathies)
Priority: -- → P3
Summary: [W10] Native Title Bar doesn't support W10 Dark Mode → Native Firefox title bar doesn't support Windows 10 App Dark Mode setting
See Also: → 1432725
See Also: → 1674566
Blocks: 1674566
See Also: 1674566
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1734359
No longer blocks: 1674566
You need to log in before you can comment on or make changes to this bug.