Closed Bug 1620202 Opened 1 year ago Closed 9 days ago

Full screen Top menu doesn't respect dark mode macOS Catalina

Categories

(Core :: Widget: Cocoa, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox88 --- affected
firefox91 --- fixed
firefox92 --- fixed

People

(Reporter: adamprocter, Unassigned)

References

Details

(Whiteboard: [mac:fullscreen:native-affected][mac:fullscreen:nonnative-affected][mac:darkmode])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:73.0) Gecko/20100101 Firefox/73.0

Steps to reproduce:

Entered Full screen mode

Actual results:

The very top menu bar is not respecting dark mode

Expected results:

should have been dark

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
Priority: -- → P2
Severity: normal → S3
Whiteboard: [mac:fullscreen]

Verified with older builds such as 67.0, and nightly builds from 2015 on macOS 10.13, 10.15, 11.3.
It revealed that this not being a regression, but something that was in this state across builds.

Updating the flags to reflect this; fwiw it might be better treated as an enhancement, for parity and consistency (wise) with other browsers.

Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Version: 73 Branch → Trunk
See Also: → 1517182
Whiteboard: [mac:fullscreen] → [mac:fullscreen][mac:darkmode]
Duplicate of this bug: 1709207
Whiteboard: [mac:fullscreen][mac:darkmode] → [mac:fullscreen:native-affected][mac:fullscreen:nonnative-affected][mac:darkmode]

This is fixed now that bug 1623686 is resolved.

Status: NEW → RESOLVED
Closed: 9 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.