Open Bug 1620310 Opened 3 years ago Updated 8 months ago

At startup the focus is anywhere, set it on first new message of default account

Categories

(Thunderbird :: Folder and Message Lists, enhancement)

Desktop
All
enhancement
Not set
normal

Tracking

(Not tracked)

REOPENED
Thunderbird 76.0

People

(Reporter: foss, Assigned: cwendling)

References

Details

Attachments

(1 file, 2 obsolete files)

Hello,

As describe on Mozillazine [1] it seems that in the past Thunderbird placed the focus on first message of the inbox folder of the default account.

What is the current behavior:

  1. Start Thunderbird
    Result:
    The caret is anywhere

  2. Tab one time
    Result: The caret is on the current tab

What behavior I propose to have:

  1. Start Thunderbird

Result:
The focus is on the first message of the inbox folder of the default account.

Why I report this now and not before?
The reason is mainly because in older release (60 and 52) there were extension like Select Inbox for doing this and without new replacement my blind or keyboard-only users stay on older release.

Why is it important?
I think having the caret and Thunderbird opening a folder a predictable way will simplify the life of users.

What do you think of my proposal?

[1] http://kb.mozillazine.org/Show_Inbox_when_starting_Thunderbird

Best regards.

Out of habit I almost always close Thunderbird with the Inbox of my default account selected.

Not sure I would like it going to the first message in the Inbox of the default account. That message could be years old.

First new message in the account's Inbox would be great.

Component: Untriaged → Folder and Message Lists

First new message in the account's Inbox would be great.

I agree with you, it was I mean, yes.

Summary: At startup the focus is anywhere, set it on first message of default account → At startup the focus is anywhere, set it on first new message of default account

First new message in the account's Inbox would be great.

OK, after discussing I propose this:

  1. If the message are ordered by date, go to the latest message without verifying if it's read of not
  2. If it's ordered another way, go to the highest message

The reason why I prefer to propose is for reliability because often the last new message is the more recent but the last new message could years old too.

This commit revamps a little the Start Page option to also provide a way
to set the start location. Options are either latest location (like currently),
first message or first unread message.

Assignee: nobody → john
Status: NEW → ASSIGNED

When not showing start page (option unticked), at startup go to Inbox and focus
first or last message according to sorting direction.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/d318ed3f2347
Provide a deterministic startup location when not showing start page r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 76.0
Attachment #9132244 - Attachment is obsolete: true

Consistently selecting a message and focussing the list of messages I understand, but this means (when the pref is not set) Thunderbird always opens to the inbox, instead of the most recently used folder. Is that intended? And if so, why is it okay to be in the most recently used folder if the pref is set?

Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(john)

(In reply to Geoff Lankow (:darktrojan) from comment #7)

Consistently selecting a message and focussing the list of messages I understand, but this means (when the pref is not set) Thunderbird always opens to the inbox, instead of the most recently used folder. Is that intended? And if so, why is it okay to be in the most recently used folder if the pref is set?

Our goal was to offer a predictable way to the end-user, especially blind who want to be sure who they'll be at startup. Personally I never remember where I'm at TB closing and I don't want to open it somewhere.

If we want something different we need to add an option to let the user decide what he wants but Magnus refuses to add a new option.

Best regards.

Flags: needinfo?(john)

The idea was that e.g. blind users don't want the start page because they do not want that extra information read, which sounds like the same group that would want a predictable location set.
But perhaps it's an oversimplification. Open to ideas, but yes, I'd like not to have at least a lot of ui prefs for something like this.

Flags: needinfo?(mkmelin+mozilla)

(In reply to Magnus Melin [:mkmelin] from comment #9)

The idea was that e.g. blind users don't want the start page because they do not want that extra information read, which sounds like the same group that would want a predictable location set.
But perhaps it's an oversimplification. Open to ideas, but yes, I'd like not to have at least a lot of ui prefs for something like this.

Probably we could just add a new checkbox "open in previously opened folder".

(In reply to Alex ARNAUD from comment #10)

Probably we could just add a new checkbox "open in previously opened folder".

That's all it would take. Then opening the inbox at start-up (or not) can be made independent of showing the start page (or not), which is counter-intuitive.

Regressions: 1631192
See Also: → 1629522
Regressions: 1629522

I had to back this out in bug 1629522 - people didn't seem to like this at all.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

(In reply to Magnus Melin [:mkmelin] from comment #12)

I had to back this out in bug 1629522 - people didn't seem to like this at all.

Maybe I missed something or doesn't understood something correctly, in the mentioned issue the user report the exact same issue we report and would like the exact same result we've implemented here. As we're screen reader users and keyboard users.

@Magnus: There is something on one of the user's profile preventing this to work but reverting it will made the initial issue back for all users it works. I don't tell we shouldn't find why the fix doesn't work in some case, I just don't understand why reverting would help in this regard.

There's a slew of issues or potential issues, more or less around the same thing. See the see alsos of bug 1629522 - many of which should be duplicates against each other. All in all, the group it causes problems for seems larger than the one it could help for.

(In reply to Magnus Melin [:mkmelin] from comment #14)

There's a slew of issues or potential issues, more or less around the same thing. See the see alsos of bug 1629522 - many of which should be duplicates against each other. All in all, the group it causes problems for seems larger than the one it could help for.

OK, thanks for clarifying, now make sense to me too.

Are you OK if we add an option for this as proposed initially?

Regression perhaps first detected in bug 1636350. Support requests on this issue from the last few days, so we'll want to fast track bug 1629522.
https://support.mozilla.org/en-US/questions/1301525
https://support.mozilla.org/en-US/questions/1301546
https://support.mozilla.org/en-US/questions/1301826

As Alex asked a couple weeks ago, if changing the non-startpage behavior forcefully doesn't play with all users (which is fair enough), what about going back to the idea of having an extra option for this? Startpage/last viewed/newest message/possibly more, like https://phabricator.services.mozilla.com/D66219 tried to do?

Flags: needinfo?(mkmelin+mozilla)

(In reply to Alex ARNAUD from comment #2)

First new message in the account's Inbox would be great.

I agree with you, it was I mean, yes.

I just wanna mention that this could conflict with a different pref:

mailnews.remember_selected_message
http://kb.mozillazine.org/Mail_and_news_settings

True(default): Selects the last message selected in the folder again the next time you open that folder.
False: Does nothing. 

I don't know what the solution here is. On one hand we do already have the solution, that you can specify folder by the command line argument. Maybe that's good enough?

Since Thunderbird is completely dependent on donations and the start page is a huge funnel for that, we need to balance it so that people don't turn it off too easily. Adding additional UI to select what to do would likely drive such actions, so I'm not too keen on it.

Flags: needinfo?(mkmelin+mozilla)

(In reply to Alfred Peters from comment #18)

I just wanna mention that this could conflict with a different pref: mailnews.remember_selected_message […]

I don't think it's much related, that preference seems to only affect the behavior during a single Thunderbird run, no across restarts.

(In reply to Magnus Melin [:mkmelin] from comment #19)

I don't know what the solution here is. On one hand we do already have the solution, that you can specify folder by the command line argument. Maybe that's good enough?

I don't think it would be very practical, but anyway I should try this: how do we do that? I see how I can open a specific email in a specific folder using -mail (it's not very intuitive, but doable), but you ought to know the message's ID, and anyway it opens the message, not the folder view.

Since Thunderbird is completely dependent on donations and the start page is a huge funnel for that, we need to balance it so that people don't turn it off too easily. Adding additional UI to select what to do would likely drive such actions, so I'm not too keen on it.

Well, if it's a concern there don't necessarily need to be some UI to change the behavior. E.g. just the patch that was rolled back, but with an advanced option to choose between its new behavior and the previous one (and default to the previous one).

Also, I wonder why it's so easy to disable the startpage (It's literally the first setting one sees) if it's a concern for getting dontaions. That's irrelevant for the problem at hand, but if people disabling this is a concern, it might make sense to move this a littler farther down or something (but admittedly I don't see much use myself for customizing the startpage of my mail client, but that's me -- unless maybe if it could show some summary of my mailbox maybe, or other broader view of it? -- so I might not realize how much it's used).

Per the mozillazine article above, something like
"C:\Program Files\Mozilla Thunderbird\thunderbird.exe" -mail mailbox://someone@pop.gmail.com/Inbox

That doesn't seem to work for me. I don't have a POP account to work with so I looked up what gFolderDisplay.displayedFolder.URI gave me (which was a imap://user@somewhere.tld/INBOX-looking URI), but that didn't work. I tried mailbox:// as well, no luck either.

Anyway, even if that worked, it's not very practical as it requires customizing the launcher for the specific mailbox, and it's not trivial at all to figure the value either.

Any news on this? It's really inconvenient for many (especially blind) users to not have the focus on a 100% predictable and useful location at startup. I totally understand that not restoring the last viewed folder might be annoying for some; but for others it would be of much help to know for sure 100% where their focus is at when they open the app (without having to remember what they did last time) -- and if possible, the focus being on something useful right away, as focus is what gives them information.

So again, what about restoring the rolled-back patch, but behind a (possibly hidden) pref, default off? I believe that would solve it for everybody: users happy with the current situation would not see any change, the startup page would show by default, and users preferring the focus on the default inbox would just have one option to set up once (which is not ideal for them, but it makes sense for the default behavior to please the most).

Or would there be another acceptable option, if that one isn't?

I'd be happy to follow up Jonathan's work to get the feature in again, whichever the consensus on implementing it is.

Flags: needinfo?(mkmelin+mozilla)

I'd suggest we get the command line argument working.

Flags: needinfo?(mkmelin+mozilla)

Attaching some debug. Don't intend to work on it so feel free to continue

Attachment #9135449 - Attachment is obsolete: true

(In reply to Magnus Melin [:mkmelin] from comment #24)

I'd suggest we get the command line argument working.

While fixing (or understanding?) this would probably be good indeed, I don't think it's a good solution for the problem here.

There are a couple reasons that makes me think it's not the best solution: it's harder to set up (one needs to understand the argument syntax, and alter their launchers, create aliases or so), and easier to forget (if you didn't alias it, and happen to run Thunderbird with no argument, you're back with the problem). Also, it doesn't adapt as easily to configuration changes, e.g. changing the default mailbox will not affect this, and vice versa.
Basically, relying on the argument would mean it's not an integrated feature, with everything that goes with it. And given the use case and people impacted, I don't think we should solve this with a kind of workaround.

(In reply to Magnus Melin [:mkmelin] from comment #24)

I'd suggest we get the command line argument working.

As suggested by Colomban, I don't think it's really practical for the users for which we're trying to make it. Thunderbird offers advanced feature for advanced users but here this is mostly intended for blind beginner people or beginner in general because opening the inbox at each startup could dramatically improve their life.

To be fully transparent with you, my colleague teaching blind has so much trouble to teach Thunderbird to blind beginners without this capability because at startup some people are not able to deal with impredictability.

@Magnus, we're totally OK to do the job ourselves.

As the first checkbox of the Preferences allow to not display the home page, it's so easy today for users to not display the home page.

What's about just adding a checkbox after the home page address to "Open the inbox of the default account at startup" only checkable if the "display home page" is unchecked? With this, we don't change the default behavior and adding something easy to check or not for the all users.

Flags: needinfo?(mkmelin+mozilla)
Assignee: john → cwendling

It's a complicated matter. I think we could consider not having the start page location UI exposed in the UI. We could have an option of what to do when starting, maybe like

Startup behaviour: [ ] select default account inbox [x] select last used folder.

The start page would always show (unless perhaps a hidden pref is set).

Flags: needinfo?(mkmelin+mozilla)

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/99d2aab955ed
Fix a parameter problem when calling onCheckItem(). r=mkmelin

Status: REOPENED → RESOLVED
Closed: 3 years ago2 years ago
Resolution: --- → FIXED

(Reopening, that landed with wrong bug number.)

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Backout by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/57fce5374f59
Backed out changeset 99d2aab955ed for landing with wrong bug number: correct bug number is 1670459

Telemetry here could help inform our decision making, or messaging to users, about any changes.

See Also: → 425025
You need to log in before you can comment on or make changes to this bug.