Open Bug 1622391 Opened 5 months ago Updated 5 months ago

Intermittent toolkit/components/pictureinpicture/tests/browser_disabledForMediaStreamVideos.js | Uncaught exception - Waiting for the hovering state to be set on the video. - timed out after 50 tries.

Categories

(Toolkit :: Video/Audio Controls, defect, P5)

defect

Tracking

()

ASSIGNED

People

(Reporter: intermittent-bug-filer, Assigned: rmaries)

References

(Regression)

Details

(Keywords: intermittent-failure, leave-open, Whiteboard: [retriggered][stockwell disabled])

Attachments

(1 file)

Filed by: rmaries [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=293080277&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Q9yX9b38SiqpX6Zvaz1N3Q/runs/0/artifacts/public/logs/live_backing.log


[task 2020-03-13T18:44:16.185Z] 18:44:16 INFO - TEST-START | toolkit/components/pictureinpicture/tests/browser_disabledForMediaStreamVideos.js
[task 2020-03-13T18:44:24.912Z] 18:44:24 INFO - TEST-INFO | started process screencapture
[task 2020-03-13T18:44:25.072Z] 18:44:25 INFO - TEST-INFO | screencapture: exit 0
[task 2020-03-13T18:44:25.075Z] 18:44:25 INFO - Buffered messages logged at 18:44:16
[task 2020-03-13T18:44:25.076Z] 18:44:25 INFO - Entering test bound test_disabledForMediaStreamVideos
[task 2020-03-13T18:44:25.076Z] 18:44:25 INFO - Waiting for videos to be ready
[task 2020-03-13T18:44:25.079Z] 18:44:25 INFO - Testing video with id: with-controls
[task 2020-03-13T18:44:25.079Z] 18:44:25 INFO - Checking toggle policy
[task 2020-03-13T18:44:25.079Z] 18:44:25 INFO - Buffered messages finished
[task 2020-03-13T18:44:25.079Z] 18:44:25 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/pictureinpicture/tests/browser_disabledForMediaStreamVideos.js | Uncaught exception - Waiting for the hovering state to be set on the video. - timed out after 50 tries.
[task 2020-03-13T18:44:25.079Z] 18:44:25 INFO - Leaving test bound test_disabledForMediaStreamVideos
[task 2020-03-13T18:44:25.079Z] 18:44:25 INFO - GECKO(2352) | MEMORY STAT | vsize 7637MB | residentFast 327MB | heapAllocated 105MB
[task 2020-03-13T18:44:25.080Z] 18:44:25 INFO - TEST-OK | toolkit/components/pictureinpicture/tests/browser_disabledForMediaStreamVideos.js | took 8750ms
[task 2020-03-13T18:44:25.080Z] 18:44:25 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-03-13T18:44:25.080Z] 18:44:25 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/pictureinpicture/tests/browser_disabledForMediaStreamVideos.js | Found an unexpected tab at the end of test run: http://example.com/browser/toolkit/components/pictureinpicture/tests/test-page.html -
[task 2020-03-13T18:44:25.080Z] 18:44:25 INFO - checking window state

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: General → Video/Audio Controls

Hi Mike, retriggers show this started from Bug 1607882, can you take a look?

Flags: needinfo?(mconley)
Regressed by: 1607882
Whiteboard: [retriggered] → [retriggered][stockwell needswork:owner]
Assignee: nobody → rmaries
Status: NEW → ASSIGNED
Attachment #9134880 - Attachment description: Bug 1622391 - Disabled browser_disabledForMediaStreamVideos.js on MacOSX. r?#intermittent-reviewers → Bug 1622391 - Disabled browser_disabledForMediaStreamVideos.js on MacOSX. r=jmaher
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e22a0fbe916e
Disabled browser_disabledForMediaStreamVideos.js on MacOSX. r=jmaher
Whiteboard: [retriggered][stockwell disable-recommended] → [retriggered][stockwell disabled]
Keywords: leave-open

It turns out that I'm going to be fixing this as part of bug 1624702.

Depends on: 1624702
Flags: needinfo?(mconley)
You need to log in before you can comment on or make changes to this bug.