Closed Bug 1624186 Opened 1 year ago Closed 1 year ago

Perma toolkit/components/pictureinpicture/tests/browser_fullscreen.js | Test timed out -

Categories

(Toolkit :: Video/Audio Controls, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1624702
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered][stockwell fixed:patch])

Filed by: cbrindusan [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=294254907&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/NgptL6lrTaqwTQKspdWxKA/runs/0/artifacts/public/logs/live_backing.log


[task 2020-03-22T12:56:45.816Z] 12:56:45 INFO - TEST-START | toolkit/components/pictureinpicture/tests/browser_dblclickFullscreen.js
[task 2020-03-22T12:56:48.683Z] 12:56:48 INFO - GECKO(2774) | MEMORY STAT | vsize 7694MB | residentFast 362MB | heapAllocated 118MB
[task 2020-03-22T12:56:48.684Z] 12:56:48 INFO - TEST-OK | toolkit/components/pictureinpicture/tests/browser_dblclickFullscreen.js | took 2831ms
[task 2020-03-22T12:56:48.684Z] 12:56:48 INFO - checking window state
[task 2020-03-22T12:56:48.684Z] 12:56:48 INFO - TEST-START | toolkit/components/pictureinpicture/tests/browser_fullscreen.js
[task 2020-03-22T12:56:49.260Z] 12:56:49 INFO - GECKO(2774) | JavaScript error: , line 0: TypeError: Fullscreen request denied
[task 2020-03-22T12:57:02.346Z] 12:57:02 INFO - GECKO(2774) | 2020-03-22 12:57:02.329 firefox[2774:36334] Persistent UI failed to open file file:///Users/cltbld/Library/Saved%20Application%20State/org.mozilla.nightly.savedState/window_1.data: No such file or directory (2)
[task 2020-03-22T12:57:33.814Z] 12:57:33 INFO - TEST-INFO | started process screencapture
[task 2020-03-22T12:57:34.017Z] 12:57:34 INFO - TEST-INFO | screencapture: exit 0
[task 2020-03-22T12:57:34.017Z] 12:57:34 INFO - Buffered messages logged at 12:56:48
[task 2020-03-22T12:57:34.018Z] 12:57:34 INFO - Entering test bound
[task 2020-03-22T12:57:34.018Z] 12:57:34 INFO - Buffered messages logged at 12:56:49
[task 2020-03-22T12:57:34.018Z] 12:57:34 INFO - Console message: [JavaScript Warning: "Request for fullscreen was denied because requesting element is not in the currently focused tab." {file: "http://example.com/browser/toolkit/components/pictureinpicture/tests/test-page.html" line: 0}]
[task 2020-03-22T12:57:34.019Z] 12:57:34 INFO - Console message: [JavaScript Error: "TypeError: Fullscreen request denied"]
[task 2020-03-22T12:57:34.019Z] 12:57:34 INFO - Buffered messages finished
[task 2020-03-22T12:57:34.019Z] 12:57:34 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/pictureinpicture/tests/browser_fullscreen.js | Test timed out -

This started to fail after toolkit/components/pictureinpicture/tests/browser_disabledForMediaStreamVideos.js got disabled in bug 1622391 which had been regressed by bug 1607882.

Flags: needinfo?(mconley)
Regressed by: 1622391, 1607882

I suspect this will get fixed once bug 1624702 lands.

Depends on: 1624702
Flags: needinfo?(mconley)
Whiteboard: [retriggered][stockwell disable-recommended] → [retriggered]
Whiteboard: [retriggered][stockwell disable-recommended] → [retriggered][Comment 11]
Summary: Intermittent toolkit/components/pictureinpicture/tests/browser_fullscreen.js | Test timed out - → Perma toolkit/components/pictureinpicture/tests/browser_fullscreen.js | Test timed out -
Duplicate of this bug: 1626948
Flags: needinfo?(mconley)
Whiteboard: [retriggered][Comment 11][stockwell disable-recommended] → [retriggered][Comment 11]

Hi! I'll get them reviewed and landed as soon as possible.

Flags: needinfo?(mconley)

The patches in bug 1624702 should land later today - thanks for your patience.

Whiteboard: [retriggered][Comment 11][stockwell disable-recommended] → [retriggered][stockwell fixed:patch]

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: General → Video/Audio Controls
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Target Milestone: --- → mozilla76
Duplicate of bug: 1624702
You need to log in before you can comment on or make changes to this bug.