Closed Bug 1623355 Opened 5 months ago Closed 3 months ago

Rename Android PGO builds to Android Shippable

Categories

(Firefox Build System :: General, task)

task
Not set
normal

Tracking

(firefox78 fixed)

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: igoldan, Assigned: Callek)

References

Details

Attachments

(10 files, 1 obsolete file)

47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review

Firefox builds are no longer called PGO builds, rather shippable builds.
As all desktop builds have shifted towards this naming convention, so should the Android builds.

See Also: → 1623354

cc a bunch of people. not sure what all depends on the name of the platform; hoping others can chime in.

:igoldan, can you outline what changes need to be made on perf dashboards, tools, etc.

Flags: needinfo?(igoldan)
Product: Firefox for Android → Firefox Build System

I've already started working on this in https://bugzilla.mozilla.org/show_bug.cgi?id=1617484 -- I'm ok with a dupe either way, or merely doing a see-also/need-info between these two.

I know there is work to do to coordinate this at least.

(In reply to Joel Maher ( :jmaher ) (UTC-4) from comment #1)

[...]
:igoldan, can you outline what changes need to be made on perf dashboards, tools, etc.

Regarding my team, I don't think we have to perform any changes. Last pgo/nightly/release -> shippable rename didn't involve any kind of treatment from our side. It only temporary made us blind on perf regressions, for about a day.

Flags: needinfo?(igoldan)

Justin, I see bug 1617484 mostly tackles nightlies. In this bug, we're especially interested in renaming the PGOs from Android.
Thus, I'd say this is a separate bug. Is it something you or someone from your team can pick?

Flags: needinfo?(bugspam.Callek)

Hrm, good point - I intend to do the same piece of work here, (turn PGO into Shippable and use the same jobs for what we ship on nightly) I just didn't get that far yet on the work.

I suppose this bug could be the one to tackle the pgo->use-shippable piece.

Flags: needinfo?(bugspam.Callek)
Blocks: 1614970
Assignee: nobody → bugspam.Callek
Attachment #9146579 - Attachment description: Bug 1623355 - Part 1/X - Rename android pgo tests to -shippable/opt and adjust run-on-platforms to maintain them all running in the same places. → Bug 1623355 - Part 1/6 - Rename android pgo tests to -shippable/opt and adjust run-on-platforms to cope. r=aki
Status: NEW → ASSIGNED
Attachment #9146580 - Attachment description: Bug 1623355 - Part 2 - Point tests based on pgo builds to use shippable builds, needs to remove nightly attribute from android shippable → Bug 1623355 - Part 2/6 - Point tests based on pgo builds to use shippable builds. r=aki
Attachment #9146581 - Attachment description: Bug 1623355 - Part 3 - Rename pgo instrumentation steps to shippable. And make condition profiles use shippable → Bug 1623355 - Part 3/6 - Rename pgo instrumentation steps to shippable. And make condition profiles use shippable. r=aki
Attachment #9146582 - Attachment description: Bug 1623355 - Part 4 - Remove PGO build types → Bug 1623355 - Part 4/6 - Remove Android PGO build types. r=aki
Attachment #9146670 - Attachment description: Bug 1623355 - Part 5 - Set treeherder symbols appropriately for Android Shippable → Bug 1623355 - Part 5/6 - Set treeherder symbols appropriately for Android Shippable. r=aki
Attachment #9146671 - Attachment description: Bug 1623355 - Part 6 - Set new shippable index's → Bug 1623355 - Part 6/6 - Set new shippable index's for Android shippable builds. r=aki

:kats, I see that fpush-linux-android's preset currently runs:

  • "build-android-api-16/debug",
  • "build-android-api-16/opt",
  • "build-android-api-16/pgo",
  • "build-android-x86/opt",
  • "build-android-x86_64/debug",
  • "build-android-x86_64/opt",

Part 4 here removes `build-android-api-16/pgo - do you need that for your f-push preset or should I modify it to include the android-api-16-shippable?

Flags: needinfo?(kats)
See Also: → 1624307

Removing it should be ok. Thanks for checking!

Flags: needinfo?(kats)
Attachment #9146579 - Attachment description: Bug 1623355 - Part 1/6 - Rename android pgo tests to -shippable/opt and adjust run-on-platforms to cope. r=aki → Bug 1623355 - Part 2/8 - Rename android pgo tests to -shippable/opt and adjust run-on-platforms to cope. r=aki
Attachment #9146580 - Attachment description: Bug 1623355 - Part 2/6 - Point tests based on pgo builds to use shippable builds. r=aki → Bug 1623355 - Part 3/8 - Point tests based on pgo builds to use shippable builds. r=aki
Attachment #9146581 - Attachment description: Bug 1623355 - Part 3/6 - Rename pgo instrumentation steps to shippable. And make condition profiles use shippable. r=aki → Bug 1623355 - Part 4/8 - Rename pgo instrumentation steps to shippable. And make condition profiles use shippable. r=aki
Attachment #9146582 - Attachment description: Bug 1623355 - Part 4/6 - Remove Android PGO build types. r=aki → Bug 1623355 - Part 5/8 - Remove Android PGO build types. r=aki
Attachment #9146670 - Attachment description: Bug 1623355 - Part 5/6 - Set treeherder symbols appropriately for Android Shippable. r=aki → Bug 1623355 - Part 6/8 - Set treeherder symbols appropriately for Android Shippable. r=aki
Attachment #9146671 - Attachment description: Bug 1623355 - Part 6/6 - Set new shippable index's for Android shippable builds. r=aki → Bug 1623355 - Part 7/8 - Set new shippable index's for Android shippable builds. r=aki
Pushed by jwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/de5f01ae37fa
Part 1/8 - Add shippable as a valid target for performance test cron targets. r=aki
https://hg.mozilla.org/integration/autoland/rev/dc3076515342
Part 2/8 - Rename android pgo tests to -shippable/opt and adjust run-on-platforms to cope. r=aki
https://hg.mozilla.org/integration/autoland/rev/888df247ba6e
Part 3/8 - Point tests based on pgo builds to use shippable builds. r=aki
https://hg.mozilla.org/integration/autoland/rev/b4ffd5ccbfc7
Part 4/8 - Rename pgo instrumentation steps to shippable. And make condition profiles use shippable. r=aki
https://hg.mozilla.org/integration/autoland/rev/fd76f6bc0797
Part 5/8 - Remove Android PGO build types. r=aki
https://hg.mozilla.org/integration/autoland/rev/87331010321a
Part 6/8 - Set treeherder symbols appropriately for Android Shippable. r=aki
https://hg.mozilla.org/integration/autoland/rev/001eb6623a75
Part 7/8 - Set new shippable index's for Android shippable builds. r=aki
https://hg.mozilla.org/integration/autoland/rev/f94e3f8179a5
Part 8/8 - Remove 'pgo' support from performance testing target tasks. r=aki

This is needed for geckoview signing, since geckoview defaults to 'nightly-autoland' update channel anyway,
and is what we use everywhere on autoland for update channel due to that default, so make taskgraph aware of it.

This patch seems to set the update channel attribute for non shippable builds too, but that aligns with what
happens on central anyway.

See-Also future Bug 1639383 - which may unify the update channels.

Attachment #9147776 - Attachment description: Bug 1623355 - Part 1/8 - Add shippable as a valid target for performance test cron targets. r=aki → Bug 1623355 - Part 2/9 - Add shippable as a valid target for performance test cron targets. r=aki
Attachment #9146579 - Attachment description: Bug 1623355 - Part 2/8 - Rename android pgo tests to -shippable/opt and adjust run-on-platforms to cope. r=aki → Bug 1623355 - Part 3/9 - Rename android pgo tests to -shippable/opt and adjust run-on-platforms to cope. r=aki
Attachment #9146580 - Attachment description: Bug 1623355 - Part 3/8 - Point tests based on pgo builds to use shippable builds. r=aki → Bug 1623355 - Part 4/9 - Point tests based on pgo builds to use shippable builds. r=aki
Attachment #9146581 - Attachment description: Bug 1623355 - Part 4/8 - Rename pgo instrumentation steps to shippable. And make condition profiles use shippable. r=aki → Bug 1623355 - Part 5/9 - Rename pgo instrumentation steps to shippable. And make condition profiles use shippable. r=aki
Attachment #9146582 - Attachment description: Bug 1623355 - Part 5/8 - Remove Android PGO build types. r=aki → Bug 1623355 - Part 6/9 - Remove Android PGO build types. r=aki
Attachment #9146670 - Attachment description: Bug 1623355 - Part 6/8 - Set treeherder symbols appropriately for Android Shippable. r=aki → Bug 1623355 - Part 7/9 - Set treeherder symbols appropriately for Android Shippable. r=aki
Attachment #9146671 - Attachment description: Bug 1623355 - Part 7/8 - Set new shippable index's for Android shippable builds. r=aki → Bug 1623355 - Part 8/9 - Set new shippable index's for Android shippable builds. r=aki
Attachment #9147778 - Attachment description: Bug 1623355 - Part 8/8 - Remove 'pgo' support from performance testing target tasks. r=aki → Bug 1623355 - Part 9/9 - Remove 'pgo' support from performance testing target tasks. r=aki

For shippable builds on non-release branches, mozharness defaults to using
nightly-{project}. The update channel is encoded in the artifact filenames
for non release-channel builds, so update taskgraph to generate the correct
artifact names on non-release branches.

Attachment #9150674 - Attachment description: Bug 1623355: [taskgraph] Set geckoview artifact names to match mozharness on non-release branches; r?Callek → Bug 1623355 - Part 1/9 - Set geckoview artifact names to match mozharness on non-release branches; r?Callek
Attachment #9150652 - Attachment is obsolete: true
Pushed by jwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/07de002afb78
Part 1/9 - Set geckoview artifact names to match mozharness on non-release branches; r=Callek
https://hg.mozilla.org/integration/autoland/rev/0101200826e5
Part 2/9 - Add shippable as a valid target for performance test cron targets. r=aki
https://hg.mozilla.org/integration/autoland/rev/449ec0123902
Part 3/9 - Rename android pgo tests to -shippable/opt and adjust run-on-platforms to cope. r=aki
https://hg.mozilla.org/integration/autoland/rev/4f9f6716d896
Part 4/9 - Point tests based on pgo builds to use shippable builds. r=aki
https://hg.mozilla.org/integration/autoland/rev/7e13b54fdbc4
Part 5/9 - Rename pgo instrumentation steps to shippable. And make condition profiles use shippable. r=aki
https://hg.mozilla.org/integration/autoland/rev/d379d3ebc3f7
Part 6/9 - Remove Android PGO build types. r=aki
https://hg.mozilla.org/integration/autoland/rev/9359e7cd1398
Part 7/9 - Set treeherder symbols appropriately for Android Shippable. r=aki
https://hg.mozilla.org/integration/autoland/rev/a7d4a9064f31
Part 8/9 - Set new shippable index's for Android shippable builds. r=aki
https://hg.mozilla.org/integration/autoland/rev/5190da2e563e
Part 9/9 - Remove 'pgo' support from performance testing target tasks. r=aki
Pushed by btara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/92c11f0bf14b
Followup to Bug 1623355 - Part 1, specifically fix typo in 'nightly'. CLOSED TREE
Regressions: 1640031
Flags: needinfo?(bugspam.Callek)
Regressions: 1640057
No longer regressions: 1640031
Regressions: 1641017

Hello, I filed bug 1641017 for raptor-browsertime regressions. This patch completely disabled those tests everywhere and is a major regression. Please test those run-on-projects changes more closely next time. There are most likely other issues that I haven't found yet as well. #perftest-reviewers should have been a reviewer for this patch, we have tools that we use to prevent these kinds of regressions: https://phabricator.services.mozilla.com/D74306

You need to log in before you can comment on or make changes to this bug.