Closed Bug 1624391 Opened 2 years ago Closed 2 years ago

Integrate Update URL generation, XML download, and XML parsing into the update agent

Categories

(Toolkit :: Application Update, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: bytesized, Assigned: bytesized)

References

Details

Attachments

(5 files, 1 obsolete file)

In other bugs (see this bug's dependencies), we have determined mechanisms for the update agent to generate the update URL, download the update XML, and parse the XML. These mechanisms need to be incorporated into the update agent.

Assignee: nobody → ksteuber
Status: NEW → ASSIGNED

One of the values needed for the update URL is the update channel, which can be read from the app.update.channel pref out of the channel-prefs.js file. These small changes are needed to be able to read the prefs with the prefs_parser crate.

Depends on D69060

Blocks: 1627805
Attachment #9137216 - Attachment is obsolete: true
Pushed by ksteuber@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0b8740e4518a
Code skeleton for integrating update url generation, update XML download, and XML parsing into the update agent r=agashlin,mhowell
https://hg.mozilla.org/integration/autoland/rev/3d101cc73d18
Allow prefs parser pref types and values to be more easily accessed so that we can read a pref value for the update URL r=njn
https://hg.mozilla.org/integration/autoland/rev/177ae9a763de
Add Update URL Generation to the update agent r=agashlin,mhowell
https://hg.mozilla.org/integration/autoland/rev/dfa39b14e0fe
Add XML downloading capability to the update agent r=agashlin,mhowell
https://hg.mozilla.org/integration/autoland/rev/cb0840a3587a
Add capability to parse update XMLs to the update agent r=agashlin,mhowell
Duplicate of this bug: 1567286
Duplicate of this bug: 1614772
Duplicate of this bug: 1614783
You need to log in before you can comment on or make changes to this bug.