Caret still blinks in URL bar after Ctrl+Enter despite loss of focus

RESOLVED DUPLICATE of bug 138963

Status

SeaMonkey
Location Bar
--
major
RESOLVED DUPLICATE of bug 138963
16 years ago
10 years ago

People

(Reporter: Malcolm Scott, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

If you type a URL into the URL bar, then open it in a new tab with Ctrl+T, the
URL bar (correctly) loses focus, but the caret is left blinking in the URL bar,
making it appear that the URL bar still has focus.

Reproducible: Always
Steps to Reproduce:
1. Type a URL into the URL bar.
2. Press Ctrl+T.
3. Notice how the caret is still blinking in the URL bar.
4. Try to type something.

Actual Results:  Text doesn't appear when you type in Step 4, even though it
"looks like" it should do.

Expected Results:  The caret should not blink in the URL bar after Ctrl+T. (The
behaviour where the URL bar loses focus is correct, it's just not reflected
properly in the UI.)

Workaround:  To give the URL bar focus, click anywhere in the page, then click
back in the URL bar. It now works correctly.

----

This bug is highly annoying, since anyone who uses tabbed browsing regularly
will almost certainly have hit this bug.

I am currently reproducing this bug in Windows XP, but I have also seen it occur
in Linux.

Comment 1

16 years ago
I was able to reproduce this bug with my mozilla 1.1b build 2002072204,but step
2 should be "press Ctrl+Enter" because Ctrl+T just opens a new tab and
Cltr+Enter opens the current typed url in a new tab.If you press Cltr+T the
caret blinks and you can indeed type.But with Ctrl+Enter I get the same bug.
(Reporter)

Comment 2

16 years ago
Yes, you're right. I meant to say 'Ctrl+Enter', not 'Ctrl+T'. Sorry.

Comment 3

16 years ago
I corrected the summary (Ctrl+T --> Ctrl+Enter)

This bug possibly depends on bug 147077 or is a duplicate of it.
Summary: Caret still blinks in URL bar after Ctrl+T despite loss of focus → Caret still blinks in URL bar after Ctrl+Enter despite loss of focus
Depends on: 164323

Updated

16 years ago
No longer depends on: 164323
(Reporter)

Comment 4

16 years ago
Since this behaviour is currently very counter-intuitive (I expect the cursor to
be in the URL bar if the caret is there), any chance of a fix soon? For me, it
is probably the most annoying bug I know of.

Comment 5

16 years ago
I noticed this bug occurs in other circumstances related to tabs as well, but
couldn't find another reliable way to reproduce. Will try to find one...

Comment 6

16 years ago
Is this not a duplicate of bug 138963?
(Reporter)

Comment 7

16 years ago
This does seem to be a dupe of bug 138963, although since this bug has a more
meaningful summary (which explains the reasons for the situation, rather than a
symptom), how about marking bug 138963 a dupe of this bug?

Comment 8

15 years ago
Under Mozilla 1.3, build id:
Mozilla/4.0 (compatible; MSIE 5.0; Mac_PowerPC)

The bug still persists.

Also, if ctrl-l is keyed in at this point, no action is taken by the browser. 
The expected situation, ctrl-l, then type a url, places all typing in the
current window, activating the type ahead feature.  As opposed to the address bar.
(Reporter)

Comment 9

15 years ago
Dupe, as per comment 6.

*** This bug has been marked as a duplicate of 138963 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.