Closed Bug 1634386 Opened 5 months ago Closed 1 month ago

The Password Import Autocomplete suggestion is displayed on Linux

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
Linux
defect

Tracking

()

VERIFIED FIXED
81 Branch
Iteration:
81.2 - Aug 10 - Aug 23
Tracking Status
firefox76 --- unaffected
firefox77 --- disabled
firefox78 --- disabled
firefox81 --- verified
firefox82 --- verified

People

(Reporter: vvalentina, Assigned: Mardak)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

Attached image linux.png

[Affected versions]:

  • Firefox Nightly 77.0a1 Build ID 20200429215539;

[Affected Platforms]:

  • Linux Ubuntu 18.04;

[Prerequisites]:

  • Have at least a pair of credentials saved in latest Chrome (i.e for Facebook)
  • In Firefox set “signon.showAutoCompleteImport” pref to “import”

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites.
  2. Open in Firefox the site foe which you saved the credentials.
  3. Click on the username field.
  4. The password autocomplete import suggestion is displayed.

[Expected result]:

  • Nothing should be displayed, because importing passwords is not possible while using Linux.

[Actual result]:

  • The Password Import Autocomplete option is displayed, and the import wizard can be triggered.

[Notes}:

  • Finalizing the wizard will have no effect, and the import suggestion will be re-displayed.
  • The wizard options are correct - don’t contain password options to be imported.

Seems like bug 1513718 is waiting to be fixed as the import suggestion shows that the data is available although the tricky part might be the password decryption. At least for the experiment, we should be able to target it skipping linux or make it windows only.

See Also: → 1513718
Priority: -- → P3
Depends on: 1618311

If we enable by default, we'll need to make sure to not suggest on Linux or fix bug 1513718.

Severity: -- → S2

S1 or S2 bugs need an assignee - could you find someone for this bug?

Flags: needinfo?(tspurway)
Severity: S2 → S3
Flags: needinfo?(tspurway)
Blocks: 1651233
Assignee: nobody → edilee
Iteration: --- → 80.2 - July 13 - July 26
Priority: P3 → P1
Iteration: 80.2 - July 13 - July 26 → 81.1 - July 27 - Aug 09
Iteration: 81.1 - July 27 - Aug 09 → 81.2 - Aug 10 - Aug 23

Share ChromeMigrationUtils.supportsLoginsForPlatform for ChromeProfileMigrator.getResources and ChromeMigrationUtils.getImportableLogins.

Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8c97dd39c9ee
The Password Import Autocomplete suggestion is displayed on Linux r=MattN
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch

I have verified that the issue is no longer reproducible on the latest Beta 81.0b1 (BuildID 20200824150741) and the latest Nightly 82.0a1 (BuildID 20200824215021) on Linux MX 4.19 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.