Closed Bug 1618311 Opened 5 months ago Closed 3 months ago

Contextually suggest importing passwords as an autocomplete entry

Categories

(Toolkit :: Password Manager, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
mozilla77
Iteration:
77.2 - Apr 20 - May 3
Tracking Status
firefox76 --- wontfix
firefox77 --- verified

People

(Reporter: Mardak, Assigned: Mardak)

References

(Blocks 5 open bugs)

Details

(Whiteboard: [passwords:import])

Attachments

(3 files)

We can "pre-import" login data from other browsers to contextually suggest importing when we know there's a password in another browser. We can start with Chrome which happens to get new Edge to work too, so we can show an entry for each and use bug 1618297 to skip the browser selection step.

Bryan, what text, icon, styles and information should we show on each entry?

Blocks: 1618314
See Also: → 1618328
See Also: → 1618330
Iteration: --- → 75.2 - Feb 24 - Mar 8

Moving to 76: waiting for designs and also need to figure out the telemetry we need for a successful experiment design too.

Iteration: 75.2 - Feb 24 - Mar 8 → 76.1 - Mar 9 - Mar 22
Flags: needinfo?(abenson)
Priority: P1 → P2
Iteration: 76.1 - Mar 9 - Mar 22 → 76.2 - Mar 23 - Apr 5
Blocks: 1626689
Iteration: 76.2 - Mar 23 - Apr 5 → 77.1 - Apr 6 - Apr 19

Here's the designs from jsavory: https://mozilla.invisionapp.com/share/W3WST99EHYS

Flags: needinfo?(abenson)

Matching latest design and copy with info icon opening sumo link

The triggering condition to show the import entry:

  • has login saved in chrome for current site
  • has no saved login in firefox for current site
  • profile age is less than 7 days

So after an import, firefox should have a saved login for the site causing the import suggestion to go away. But for a different site, if another browser has a saved login and firefox still doesn't have a saved login, the import suggestion can show again.

The info icon opens up the sumo article from bug 1626689

https://support.mozilla.org/1/firefox/%VERSION%/%OS%/%LOCALE%/password-import (normal url replacing behavior)

which should redirect to

https://support.mozilla.org/en-US/kb/import-data-another-browser

Blocks: 1628849
Depends on: 1629108
Iteration: 77.1 - Apr 6 - Apr 19 → 77.2 - Apr 20 - May 3
Priority: P2 → P1

Add importableLogins autocomplete items that show for a site when there's chromium-based logins, no saved logins, and appropriate experiment state. Default behavior is unchanged with default "" pref value, and new behavior can be turned on with "import" pref value.

Flags: needinfo?(edilee)
See Also: → 888560

jaws, the designs in comment 2 look to be based on those from bug 1601442 updating the overall design of login autocomplete items. The implementation for this bug right now is keeping consistent with the existing styles, but I suppose potentially we'll want to fix bug 1601442 before shipping the experiment.

See Also: → 1601442
Status: NEW → ASSIGNED
Whiteboard: [passwords:import]
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5690715ef70e
Contextually suggest importing passwords as an autocomplete entry r=MattN,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77

This landed differently from previously documented technical plan pref name. You can set signon.showAutoCompleteImport to "import" (without quotes) to turn on the import suggestions. Or set it as "control" where the import suggestions don't show up (and currently shows the login footer). Or leave it empty "" which is the default behavior of not changing autocomplete.

This does not have telemetry yet to be covered in bug 1628849.

Flags: needinfo?(vvirlics)

I've verified this using Firefox Nightly 77.0a1 (Build ID 20200429030514) and Chrome (Version 81.0.4044.129) on Windows 10 x64.

  • If the pref is set to "import": import suggestions are turned on, and work as expected;
  • If the pref is set to "control": import suggestions do not show up, but the "View Saved Logins" footer does, but has no utility;
  • if the pref is set to "": import suggestions do not show up;

Also, while checking the Import Pass Autocomplete behavior, I've observed the following:

  1. Click on “Learn more” button shows a selection action on the entire line;
  2. After import, if the user clicks on password field - the autocomplete action will be made just for password field, if he clicks inside the username field the autocomplete will be made for both fields; I guess this is intended?
    • After the username and pass values are displayed in corresponding fields, clicking again (twice) inside the username field will re-trigger the suggestion - is this ok?
Flags: needinfo?(vvirlics) → needinfo?(edilee)

(In reply to Valentina Virlics [:vvalentina], Ecosystem QA from comment #12)

  1. Click on “Learn more” button shows a selection action on the entire line;

I'll check with design. I think it should be okay although a workaround would be to handle the user clicking the icon on mousedown instead of a whole "click" (waiting for mouseup).

  1. After import, if the user clicks on password field - the autocomplete action will be made just for password field, if he clicks inside the username field the autocomplete will be made for both fields; I guess this is intended?

Yeah, this seems to be the behavior of normal firefox filled passwords although it does seem like a bug to only fill the password. Might be good to track as a general password manager bug if it doesn't exist yet.

 - After the username and pass values are displayed in corresponding fields, clicking again (twice) inside the username field will re-trigger the suggestion - is this ok?

Just making sure, the "suggestion" is the saved password not the new import password? This also seems like the normal firefox behavior for filled passwords. How would you expect this to behave differently?

Flags: needinfo?(edilee) → needinfo?(vvirlics)

(In reply to Ed Lee :Mardak from comment #13)

  1. After import, if the user clicks on password field - the autocomplete action will be made just for password field, if he clicks inside the username field the autocomplete will be made for both fields; I guess this is intended?

Yeah, this seems to be the behavior of normal firefox filled passwords although it does seem like a bug to only fill the password. Might be good to track as a general password manager bug if it doesn't exist yet.

I'll search for an already logged issue, and if I don't find it, will log one.

After the username and pass values are displayed in corresponding fields, clicking again (twice) inside the username field will re-trigger the suggestion - is this ok?

Just making sure, the "suggestion" is the saved password not the new import password? This also seems like the normal firefox behavior for filled passwords. How would you expect this to behave differently?

The suggestion drop down looks like the saved pass. Would expect nothing to happen if I click the username/password field, because I already have both fields filled. But if the normal Firefox behavior is to show up the saved suggestions, I'll expect to trigger them at first click and for both fields.

Flags: needinfo?(vvirlics) → needinfo?(edilee)
Regressions: 1607878
No longer regressions: 1607878

(In reply to Valentina Virlics [:vvalentina], Ecosystem QA from comment #14)

Would expect nothing to happen if I click the username/password field, because I already have both fields filled. But if the normal Firefox behavior is to show up the saved suggestions, I'll expect to trigger them at first click and for both fields.

Yeah that's the normal Firefox behavior of letting the user view saved logins or switch to a different login.

Marking verified per comment 12 and various followups bug 1634386 and bug 1634382.

Blocks: 1634386, 1634382
Status: RESOLVED → VERIFIED
Flags: needinfo?(edilee)
No longer regressions: 1644962
No longer regressions: 1644963
Blocks: 1648171
Blocks: 1648182
See Also: → 1656622
You need to log in before you can comment on or make changes to this bug.