Closed Bug 1636820 Opened 3 months ago Closed 3 months ago

Passwords in about:logins cannot be read or copied on Linux

Categories

(Firefox :: about:logins, defect, P1)

78 Branch
All
Linux
defect

Tracking

()

VERIFIED FIXED
Firefox 78
Tracking Status
firefox-esr68 --- unaffected
firefox75 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 --- verified

People

(Reporter: baron, Assigned: jaws)

References

(Regressed 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

Try to see a password, by clicking the "eye", or copy it by clicking "copy".

Actual results:

Nothing happens. I cannot see the password, and it is not copied.

Expected results:

I should be able to see the password or copy it.

This started yesterday. I just installed the newest version and it still a problem: 78.0a1 (2020-05-10) (64-bit)

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Password Manager
Product: Firefox → Toolkit

Jared, I guess this is a regression from a recent patch.

Severity: normal → S2
Component: Password Manager → about:logins
Flags: needinfo?(jaws)
Keywords: regression
Priority: -- → P1
Product: Toolkit → Firefox

Thank you for the report Jonathan. Would you be able to use the mozregression tool to help us narrow down when this stopped working for you? You can read more about the tool here, https://mozilla.github.io/mozregression/

Flags: needinfo?(baron)
Flags: needinfo?(baron)
Regressed by: 1636032
Duplicate of this bug: 1636981

(In reply to Emilio Cobos Álvarez (:emilio) from comment #2)

I see the following in the Browser Console:

[fluent] Missing translations in en-US: about-logins-copy-password-os-auth-dialog-message-linux. Localization.jsm:202:13
AboutLoginsChild: error recording telemetry event: message.data.telemetryEvent is undefined 2 AboutLoginsChild.jsm:217
    receiveMessage resource:///actors/AboutLoginsChild.jsm:217
    (Async: JSActor query)
    receiveMessage resource:///actors/AboutLoginsParent.jsm:413
    AsyncFunctionNext self-hosted:693
    (Async: async)
    promptForMasterPassword resource:///actors/AboutLoginsChild.jsm:71
    masterPasswordAuth chrome://browser/content/aboutlogins/components/login-item.js:406
    handleEvent chrome://browser/content/aboutlogins/components/login-item.js:405
    (Async: EventListener.handleEvent)
    connectedCallback chrome://browser/content/aboutlogins/components/login-item.js:101
    <anonymous> chrome://browser/content/aboutlogins/components/login-item.js:899
    InnerModuleEvaluation self-hosted:1572
    evaluation self-hosted:1543
TypeError: can't access property "value", messageText is null

Thanks!

OS: Unspecified → Linux
Hardware: Unspecified → All
Summary: passwords in about:logins cannot be read or copied → Passwords in about:logins cannot be read or copied on Linux

(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #3)

Thank you for the report Jonathan. Would you be able to use the mozregression tool to help us narrow down when this stopped working for you? You can read more about the tool here, https://mozilla.github.io/mozregression/

I am 80% sure that it started with the May 9 build. The other 20% is May 8. I don't have time to do this now. But if it isn't resolved soon I will do it tomorrow. (I also note that "edit" doesn't seem to work either.)

(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #3)

Thank you for the report Jonathan. Would you be able to use the mozregression tool to help us narrow down when this stopped working for you? You can read more about the tool here, https://mozilla.github.io/mozregression/

Actually I just now downloaded mozregression for linux, and I cannot find the installation instructions, at least nothing that I understand. However, as I said, I'm sure it hasn't been that long, so I am willing to go through all the recent builds one by one, except that I forgot where to find them. Can you tell me the URL?

If you've downloaded mozregression, you can run it via ./mozregression --good 2020-04-01 and it will download, unpack, and launch the builds for you (starting from April 1st).

Sorry, I wasn't following the earlier comments in this bug. From comment 5 we have figured it out. I'll put up a patch.

Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)

I have managed to reproduce the issue on Ubuntu 18.04 x64. The issue is reproducible for the "Edit", "Show" and "Copy" button. Using the mozregression tools I got the following resuts:

Last good revision: 20a72eb47bd15d7299a968e7ad2c87037db02970
First bad revision: ded8b9faf51640feb36508109cde5e255af68381
Pushlog: link

Looks like Bug 1636032 introduced this bug.
I have attached a screenshot with browser console errors displayed after clicking the "Copy" button.

Duplicate of this bug: 1637421
Duplicate of this bug: 1637368
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/a8491d20ec08
Don't request dialog strings for OS authentication on Linux since the feature isn't supported there yet. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78

Hi,

Sorry but the bug is always here this morning (2020-05-14) on Firefox nighly Debian 10. In the about:logins I can't see the password when I click on the "eye" and I can't copy the password when I click on the "Copier" button (french version)

--
Patrick

Fixes 'Error: reauth is required to either be false or a non-empty string OSKeyStore.jsm:181:13'

Pushed by fbraun@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bcca4b48fc21
Follow-up to also provide a default string for ensureLoggedIn on Linux. r=freddyb

(In reply to pvergain from comment #16)

Hi,

Sorry but the bug is always here this morning (2020-05-14) on Firefox nighly Debian 10.

Should be fixed in your next Nightly. I think our next build kicks off at noon UTC.

Regressions: 1637860

Hello,

It works ! Thank you very much for the work !
I wish you a happy weekend !

--
Patrick

I have verified this issue and is no longer reproducible on the latest Nightly 78.0a1 build (Build ID: 20200517213618). Tested on Ubuntu 18.04 x64.

  • The password can be successfully shown or copied and the login can be edited.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.