Closed Bug 1644624 Opened 1 year ago Closed 11 months ago

Update builders to rustc 1.47

Categories

(Firefox Build System :: Toolchains, task)

task

Tracking

(firefox84 fixed)

RESOLVED FIXED
84 Branch
Tracking Status
firefox84 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

(Blocks 1 open bug)

Details

(Keywords: perf-alert)

Attachments

(4 files, 1 obsolete file)

No description provided.

For the record: this causes build failures on macOS with LTO, due to some change in rustc. This was fixed in recent nightlies, and may be uplifted to 1.45.
1.45 itself uses LLVM 10, and can't be used for cross-LTO until we upgrade to clang 10.

Depends on: clang-10
Summary: Update builders to rustc 1.44 → Update builders to rustc > 1.44

No it wasn't.

(In reply to Mike Hommey [:glandium] from comment #3)

No it wasn't.

Are we fairing any better with 1.45 (https://github.com/rust-lang/rust/blob/master/RELEASES.md#version-1450-2020-07-16)?

In theory, yes, but see comment 1.

Depends on: 1660340

Seeing as bug 1660340 is going to be the basis for future builds, does this imply that Rust 1.46 will target FF82?

It depends. Last time I tried clang 10 and rust 1.45, things didn't go well on multiple platforms, so who knows...

(In reply to Mike Hommey [:glandium] from comment #7)

It depends. Last time I tried clang 10 and rust 1.45, things didn't go well on multiple platforms, so who knows...

And now that things are moving to Clang 11 for FF82, does this also mean it will use the newly minted Rust 1.46?

Same answer as comment 7.

Blocks: 1602810
Depends on: 1670138
Depends on: 1670156
Depends on: 1670163

Status with 1.47: slightly less busted than 1.46 and 1.45, but still busted on PGO and/or LTO.

Blocks: 1671545
No longer blocks: 1661961, 1667736
Summary: Update builders to rustc > 1.44 → Update builders to rustc 1.47
Blocks: 1671555

Also upgrade the ccov builds to clang 11, as they were stuck on clang 9
because of the older version of rust, and the new version of rust
requires to bump clang as well (due to code-coverage-related symbols
name change).

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/ce09ad625b53
Pass LLVM flags from PROFILE_GEN_CFLAGS to the rust compiler. r=firefox-build-system-reviewers,dmajor
https://hg.mozilla.org/integration/autoland/rev/d91db0801099
Optionally postprocess the compiler_builtins rlib when repacking rust. r=firefox-build-system-reviewers,dmajor
https://hg.mozilla.org/integration/autoland/rev/609ac687f7e3
Upgrade builders to rustc 1.47. r=firefox-build-system-reviewers,dmajor
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fee83fc16940
Partially backout changeset 609ac687f7e3 for tsan mochitest bustage. CLOSED TREE
Regressions: 1672094
Blocks: 1672092

(In reply to Pulsebot from comment #16)

Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fee83fc16940
Partially backout changeset 609ac687f7e3 for tsan mochitest bustage. CLOSED
TREE

== Change summary for alert #27265 (as of Mon, 19 Oct 2020 23:17:08 GMT) ==

Regressions:

Ratio Suite Test Platform Options Absolute values (old vs new)
0.35% installer size osx-cross 79,953,855.50 -> 80,235,054.25

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=27265

(In reply to Cosmin Sabou [:CosminS] from comment #17)

Backed out for windows shippable bustage.

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=windows%2C2012%2Cshippable%2Copt%2Cprofile-guided%2Coptimization%2Cbuilds%2Cbuild-win32-shippable%2Fopt%2Cb&revision=609ac687f7e38023eae03bad472b1632d7d04768&selectedTaskRun=HhzwwPv4SYKs9QiZ0iVbDw.0

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=319085043&repo=autoland

Backout link: https://hg.mozilla.org/integration/autoland/rev/9a2598a10e2234fd475706330cd468acca9338ed

== Change summary for alert #27269 (as of Tue, 20 Oct 2020 06:22:16 GMT) ==

Improvements:

Ratio Suite Test Platform Options Absolute values (old vs new)
0.29% installer size osx-cross 80,171,167.75 -> 79,939,072.42

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=27269

Depends on: 1672306
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/1edadabf402b
Pass LLVM flags from PROFILE_GEN_CFLAGS to the rust compiler. r=firefox-build-system-reviewers,dmajor
https://hg.mozilla.org/integration/autoland/rev/6c886dc65188
Optionally postprocess the compiler_builtins rlib when repacking rust. r=firefox-build-system-reviewers,dmajor
https://hg.mozilla.org/integration/autoland/rev/5711df59da63
Upgrade builders to rustc 1.47. r=firefox-build-system-reviewers,dmajor
Flags: needinfo?(mh+mozilla)
Pushed by btara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a6b912aecb35
Apply the compiler_builtins hack to aarch64-linux-android too. CLOSED TREE
See Also: → 1672499
Keywords: perf-alert
Attachment #9182525 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.