Open Bug 1616692 (clang-10) Opened 5 months ago Updated 3 days ago

[meta] Upgrade to clang 10.0.0

Categories

(Firefox Build System :: Toolchains, task, P3)

task

Tracking

(Not tracked)

People

(Reporter: dmajor, Assigned: dmajor)

References

(Depends on 4 open bugs, Blocks 2 open bugs, Regressed 2 open bugs)

Details

(Keywords: meta)

Attachments

(1 file)

47 bytes, text/x-phabricator-request
Details | Review

This is a meta bug tracking work related to using clang 10.0.0 in automation.

I am not proposing that we actually make the switch yet; this bug is just for tracking related work.

Keywords: meta
See Also: → build-clang-trunk
Summary: Upgrade to clang 10.0.0 → [meta] Upgrade to clang 10.0.0
Depends on: 1617216
Depends on: 1619165

Hey glandium; if we bump to clang 10 we can start testing Control Flow Guard on Windows which would be some free mitigations. Is that okay with you?

Flags: needinfo?(mh+mozilla)

Why would it not? If upgrading doesn't break anything...

Flags: needinfo?(mh+mozilla)

it is the soft freeze, so, we should probably wait until it is over :)
(until may 4th)

I can take this. Between testing and review time I expect this will go past soft freeze anyway.

Assignee: nobody → dmajor
Depends on: 1634523
Depends on: 1631929
Depends on: 1634949
Depends on: 1635933
Depends on: 1636542
Attached file Update to clang 10.0.0
Pushed by dmajor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7340fb8c2297
Update to clang 10.0.0 r=froydnj
Pushed by dmajor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/58cbc2929fb3
followup, fix sccache task bustage. CLOSED TREE
Flags: needinfo?(dmajor)
Regressions: 1637503
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Depends on: 1637682

As they are tier-2, I don't think we should.
David should be also involved in the potential backout (or not)

Flags: needinfo?(dmajor)

Let's keep it in tree. Bug 1638409 tracks the regression.

Flags: needinfo?(dmajor)
Flags: needinfo?(aryx.bugmail)
Regressions: 1638409

David, can we back out for now. The regressions are piling up and it looks like Windows-on-ARM is completely broken. We don't have time or bandwidth to reasonably triage and fix all the issues before the next release, particularly given our reliance on upstream LLVM addressing all the issues.

Flags: needinfo?(dmajor)
Depends on: 1639318
Backout by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1a79875b2cf6
Backed out changeset 80ba3f3cfaf9 at dev's request. CLOSED TREE
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c17af0632260
Update to clang 10.0.0 r=froydnj

(In reply to Dorel Luca [:dluca] from comment #18)

Had to reland this one because it was causing perma leaks failures on WPT:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=303020348&repo=autoland&lineNumber=7376

TH:
https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=1a79875b2cf67e3539939f7002b3e5ba5ceccd79&selectedTaskRun=RhubQ4IbQ4mNixEzfRbsAw-0

dmajor: Please take a look at this ^

Please back this out again, it fixes several issues that are more important than a leak on Linux (it is almost certainly not the cause of the leak). Aarch64-windows is completely broken right now.

Flags: needinfo?(dluca)

(In reply to Pulsebot from comment #16)

Backout by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1a79875b2cf6
Backed out changeset 80ba3f3cfaf9 at dev's request. CLOSED TREE

== Change summary for alert #25997 (as of Wed, 20 May 2020 00:21:28 GMT) ==

Regressions:

2% compiler_metrics num_static_constructors windows2012-64-shippable opt instrumented 128.00 -> 131.00
0.45% installer size osx-shippable opt instrumented 117,582,479.50 -> 118,112,308.25
0.26% installer size osx-shippable opt nightly 84,432,802.17 -> 84,655,979.50

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=25997

(In reply to Pulsebot from comment #17)

Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c17af0632260
Update to clang 10.0.0 r=froydnj

== Change summary for alert #26000 (as of Wed, 20 May 2020 02:48:23 GMT) ==

Improvements:

1% compiler_metrics num_static_constructors windows2012-64-shippable opt instrumented 129.88 -> 128.00

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=26000

I have a bisect in progress on try to figure out where the leak comes from. But right now tests are not starting, so this will take more time.

See Also: → 1639519
Flags: needinfo?(dmajor)

jgraham: We upgraded CI to clang 10 last week, but had to backout and restore clang 9 yesterday, and that uncovered a LeakSan failure in WPT.

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=303020348&repo=autoland&lineNumber=7376

Could it be related to bug 1636118, which landed during the period of clang 10? I'm thinking the most likely explanation is that the inlining changed between clang 9 and 10, in such a way that something on the lsan-allowed list no longer matches.

Flags: needinfo?(james)

On second thought, now that the LSan failure has its own bug, let's move that discussion to bug 1639519.

Flags: needinfo?(james)

== Change summary for alert #26016 (as of Wed, 20 May 2020 16:36:21 GMT) ==

Improvements:

8% about_newtab_with_snippets linux64-shippable opt e10s stylo 86.06 -> 79.01
8% perf_reftest_singletons id-getter-2.html windows10-64-shippable opt e10s stylo 750.89 -> 693.22
5% tsvgx windows7-32-shippable opt e10s stylo 130.05 -> 124.00
4% tsvgr_opacity linux64-shippable-qr opt e10s stylo 109.96 -> 105.35
3% tsvgr_opacity linux64-shippable opt e10s stylo 153.70 -> 148.56
3% tp5o_scroll linux64-shippable opt e10s stylo 1.28 -> 1.24

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=26016

== Change summary for alert #26003 (as of Wed, 20 May 2020 04:36:26 GMT) ==

Improvements:

10% build times windows2012-aarch64 opt aarch64-no-eme nightly taskcluster-c5d.4xlarge 2,427.68 -> 2,187.97
9% build times linux64-shippable opt nightly taskcluster-c5.4xlarge 3,201.86 -> 2,910.93
9% build times windows2012-64-shippable opt nightly taskcluster-m5.4xlarge 2,609.49 -> 2,373.64
9% build times windows2012-32-shippable opt nightly taskcluster-c5d.4xlarge 2,472.63 -> 2,262.24
7% build times linux64-shippable opt nightly taskcluster-m5.4xlarge 3,194.27 -> 2,980.91
7% build times osx-shippable opt nightly taskcluster-c5d.4xlarge 3,133.88 -> 2,927.06
6% build times linux64-shippable opt nightly taskcluster-c5d.4xlarge 2,990.06 -> 2,804.88

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=26003

== Change summary for alert #26020 (as of Wed, 20 May 2020 19:48:03 GMT) ==

Improvements:

33% raptor-tp6-outlook-firefox-cold replayed windows7-32-shippable opt 1,393.12 -> 1,852.92
4% raptor-tp6-facebook-firefox-cold not-replayed windows7-32-shippable opt 346.67 -> 331.17
3% raptor-tp6-wikipedia-firefox-cold loadtime windows7-32-shippable opt 1,511.79 -> 1,466.25
3% raptor-tp6-netflix-firefox-cold fcp linux64-shippable-qr opt 624.38 -> 606.92
3% raptor-tp6-wikipedia-firefox-cold fcp windows7-32-shippable opt 1,350.33 -> 1,314.33
3% raptor-tp6-outlook-firefox-cold loadtime linux64-shippable opt 843.04 -> 821.67
2% raptor-tp6-sheets-firefox-cold loadtime linux64-shippable-qr opt 1,650.50 -> 1,617.42

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=26020

Status: REOPENED → NEW
Target Milestone: mozilla78 → ---

While the patch was on autoland, it seems it also regressed most devtools performance tests: https://treeherder.mozilla.org/perf.html#/alerts?id=25964

Depends on: 1641674

It would seem that some of these issues are fixed in the upcoming CLANG 10.0.1 release. Is the intent to hold off until FF80?

You need to log in before you can comment on or make changes to this bug.